Jump to content



Photo

WD My Book Elite with WD20EADS 2TB - lost partition


  • Please log in to reply
8 replies to this topic

#1 insanelyapple

insanelyapple

    Neowinian

  • Joined: 23-December 06
  • Location: Biggest village in Europe

Posted 20 June 2011 - 09:24

I really hope that someone will help me.

I have a WD My Book Elite with WD20EADS 2TB
iside, connected via USB.


While copying a circa about 3GB iso file to the above metioned drive, at around 70-80% Vista just hung - everything, even desktop/explorer.exe went "not responding" and dimmed. I just unplugged the power from the surge protector and then did a hard reset (by pressing the button on the case ; and yes, i realise that was really bad and stupid lol).

After booting the OS, the disk didn't show up in the Computer window, so i opened Disk Management and it asked me to initialize the disk and gave me a choice between GPT and MBR (i didnt choose anything) - the whole 2TB is marked as unallocated space.

I took the disk out of WD's casing and connected it to my PC via the standard internal SATA interface and tried to use various programs to recover lost partition (Find and Mount, MiniTool programs, TestDisk, PC Inspector File Recovery, an Acronis tool is now scanning the disk as I type); none of them were able to scan the whole drive at any pace even remotly approaching sanity thus far - MiniTool managed to scan 3% of the drive in quick mode after 10hrs with 300hrs to go.

SMART status seems to be ok. Im pretty sure that all data is avaiable but MBR/partition information is somehow, purged.

So, what should I do now? Let Acronis scan disk, initialize it then scan, initialize it, format and try to recover files?


#2 +PeterUK

PeterUK

    Neowinian Senior

  • Tech Issues Solved: 5
  • Joined: 26-March 07

Posted 20 June 2011 - 11:14

Try using the wizard for partition recovery in EASEUS Partition Master.
http://www.partition...om/personal.htm

When you look at the drives circuit board do you see any burn marks?

#3 articuno1au

articuno1au

    Neowinian Senior

  • Tech Issues Solved: 2
  • Joined: 20-March 11
  • Location: Brisbane, Australia

Posted 20 June 2011 - 11:15

It sounds like there is something wrong with the disk if that's the case :|

It might not be recoverable.

#4 OP insanelyapple

insanelyapple

    Neowinian

  • Joined: 23-December 06
  • Location: Biggest village in Europe

Posted 21 June 2011 - 09:35

There is no sign of burning, i didn't notice any smoke or something... I just unplugged power from My Book - that's all lol.

Anyway, i've initialized disk in EASEUS and instead of one long partition there are now 4-5 partitions (it depends on program that is actually running, but Windows Disk Managment shows only one partition). And i'm trying to scan O&O Disk Recovery whole disk in search for lost files; after scanning ~170GB and 11hrs, 11 files found so far

#5 sach2

sach2

    Resident One Post Wonder

  • Joined: 09-September 11

Posted 09 September 2011 - 04:20

Hi,

Insanelyapple, I have the exact same symptoms.

Did any partition or recovery software work to read the old files? I've tried just about everyone except Easeus.

What exactly did initializing the disk do for you? Did it make it more likely for partition recovery?

Thanks for anything you can remember from your situation. :)

#6 Sir Topham Hatt

Sir Topham Hatt

    A Very Talented Individual

  • Tech Issues Solved: 1
  • Joined: 02-November 03
  • Location: Island of Sodor, UK

Posted 09 September 2011 - 10:56

I had an external 1Tb WD disk loose it's index table once, but the situation sounds similar.
My PC was fine, but one time when plugging in the disk, it just asked me to format it. I did a quick format which was alright, then used Aaseus (I think) to recover the data to another disk. Seems fine now and this was well over a year ago. It's been my only problem with a WD drive.

#7 titanpi

titanpi

    Resident One Post Wonder

  • Joined: 17-June 13

Posted 17 June 2013 - 21:58

I had a similar problem with a 2tb Mybook. What I discovered is that the mybook disk format and partition information is contained on the board with the SATA bridge inside the enclosure. This is why partition recovery does NOT WORK in this case. I tested this by buying a similar MyBook version and looking at the disk structure while in the enclosure and after it was removed from the enclosure. The result is without accessing the drive through the enclosure, the drive will appear as all unallocated space and disk management will view it as not initialized and not formatted. SOLUTION - (1) Buy a similar version of your Mybook ( I suggest if you need an older MyBook - go to a small mom & pop computer store). (2) Take the new Mybook apart (careful it's only 4 little plastic clasps inside the enclosure. (3) Swap your old MyBook drive for the new MyBook Drive. (4) Plug & Play, you'll find all your files intact and accessible.

RECOMMENDATION - Copy everything over to a ANYTHING BUT a MyBook. Throw away MyBook and get a hard drive enclosure that does not hold disk format, partition, or anything else on an intermediary board. This was a bit of a ripoff because it seems like lots of people have had this problem. Western Digital will not sell you the board, but they will sell you their data recovery services (which probably involves the same steps I just shared for an additional minimum of $500.00



#8 roguekiller23231

roguekiller23231

    Neowinian

  • Tech Issues Solved: 1
  • Joined: 26-March 11

Posted 18 June 2013 - 02:06

this is going to be a nightmare if you are going to recover through USB, because instead of taking 24 hours it will take 4-5 weeks.

 

i have never had to do this when recovering a patrician, but it should work just the same, do a 'quick format' and GDP if it's a none boot drive.

 

dont add any files or folders to the drive.

 

once the drive is accessible (i seriously suggest you take it out of the enclosure and use it in a PC) you will need to have another drive to save the recovered files to.

 

Recuva

http://www.piriform.com/recuva

 

run this, do a 'deep scan' (which will take 1-2 hours usually, on USB 2.0 much much longer) i'm not sure if it's still default on, but you can in the options recover file paths.

 

once the deep scan is complete, it will show you a list of all recoverable files and the chances of recovering the whole file.

 

you will need to select which files you are going to recover, and save them to another drive.

 

this is also a slow process, can take 24 hours if you are recovering the whole 2TB.

 

Edit_

 

http://www.piriform....formatted-disks

 

Recuva suggests that it will recover from formatting.



#9 goatsniffer

goatsniffer

    Supercalifragilisticexpialidosh

  • Joined: 11-January 04
  • Location: New York, USA

Posted 23 June 2013 - 06:33

MyBooks suck. Once you get your data back, just get a standard desktop hard drive and a good solid external enclosure. Rosewill makes a great one.