Jump to content



Photo

[uTorrent] Disk overloaded 100%.. ?


  • Please log in to reply
20 replies to this topic

#1 Harreh

Harreh

    Neowinian Senior

  • Joined: 18-May 05
  • Location: Manchester, England.

Posted 13 September 2011 - 14:39

So I'm trying to download a torrent here and I couldn't help but notice that my dl speed was running at 10Kb/s instead of the usual 2MB/s.
Now, when I re-start uTorrent my dl speeds steadily climbs but then dwindles back down to 10KB/s.

I thought perhaps my ISP is throttling me but then I noticed something at the bottom in the status bar which reads "Disk overloaded 100%".
Also uTorrent is consuming a steady 50% of CPU usage and doesn't terminate when I close uTorrent.

Any ideas?


#2 Andrew Hogwood

Andrew Hogwood

    Resident One Post Wonder

  • Joined: 13-September 11

Posted 13 September 2011 - 14:48

So I'm trying to download a torrent here and I couldn't help but notice that my dl speed was running at 10Kb/s instead of the usual 2MB/s.
Now, when I re-start uTorrent my dl speeds steadily climbs but then dwindles back down to 10KB/s.

I thought perhaps my ISP is throttling me but then I noticed something at the bottom in the status bar which reads "Disk overloaded 100%".
Also uTorrent is consuming a steady 50% of CPU usage and doesn't terminate when I close uTorrent.

Any ideas?


Google is your friend:

http://banglagamer.c...-uTorrent-Guide

#3 OP Harreh

Harreh

    Neowinian Senior

  • Joined: 18-May 05
  • Location: Manchester, England.

Posted 13 September 2011 - 14:55

:rolleyes:

Yes, everything that I've tried that Google has offered me has not solved this issue.

From this to this.

edit: Although, the first option did reduce it from 100% to 87%. The issue still remains however.

#4 Stup0t

Stup0t

    Neowinian

  • Joined: 08-August 07
  • Location: UK
  • OS: Windows 8.1 Pro x64
  • Phone: Nokia Lumina 520

Posted 13 September 2011 - 15:00

Happened to me, tried all the fixes and nothing worked. So changed to a different client and all is working again.

Using qBitorrent at the moment.

#5 Sir Topham Hatt

Sir Topham Hatt

    A Very Talented Individual

  • Tech Issues Solved: 1
  • Joined: 02-November 03
  • Location: Island of Sodor, UK

Posted 13 September 2011 - 15:35

Have you tried reducing the amount of connections uTorrent has?
For each torrent and overall?
Try setting a speed which is half of your total download internet connection.
Ensure nothing else is running on the internet.
Ensure nothing else is running from the hard drive to which you are downloading.

These are my only pointers I can think of.
The 100% overload is exactly that. I get this when uTorrent finds a seeder which is seeding at a speed that my PC can't really keep up.

#6 Jason S.

Jason S.

    Neowinian Senior

  • Tech Issues Solved: 4
  • Joined: 01-September 03
  • Location: Cleveland, Ohio

Posted 13 September 2011 - 15:38

i get this message occasionally w/ uTorrent. it'll say "overloaded 100%" but then slowly dwindles back down to 0% where all my torrents speed up again. ive never bothered to care about it since it seems to fix itself :shrug:

#7 Nagisan

Nagisan

    Neowinian Senior

  • Tech Issues Solved: 1
  • Joined: 02-June 06

Posted 13 September 2011 - 15:44

Happened to me, tried all the fixes and nothing worked. So changed to a different client and all is working again.

Using qBitorrent at the moment.

I think I'm going to give qBittorrent a try....I have been having a recent problem (didn't have it a week ago) where uTorrent will hang for 30-90 seconds, completely unresponsive, then suddenly come back to life like nothing ever happened. I have tried reinstalling uTorrent both with manually removing settings and leaving settings there, as well as with no torrents at all. It has happened when I attempt to open uTorrent from the system tray, attempted to add a torrent, delete a torrent, change the options, etc.....pretty much any action (and even no action at all) can cause it to hang for awhile. No clue what happened but uTorrent doesn't seem to be worth a crap anymore.

My personal suggestion if the normal (google) results do not fix your issue is to look for another torrent client, uTorrent IMO is nothing like it was a year ago, it is still a good client, but its not worth a crap when it doesn't work right for you.

#8 Hum

Hum

    totally wAcKed

  • Tech Issues Solved: 5
  • Joined: 05-October 03
  • Location: Odder Space
  • OS: Windows XP, 7

Posted 13 September 2011 - 15:46

How many completed files are you sharing ?

I have to pause other files to get the fastest download for the file I want.

Did you set bandwidth to high priority ?

I sometimes get a boost when I right-click and hit Update Tracker.

And if I Exit BitTorrent, I usually have to disconnect the Net connection to get the program to stop uploading.

#9 x9248

x9248

    Neowinian

  • Joined: 30-December 06
  • Location: USA

Posted 13 September 2011 - 15:52

Why would you disable disk cache? You want cache if your disk is overloading...

Anyways, under those same options you can try disabling "Write out finished pieces immediately". This way pieces will write periodically to the HDD rather than all at once if you are downloading too fast for your HDD to keep up.

I've moved onto qbittorrent tho, as others have mentioned I'd recommend you do the same.

#10 Davo

Davo

    Neowinian

  • Joined: 15-September 06

Posted 13 September 2011 - 15:54

Do you have it set to pre-allocate files? If so, it's trying to create everything at once and slowing down the actual write operations as it tries to create the "imaginary' space.

#11 dknm

dknm

    Neowinian

  • Joined: 04-April 10
  • Location: UK

Posted 13 September 2011 - 15:55

It's normal for this to happen when you first start a download, as files are being allocated to the hdd at a speed that saturates its buffer (typically 32-64 MB for 3.5"). You can manually override the disk cache to some value that can keep up with your downstream till a point ( it doesn't help when maxing out a 100 Mbit connection)

Give it 3 minutes max and your speed will come up again.



#12 Vice

Vice

    Bye!

  • Joined: 03-September 04

Posted 13 September 2011 - 15:55

In uTorrent go to Options in the top menubar. Then select Preferences. Down in the bottom left of the Preferences menu expand the bit that says Advanced and then click on Disk Cache.

In here click the box that says "Override automatic cache size and specify the size manually (MB):"


In the box write in 1/4th of your RAM amount. So if you have 4GB of RAM, put in 1024. If you have 2GB of RAM put in 512.

Also tick these boxes:

Reduce Memory usage when the cache is not needed

Enable caching of disk writes
- Write out finishes pieces immediately

Enable caching of disk reads
- Remove old blocks from the cache
- Increase automatic cache size when cache thrashing

Disable Windows caching of disk writes
Disable windows caching of disk reads

This should stop your Disk 100% issues.

#13 OP Harreh

Harreh

    Neowinian Senior

  • Joined: 18-May 05
  • Location: Manchester, England.

Posted 13 September 2011 - 16:34

Have you tried reducing the amount of connections uTorrent has? Yep. I have this in-place as per personal preference anyway.
For each torrent and overall? Only got this one torrent running.
Try setting a speed which is half of your total download internet connection. Tried that.. speed goes up then back down
Ensure nothing else is running on the internet. Check.
Ensure nothing else is running from the hard drive to which you are downloading. Check.

These are my only pointers I can think of.
The 100% overload is exactly that. I get this when uTorrent finds a seeder which is seeding at a speed that my PC can't really keep up.



How many completed files are you sharing ? I've only got this one torrent running which is set to download only one file (which is naturally incomplete).

I have to pause other files to get the fastest download for the file I want. Yeah I try to run one torrent at a time.

Did you set bandwidth to high priority ? Not tried this, although it feels like a shot in the dark.

I sometimes get a boost when I right-click and hit Update Tracker. Tried that and didn't help.

And if I Exit BitTorrent, I usually have to disconnect the Net connection to get the program to stop uploading.


Why would you disable disk cache? You want cache if your disk is overloading... That's what I thought.. didn't really like the answers Google came up with so came here...

Anyways, under those same options you can try disabling "Write out finished pieces immediately". This way pieces will write periodically to the HDD rather than all at once if you are downloading too fast for your HDD to keep up. I find it hard to believe that a 2MB/s (Megabytes per second) is 'too fast'.

I've moved onto qbittorrent tho, as others have mentioned I'd recommend you do the same. Think I will change my client. Really not a fan of 3.0


Do you have it set to pre-allocate files? If so, it's trying to create everything at once and slowing down the actual write operations as it tries to create the "imaginary' space.


I do have that option on. I'll experiment with that.

It's normal for this to happen when you first start a download, as files are being allocated to the hdd at a speed that saturates its buffer (typically 32-64 MB for 3.5"). You can manually override the disk cache to some value that can keep up with your downstream till a point ( it doesn't help when maxing out a 100 Mbit connection)

Give it 3 minutes max and your speed will come up again.


I'm aware of this and I've had the torrent running for a fair amount of time.


And finally:
@Vice: I'll check that out shortly.


Currently I'm running a defrag (default W7 defragger). It said it was 1% fragmented and it's currently taking time on Pass 7: Consolidation.


Thanks for all the lovely replies Neowin! I'll check out the suggestions once this defrag is complete.

#14 OP Harreh

Harreh

    Neowinian Senior

  • Joined: 18-May 05
  • Location: Manchester, England.

Posted 13 September 2011 - 17:57

In uTorrent go to Options in the top menubar. Then select Preferences. Down in the bottom left of the Preferences menu expand the bit that says Advanced and then click on Disk Cache.

In here click the box that says "Override automatic cache size and specify the size manually (MB):"


In the box write in 1/4th of your RAM amount. So if you have 4GB of RAM, put in 1024. If you have 2GB of RAM put in 512.

Also tick these boxes:

Reduce Memory usage when the cache is not needed

Enable caching of disk writes
- Write out finishes pieces immediately

Enable caching of disk reads
- Remove old blocks from the cache
- Increase automatic cache size when cache thrashing

Disable Windows caching of disk writes
Disable windows caching of disk reads

This should stop your Disk 100% issues.


This seems to have resolved my issue, nice one!

Still gonna look into a different client though... 50% usage constantly just isn't on (even when it's just idling with no torrent running...).

#15 OP Harreh

Harreh

    Neowinian Senior

  • Joined: 18-May 05
  • Location: Manchester, England.

Posted 13 September 2011 - 18:18

This seems to have resolved my issue, nice one!


Guess I spoke too soon.


Also, some strange stats:

In the downloaded column, it says it's done 790MB.
Yet on the info tab, it says it's done 514MB.
And also on the info tab it says I have 0 pieces and indeed there is no file created. In the folder there's a uTorrent part .dat file which is 280KB.

Proper confusing...



Click here to login or here to register to remove this ad, it's free!