Jump to content



Photo

Windows 8 CP and Gaming (Or, Why Won't My Games Work?!)


  • Please log in to reply
53 replies to this topic

#46 funkydude

funkydude

    Neowinian

  • Joined: 18-March 11
  • OS: Windows 8, Xubuntu, Mint (cinnamon)

Posted 17 June 2012 - 15:09

Still can't play LA Noire. I've seen that it seems it doesn't detect properly the video card, because I would usually receive a message about how many cores or threads (dunno remember well) I want running.


Are you using the special Windows 8 GPU drivers for whatever card you have?


#47 Jmixmaster

Jmixmaster

    Neowinian

  • Joined: 21-August 10

Posted 04 August 2012 - 10:27

Sorry to bump, but I have found that The Sims 2 does not install on Windows 8. You can't even get past the directory selector for the base game. This makes me sad but oh well :(

However, SimCity 4 does work.

#48 OP Darrian

Darrian

    The Apathetic

  • Tech Issues Solved: 1
  • Joined: 22-October 01

Posted 04 August 2012 - 10:31

Well, that's interesting. However, I made this thread when the community preview was the latest version we were all playing with. Are you using the newly leaked RTM? Also, have you tried running the Sims 2 setup.exe as administrator? I don't happen to have that game so I can't try it myself.

#49 Jmixmaster

Jmixmaster

    Neowinian

  • Joined: 21-August 10

Posted 04 August 2012 - 10:46

No, I'm running the RP, however I am going to take advantage for the $40 upgrade offer for the RTM. But yes, I've tried to run it in compatibility mode all the way from XP SP2 to Windows 7. Tried with Run as administrator too. It seems as though the installer does not like a part of W8 or possibly W8 doesn't like the installer :p When I try to click next, the window just refreshes itself, and goes back to the "Select Install Destination" folder. I can't even click the cancel button to close the installer, I have to use task manager to kill it. However, it has never started installing anything so no damage is done by doing that

#50 winter_winds

winter_winds

    Resident One Post Wonder

  • Joined: 12-August 12

Posted 12 August 2012 - 02:17

Hi, i new here :)

i'am using Leaked RTM windows 8 enterptise 64 bit

stil game with GWFL not work....:(

i was tried :

SF VI AE, SF X TEKKEN (crashed),
GTA IV, EFLC, DiRT Showdown (GFWL do not show up, even i press HOME button)
DiRT3 (not run at all)


~Sorry for my bad english~

#51 hagjohn

hagjohn

    Neowinian Senior

  • Joined: 20-July 03
  • Location: Pennsylvania
  • OS: Windows 8.1
  • Phone: Nokia Yellow 1020 w/ 8.1

Posted 12 August 2012 - 02:21

I haven't had any issues with any games I've played.

#52 aionaddict

aionaddict

    Neowinian

  • Joined: 15-August 02

Posted 12 August 2012 - 02:24

Aion 64 bit still won't load on the RTM build.

#53 sweety141

sweety141

    Resident One Post Wonder

  • Joined: 14-September 12

Posted 14 September 2012 - 10:53

hey guysss i also stuck .., in my lap also not wrking gamess .,l iam also having windows 8 /. and in my lap skyrim is not wrking
can yu any guyss help me ???

#54 fablink

fablink

    Resident One Post Wonder

  • Joined: 04-October 12

Posted 04 October 2012 - 09:12

Hi,

For the problem with GFWL, in particular with SSF4:AE. The problem was fix when i create a local account and not my Microsoft account.

Sorry for my English