Jump to content



Photo

Android built in email app and Exchange

android exchange native email app motorola

  • Please log in to reply
15 replies to this topic

#1 D!ABOL!C

D!ABOL!C

    Neowinian Senior

  • Joined: 06-April 03
  • Location: North Carolina
  • OS: Windows 8.1 and OSX 10.9.3
  • Phone: HTC One (M8) Android 4.4.2

Posted 02 April 2012 - 19:24

I'm just checking to see if i'm the only one, as this is kind of annoying.

I have a Droid X and one of the other guys I work with has a Droid 4. We are able to set up our Exchange email account using the native email app on our phones and we can receive mail fine. However if we try to send an email we get a connection failed. We both have the latest version of our Android OS. The alternative we are using is the Touchdown App.

Another person that works with us has an HTC Incredible. They are able to use the native app fine.

Now i'm guessing that since the X and the 4 are not working, it is a Motorola thing. I just wanted to confirm if other people are having this issue.

Some extra info. We are on Exchange 2010 and we are using a Squid box for authentication.

Any insight would be fantastic. Thank you.


#2 Geoffrey B.

Geoffrey B.

    LittleNeutrino

  • Tech Issues Solved: 9
  • Joined: 25-July 05
  • Location: Ohio
  • OS: Windows 8.1u1
  • Phone: Nokia Lumia 928 WP8.1u1

Posted 02 April 2012 - 19:31

I do not have any problems with the native Android Mail app sending or receiving from Exchange 2010

#3 OP D!ABOL!C

D!ABOL!C

    Neowinian Senior

  • Joined: 06-April 03
  • Location: North Carolina
  • OS: Windows 8.1 and OSX 10.9.3
  • Phone: HTC One (M8) Android 4.4.2

Posted 02 April 2012 - 19:33

Do you have a Motorola phone?

#4 cybertimber2008

cybertimber2008

    Neowinian Senior

  • Joined: 02-December 08

Posted 02 April 2012 - 19:45

My coworker has the motorola electrify and connects to our exchange 2010 server just fine (just asked him).
logcat!

Edit: Can you walk us through the steps you took to create the account on the phone? screenshots help, and you can blur out the unnecessary parts. I'm wondering if it was created in a particular way which does commonly cause problems with outgoing email.

Edit edit: A "squid" box? What's that? Do you mean the linux squid proxy server?

Edited by cybertimber2008, 02 April 2012 - 20:06.


#5 Geoffrey B.

Geoffrey B.

    LittleNeutrino

  • Tech Issues Solved: 9
  • Joined: 25-July 05
  • Location: Ohio
  • OS: Windows 8.1u1
  • Phone: Nokia Lumia 928 WP8.1u1

Posted 02 April 2012 - 20:00

Do you have a Motorola phone?

Yes I have a Motorola Droid 3 on Verizon.

#6 OP D!ABOL!C

D!ABOL!C

    Neowinian Senior

  • Joined: 06-April 03
  • Location: North Carolina
  • OS: Windows 8.1 and OSX 10.9.3
  • Phone: HTC One (M8) Android 4.4.2

Posted 02 April 2012 - 20:10

Edit edit: A "squid" box? What's that? Do you mean the linux squid proxy server?


That's correct. We use that for our OWA access.

#7 Geoffrey B.

Geoffrey B.

    LittleNeutrino

  • Tech Issues Solved: 9
  • Joined: 25-July 05
  • Location: Ohio
  • OS: Windows 8.1u1
  • Phone: Nokia Lumia 928 WP8.1u1

Posted 02 April 2012 - 20:16

Here are modified Instructions (removed company info) I made for instructing users at my company how to connect
1.png 2.png 4.png 5.png

#8 OP D!ABOL!C

D!ABOL!C

    Neowinian Senior

  • Joined: 06-April 03
  • Location: North Carolina
  • OS: Windows 8.1 and OSX 10.9.3
  • Phone: HTC One (M8) Android 4.4.2

Posted 02 April 2012 - 20:22

Edit: Can you walk us through the steps you took to create the account on the phone? screenshots help, and you can blur out the unnecessary parts. I'm wondering if it was created in a particular way which does commonly cause problems with outgoing email.


I haven't figured out how to do screenshots on the phone, but i'll do a step by step.

1) Click Settings
2) Click Accounts
3) Click Add Account
4) Click Corporate Sync
5) Then I enter credentials etc:
Email address
Password
Domain (which is optional)
Username (Formatted Domain\user)

It then tries to auto connect which it fails. Then I manually enter server address, which points at the squid box.

6) Server Address: squid.<domainhere>.com
Secure connection is checked.


After I click save, connection is completed succesfully. Email starts sync with contacts and calendar.


When I try to send an email with that account, I get a Message cannot be sent message.

#9 rajputwarrior

rajputwarrior

    olé olé olé olé

  • Joined: 20-June 04
  • Location: BC, CANADA

Posted 02 April 2012 - 20:22

my work 2010 exchange account works fine on my gtab running ICS and HC before it. Just had to manually set up the settings and it authenticated no problem and able to send/receive no problem.

#10 OP D!ABOL!C

D!ABOL!C

    Neowinian Senior

  • Joined: 06-April 03
  • Location: North Carolina
  • OS: Windows 8.1 and OSX 10.9.3
  • Phone: HTC One (M8) Android 4.4.2

Posted 02 April 2012 - 20:27

Well, good news is there a software update for my phone. I'll update it when I get home from work. Perhaps that will make a difference.

#11 OP D!ABOL!C

D!ABOL!C

    Neowinian Senior

  • Joined: 06-April 03
  • Location: North Carolina
  • OS: Windows 8.1 and OSX 10.9.3
  • Phone: HTC One (M8) Android 4.4.2

Posted 03 April 2012 - 01:29

Update complete. Same result. Oh well.

#12 BigBoy

BigBoy

    Neowinian

  • Joined: 28-August 01

Posted 03 April 2012 - 01:51

http://blogs.technet...15/3410397.aspx

Unfortunately, IMO, you just don't know what you are getting with Android, as far as quality implementation of ActiveSync. Fragmentation in this space is terrible. If you really need to depend on it, you should buy TouchDown.

#13 OP D!ABOL!C

D!ABOL!C

    Neowinian Senior

  • Joined: 06-April 03
  • Location: North Carolina
  • OS: Windows 8.1 and OSX 10.9.3
  • Phone: HTC One (M8) Android 4.4.2

Posted 03 April 2012 - 02:08

http://blogs.technet...15/3410397.aspx

Unfortunately, IMO, you just don't know what you are getting with Android, as far as quality implementation of ActiveSync. Fragmentation in this space is terrible. If you really need to depend on it, you should buy TouchDown.


I actually got a free license from Motorola because the X came out right about the time Exchange 2010 was getting rolling and they had problems getting it to work with Exchange. They offered free Touchdown licenses for users. I actually like Touchdown but was kinda hoping on getting the native app working.

#14 cybertimber2008

cybertimber2008

    Neowinian Senior

  • Joined: 02-December 08

Posted 03 April 2012 - 03:11

It could be the squid proxy server. I wasn't aware they were two directional, and I saw some things about exchange and squid earlier (when i posted) that I'll read over tomorrow (it's late here!) to see if there is anything helpful there. I'd think an exception would have to be made for the activesync traffic, while regular web users to OWA could access it normally though the proxy.
I'd think Android would detect the man-in-the-middle and drop the connection (SSL cert issue, etc etc).

Any difference if the SSL requirement is removed from the account (on the phone)?

#15 neo158

neo158

    Neowinian Senior

  • Joined: 18-July 02
  • OS: Windows 8.1 Professional x64; Windows RT 8.1
  • Phone: Samsung ATIV S i8750

Posted 04 April 2012 - 21:29

There are known issues with Exchange ActiveSync on versions of Android prior to HC, my HTC Desire refused to connect to my uni email even though all the credentials were correct. My Galaxy Nexus connected and worked just fine though, but seeing as that is stock Android 4.0 that's not surprising.