Jump to content



Photo

Wordpress not showing any posts for new installation

iis sql server word press

  • Please log in to reply
10 replies to this topic

#1 SirEvan

SirEvan

    Neowinian Senior

  • Joined: 17-April 03
  • Location: Santa Clara, CA
  • OS: Windows 8
  • Phone: HTC One (AT&T)

Posted 26 April 2012 - 23:39

I just tried setting up word press, using IIS 7.5, SQL server 2008 R2, PHP 5.3.10, and wordpress 3.3.2. Using various guides on the internet, I was able to get it working, installed, and setup. As far as I can tell there are no issues (i can change settings, update themes, etc. Everything looks like it's working, except no posts show on the home page. If I go into the admin panel, and look at posts, it says "all(3)", but then shows no entries. If I make a new post, it gives me a link that lets me see the post, but then when I click home, or search for it, it doesn't show. What's strange, is that if i create new categories, they show up on the home page, but if I associate a post to a category and then click a category, it doesn't show either.

Anyone know what the issue is?

Here's a link to it:http://www.healthyin....com/wordpress/

Admin link: http://www.healthyin...press/wp-admin/

Admin login is admin / 1234abcd


I've tried granting full permissions to all folders, turned off windows firewall on both the SQL server and the IIS server, as well as looked at the database to verify that the content is being inserted into the database. All the posts I've seen on wordpress and other sites are for people who had working sites, but now aren't seeing new posts, but I haven't found anything for new installs yet, so I'm at a loss.


#2 OP SirEvan

SirEvan

    Neowinian Senior

  • Joined: 17-April 03
  • Location: Santa Clara, CA
  • OS: Windows 8
  • Phone: HTC One (AT&T)

Posted 27 April 2012 - 04:51

further, it seems direct links work, such as http://www.healthyin.../wordpress/?p=5

#3 shozilla

shozilla

    Neowinian Senior

  • Tech Issues Solved: 6
  • Joined: 11-January 09

Posted 27 April 2012 - 05:08

Looks like your posts were published private... try change your posts to public then update them.

check your posts status on the right-hand side column when you are at editing post window.

Did you install wordpress from control panel? or you download/install wordpress by yourself?

#4 OP SirEvan

SirEvan

    Neowinian Senior

  • Joined: 17-April 03
  • Location: Santa Clara, CA
  • OS: Windows 8
  • Phone: HTC One (AT&T)

Posted 27 April 2012 - 07:17

Looks like your posts were published private... try change your posts to public then update them.

check your posts status on the right-hand side column when you are at editing post window.

Did you install wordpress from control panel? or you download/install wordpress by yourself?


downloaded and installed it myself. I went back, wiped it out again, reinstalled wordpress, reconfigured the database, set up url-rewrite mod, and it still doesn't seem to show stuff. I can see posts with a direct link but not on the page, even if i mark it private. Also, this is whats troubling me:
psts.png

It says "ALL: 4" now, but yet "no posts found". It's as if it's not able to read back from the database, but i know thats not true because the direct urls work.

I don't think it's a database issue, I think it's something in the php. I'm looking to try and see where the functions for wordpress are, to see what's going on with reading data back. I'm still looking, but if I can't figure it out, I'm going to try two things. 1.) install all in one, instead of a two-tier environment, and 2.) try running the microsoft wordpress setup that is supposed to download everything and configure it (but usese mysql). I don't really want to run a 2nd database, but I suppose I may have to if I can't get it working with my existing SQL server.

Also, I just added a page, and that shows up as well, so it's something specific to posts. I've used different themes and it doesnt change anything.

#5 shozilla

shozilla

    Neowinian Senior

  • Tech Issues Solved: 6
  • Joined: 11-January 09

Posted 27 April 2012 - 07:54

Try MySQL instead. Info and download: http://www.mysql.com

So you will use MySQL with your IIS server.


See here: http://codex.wordpre...r_own_Computer

Scroll down until you see "Easy 5 Minute WordPress Installation on Windows" then read the Step 4 which says "Installation of WordPress and its requirements".. read that part and Step 5 as well. It might help you out and change SQL server to MySQL or get BitNami which has everything you need out of the box.


If your site is hosted by your provider then ask your site admin to add mysql or change your wordpress settings to MySQL instead...

If your site is hosted on your computer, see the site that i just provided you a link.

#6 +Nik L

Nik L

    Where's my pants?

  • Tech Issues Solved: 2
  • Joined: 14-January 03

Posted 27 April 2012 - 08:01

Offtopic: Didn't realise it even ran on IIS and Ms SQL Server!

#7 OP SirEvan

SirEvan

    Neowinian Senior

  • Joined: 17-April 03
  • Location: Santa Clara, CA
  • OS: Windows 8
  • Phone: HTC One (AT&T)

Posted 27 April 2012 - 17:06

Try MySQL instead. Info and download: http://www.mysql.com So you will use MySQL with your IIS server. See here: http://codex.wordpre...r_own_Computer Scroll down until you see "Easy 5 Minute WordPress Installation on Windows" then read the Step 4 which says "Installation of WordPress and its requirements".. read that part and Step 5 as well. It might help you out and change SQL server to MySQL or get BitNami which has everything you need out of the box. If your site is hosted by your provider then ask your site admin to add mysql or change your wordpress settings to MySQL instead... If your site is hosted on your computer, see the site that i just provided you a link.


Thanks. I was going to give mysql a try next, though I think it's more in something with the PHP going on. I was trying to avoid running two seperate database platforms, but I suppose if it works in mysql then it'll have to do. and yeah nik, theres a dozen or so guides on how to use wordpress with sql..it was actually rather easy to set up.

#8 OP SirEvan

SirEvan

    Neowinian Senior

  • Joined: 17-April 03
  • Location: Santa Clara, CA
  • OS: Windows 8
  • Phone: HTC One (AT&T)

Posted 27 April 2012 - 18:03

meh. MySql version works fine, although it's using 3.3.1, maybe 3.3.2 doesn't work right. Either way this was easy, so I guess I'll just roll with two databases for now.

Thanks

#9 OP SirEvan

SirEvan

    Neowinian Senior

  • Joined: 17-April 03
  • Location: Santa Clara, CA
  • OS: Windows 8
  • Phone: HTC One (AT&T)

Posted 27 April 2012 - 23:03

found the solution here http://sourceforge.n...85&atid=1328061


translations.php


line 726


Change this: $pattern = '/LIMIT\s*(\d+)((\s*,?\s*)(\d+)*)(;{0,1})$/is';


to this: $pattern = '/LIMIT\s*(\d+)((\s*,?\s*)(\d+)*);{0,1}$/is';



Removing the extra parentheses allows "LIMIT 0, 10" to become "TOP 10".


With the extra parentheses, the "0" is used instead.


everything works now, and I'm back on SQL Server 2008 r2

#10 shozilla

shozilla

    Neowinian Senior

  • Tech Issues Solved: 6
  • Joined: 11-January 09

Posted 27 April 2012 - 23:10

Good. Glad that you got it solved.

I mostly use Apache and MySQL for the scripts that I write with.

I used to run IIS on my system but it wasn't long before I changed to Apache.



Have fun with your blog.

#11 avicario

avicario

    Resident One Post Wonder

  • Joined: 31-October 12

Posted 31 October 2012 - 11:42

SirEvan, your post on this issue has been the end of my tortuous way to install WordPress on Windows Server 2008 R2, with IIS, PHP and SQL Server 2008 R2, and in Spanish (which gives more problems)
This problem with the list of posts was the last to be resolved (at least for now).

Thanks a lot for sharing your solution.

Alvaro



Click here to login or here to register to remove this ad, it's free!