Sign in to follow this  
Followers 0

Window 7 slow boot


14 posts in this topic

Posted

I have this Windows 7 installed for about 3 months (estimated. not really exact.) and I'm having a really annoying and common problem: boot time. But my point is that I've already done all I know (that i could do) to reduce the boot time, but it's still really slow.

[b]Some detailed information:[/b]
OS: Windows 7 Ultimate x64
CPU: Intel Core i3-2100 @ 3.1GHz
Motherboard: MSI H61M-P21 (B3)
RAM: Corsair ValueSelect 4GB DDR3 1333MHz
VGA: Sapphire AMD Radeon HD 7770 GHz Edition 1GB GDDR5
PSU: CoolerMaster eXtreme PowerPlus 550W
HDDs:[list]
[*]WD 500GB 7200RPM 16MB cache (First partiotion: Windows; second partition: Only files)
[*]Seagate 320GB 7200RPM 8MB cache (Only files)
[*]Fujitsu 60GB 5400RPM 8MB cache (Ubuntu installed)
[/list]
Boot apps:[list]
[*]56 on boot
[*]23 removed or delayed
[*]10 can be removed but are necessary
[*]46 can't be modified
[/list]

I've already uninstalled what I don't need, cleared every system's garbage, uninstalled ghost drivers, removed or delayed apps from boot.
Could someone understand why this computer is taking from 1:40 to 2:30 (mm:ss) minutes to boot up?
I'd appreciate if someone tell me some other ideas for reducing boot time.

PS: I had a very lower computer configuration earlier, and it was booting VERY faster (from 30 to 60 seconds) than the actual one.

Share this post


Link to post
Share on other sites

Posted

Is the CPU set for AHCI in BIOS?
Also, is IDE disabled? If not, you might as well disable it if everything you have is SATA. The IDE check usually takes 5-10 seconds if it's enabled.

Though I don't think these things would cause that long startup time.
You could unplugging all the other hard drives except the Windows one and see if it boots faster. Maybe the Ubuntu dual-boot isn't playing nice with the Windows startup.

Share this post


Link to post
Share on other sites

Posted

Have you tested your hard drive ? (S.M.A.R.T., defragged, error check, etc.)

Checked the HDD cables ?

Something may not be seated tightly.

I suspect it is something to do with all those drives/partitions.

Share this post


Link to post
Share on other sites

Posted

The first thing i do when i buy a PC is to Format it. Crapware are the worst.
I recommend doing it if you have not done it.

run [b]msconfig [/b]and disable unwanted service and startups(two different tabs).
Run some cleaner like ccleaner

Right "Disk cleanup" delete old system restore points and delete all temp files.

Check for faulty HDD and RAM

Share this post


Link to post
Share on other sites

Posted

If you go in the event viewer, under applications and services logs, Microsoft, Windows, Diagnostics-Performance, it should have listed things that are taking longer than normal to boot, and the milliseconds it takes to load them. Also check your services.

Share this post


Link to post
Share on other sites

Posted

[quote name='still1' timestamp='1339170821' post='594919513']
The first thing i do when i buy a PC is to Format it. Crapware are the worst.
I recommend doing it if you have not done it.
[/quote]

It's pretty clear that he built it from scratch. No PC manufacturer that I know of ships a PC with an MSI motherboard, Corsair RAM, and a Cooler Master PSU. ;)
1 person likes this

Share this post


Link to post
Share on other sites

Posted

In my case it was the pure volume of USB devices I had attached, when I remove them my boot times reduce significantly. External hard disks seem to be the worst culprits.

Share this post


Link to post
Share on other sites

Posted

[quote name='Astra.Xtreme' timestamp='1339171385' post='594919537']
It's pretty clear that he built it from scratch. No PC manufacturer that I know of ships a PC with an MSI motherboard, Corsair RAM, and a Cooler Master PSU. ;)
[/quote]
ha... I didn't notice that. just took a shot :)

Share this post


Link to post
Share on other sites

Posted

Could be the hardware setup. I guess you have RAID on that motherboard. That will take 10-20s from the boot time. Is the BIOS set to quick boot? That will take another 10-15 seconds on the boot. Many things to consider and check.

Newer hardware have a tendency to have many features that will take longer time to boot up.

Share this post


Link to post
Share on other sites

Posted

Might not hurt to update the BIOS either.

Share this post


Link to post
Share on other sites

Posted

check your event logs it will tell you the culprit...its either a process or a program that is the culprit

Share this post


Link to post
Share on other sites

Posted

1. are the times you mentioned from cold or from the time Windows actually starts to load?

2. do you have network resources connected at boot? say, a NAS w/ mapped drives? i have this setup and it adds 10-15s to my boot time

Share this post


Link to post
Share on other sites

Posted

[quote name='neingesicht' timestamp='1339171134' post='594919531']
If you go in the event viewer, under applications and services logs, Microsoft, Windows, Diagnostics-Performance, it should have listed things that are taking longer than normal to boot, and the milliseconds it takes to load them. Also check your services.
[/quote]I wasn't aware of this before so I'm going to keep that in mind. But is there a Server 2003 equivalent?

Share this post


Link to post
Share on other sites

Posted

[quote name='Astra.Xtreme' timestamp='1339170750' post='594919507']
Is the CPU set for AHCI in BIOS?
Also, is IDE disabled? If not, you might as well disable it if everything you have is SATA. The IDE check usually takes 5-10 seconds if it's enabled.

Though I don't think these things would cause that long startup time.
You could unplugging all the other hard drives except the Windows one and see if it boots faster. Maybe the Ubuntu dual-boot isn't playing nice with the Windows startup.
[/quote]
Dude, I think my problem was exactly the slowness of the IDE mode. :huh:
I activated the AHCI mode and everything became fast. :woot: I'm just testing it some more times to be sure it's fixed, but I'm almost sure this was the problem.

Also, thanks for all other replies.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.