Jump to content



Photo

Glitchy font rendering in Firefox / Waterfox 14.0.1

firefox

  • Please log in to reply
5 replies to this topic

#1 Wakers

Wakers

    Neowinian Senior

  • Joined: 30-July 07

Posted 13 August 2012 - 12:20

I don't know what's going on with it, the best way I can describe it as I'm scrolling down a page, or entering text into a field (like this one) the rendering on the font is changing constantly. It goes from being smoothed, to blurred, to over coloured per letter that I'm typing, almost.

I don't have this problem in IE, Chrome or Opera.

Anyone else have anything like this?

Win8 RP
i5-2400
ATi 6850
8Gb DDR3

I've tried the anti-aliasing tuner add on but it only changes the appearance of static text, and doesn't solve the problem.


#2 Steven P.

Steven P.

    aka Neobond

  • Tech Issues Solved: 60
  • Joined: 09-July 01
  • Location: Neowin HQ

Posted 13 August 2012 - 12:25

I know what you mean, I have since switched to Chrome partly because of it, and the crappy stability issues with certain extensions (Echofon is one).

#3 OP Wakers

Wakers

    Neowinian Senior

  • Joined: 30-July 07

Posted 13 August 2012 - 12:26

It's driving me nuts, honestly. I'm stuck using FF14 for work related projects at the moment, and this is the worst font rendering I've ever seen.

I aborted FF4 because of font rendering, and they seem unable to get it working anything like properly.

#4 Mayhem

Mayhem

    Neowinian

  • Joined: 09-February 04

Posted 19 August 2012 - 15:20

had the same issues as other people http://forums.mozill...6015&p=12207479

https://bugzilla.moz...g.cgi?id=760299

taken from bugzilla link
Temporary fix:
Head to - about:config and search for - gfx.direct2d.disabled - set to "TRUE"

it worked for me

#5 HeyRatFans

HeyRatFans

    [This space for rent]

  • Joined: 04-November 01

Posted 20 August 2012 - 17:17

Thanks Mayhem, that fixed my Firefox crashing randomly since I installed the AMD Catalyst drivers. Hopefully Mozilla / AMD (whoever is to blame) will get this fixed ASAP.

#6 darth_vader

darth_vader

    Neowinian

  • Joined: 13-January 07
  • Location: Tatooine

Posted 20 August 2012 - 17:26

Go to about:config and search "gfx.font_rendering.cleartype_params.rendering_mode", set to "2" (GDI Classic). You now have HW acceleration and good font rendering (tested on Firefox 14.01 and Palemoon 12.3 x64).



Click here to login or here to register to remove this ad, it's free!