Jump to content



Photo

Notifications on Main Page

request

  • Please log in to reply
41 replies to this topic

#16 +i11usive

i11usive

    Neowinian Senior

  • Joined: 28-November 06
  • OS: Windows 8.1
  • Phone: Galaxy S5

Posted 05 September 2012 - 11:54

Does it automatically update without a page refresh?


#17 OP Harrison H.

Harrison H.

    Neowinian

  • Tech Issues Solved: 2
  • Joined: 21-August 04
  • Location: Florida
  • OS: Windows 8.1
  • Phone: Nokia Lumia 1520

Posted 06 September 2012 - 00:32

Nice job, thanks!

#18 nekkidtruth

nekkidtruth

    I'm sorry, do you still exist?

  • Joined: 10-March 07
  • Location: Canada
  • OS: Windows 7 64-bit
  • Phone: Stock LG Nexus 5

Posted 06 September 2012 - 01:13

Brings me to a blank page.

#19 ShMaunder

ShMaunder

    Neowinian

  • Joined: 15-December 06
  • Location: Wiltshire, UK
  • OS: Ubuntu 12.04
  • Phone: Nexus 4

Posted 06 September 2012 - 13:21

Works well! Good improvement.

#20 nekkidtruth

nekkidtruth

    I'm sorry, do you still exist?

  • Joined: 10-March 07
  • Location: Canada
  • OS: Windows 7 64-bit
  • Phone: Stock LG Nexus 5

Posted 07 September 2012 - 00:55

It's working fine for me now as well. Can't even describe how ecstatic I am that this has finally been implemented. Such a fantastically convenient feature!

#21 Mark

Mark

    (: ollǝɥ

  • Joined: 22-October 04
  • Location: Derbyshire, UK

Posted 10 September 2012 - 21:26

Has anyone else had their notifications buttons lighting up as white (as though you have a message) even when you don't? I went into the notification centre and set all messages as viewed just in case there was one I missed but still, every time I visit neowin it looks like I have new messages/notifications.

#22 nekkidtruth

nekkidtruth

    I'm sorry, do you still exist?

  • Joined: 10-March 07
  • Location: Canada
  • OS: Windows 7 64-bit
  • Phone: Stock LG Nexus 5

Posted 11 September 2012 - 01:07

Has anyone else had their notifications buttons lighting up as white (as though you have a message) even when you don't? I went into the notification centre and set all messages as viewed just in case there was one I missed but still, every time I visit neowin it looks like I have new messages/notifications.


The only thing I've noticed, and this happens with the icon on both the main page and the forums page (or My Content page), is if there is a notification and I go to that thread, but don't use the notification icon to go to that thread, it stays lit up. I have to physically click on the icon to see the notifications and then the next time the page is refreshed, it's no longer lit up.

That being said, the main page notification icon and the icon on the other pages on the site, are not running off the same database?, cookie?, code? because I have to physically click on both the front page one, and the forum one to get rid of both notifications. If I forget one, it continues to show new content.

#23 Mark

Mark

    (: ollǝɥ

  • Joined: 22-October 04
  • Location: Derbyshire, UK

Posted 11 September 2012 - 07:21

The only thing I've noticed, and this happens with the icon on both the main page and the forums page (or My Content page), is if there is a notification and I go to that thread, but don't use the notification icon to go to that thread, it stays lit up. I have to physically click on the icon to see the notifications and then the next time the page is refreshed, it's no longer lit up.

That being said, the main page notification icon and the icon on the other pages on the site, are not running off the same database?, cookie?, code? because I have to physically click on both the front page one, and the forum one to get rid of both notifications. If I forget one, it continues to show new content.


Another problem is, new items don't show up in bold so it actually appears that notifications are all viewed when they aren't...

#24 Redmak

Redmak

    Neowinian Senior

  • Tech Issues Solved: 39
  • Joined: 09-July 01
  • Location: Netherlands
  • OS: Windows 8
  • Phone: HTC One

Posted 11 September 2012 - 07:58

Bold for unread notifications added

The notifications are set to "read" and the "new notifications icon" is disabled when you click the icon on main. I thought that was the best way to go about.

I haven't really looked at the forums so that still works as IPB intended.

#25 Mark

Mark

    (: ollǝɥ

  • Joined: 22-October 04
  • Location: Derbyshire, UK

Posted 11 September 2012 - 08:28

One more

Bold for unread notifications added

The notifications are set to "read" and the "new notifications icon" is disabled when you click the icon on main. I thought that was the best way to go about.

I haven't really looked at the forums so that still works as IPB intended.


One more thing (and I might just be getting picky here) when middle clicking to open a notification in a new tab on the forums, the menu stays open so you can open a bunch of threads all at once, whereas on the front page, the notifications menu slides back in every time. Any chance of keeping it open on clicks?

Thanks!

#26 Redmak

Redmak

    Neowinian Senior

  • Tech Issues Solved: 39
  • Joined: 09-July 01
  • Location: Netherlands
  • OS: Windows 8
  • Phone: HTC One

Posted 12 September 2012 - 08:36

One more

One more thing (and I might just be getting picky here) when middle clicking to open a notification in a new tab on the forums, the menu stays open so you can open a bunch of threads all at once, whereas on the front page, the notifications menu slides back in every time. Any chance of keeping it open on clicks?

Thanks!


Done

#27 +i11usive

i11usive

    Neowinian Senior

  • Joined: 28-November 06
  • OS: Windows 8.1
  • Phone: Galaxy S5

Posted 12 September 2012 - 14:56

Anyway else experiencing this? Am running latest version of Chrome and the hyperlinks on the notifications dropdown don't fire. They do when I go into Forums / Notifications.

#28 Redmak

Redmak

    Neowinian Senior

  • Tech Issues Solved: 39
  • Joined: 09-July 01
  • Location: Netherlands
  • OS: Windows 8
  • Phone: HTC One

Posted 12 September 2012 - 14:57

Anyway else experiencing this? Am running latest version of Chrome and the hyperlinks on the notifications dropdown don't fire. They do when I go into Forums / Notifications.


Oops...overlooked that... will be fixed asap

#29 .Neo

.Neo

    Generic User

  • Joined: 14-September 05
  • Location: Amsterdam, NL
  • OS: OS X Mavericks
  • Phone: iPhone 5s

Posted 12 September 2012 - 15:12

It would be nice if you guys did something with OS X Mountain Lion's Notification Center as well. Websites can show alerts through Safari 6.

Attached Images

  • Screen Shot 2012-09-12 at 17.11.47.png


#30 SuperKid

SuperKid

    Im no superman

  • Joined: 21-April 08
  • Location: Birmingham, England, UK
  • OS: OS X 10.8, iOS 7
  • Phone: iPhone 4S

Posted 12 September 2012 - 15:20

It would be nice if you guys did something with OS X Mountain Lion's Notification Center as well. Websites can show alerts through Safari 6.


and I think Notifications work with Chrome as well now

EDIT: Yeah they do they show in the Notification Center options