Sign in to follow this  
Followers 0
Mindovermaster

GPU Upgrade/Change

32 posts in this topic

I asked this on another forum, but didn't get very much feedback.

I currently have a XFX Radeon HD5770.

What I envision, is to go to Linux. Probably Ubuntu. My 5770 does not play kindly with Ubuntu. I tried this on a spare HDD I had. It would not load the propietary driver. It just.. fails.

What I am looking for is a NVIDIA alternative. For me, something like a 560Ti is too much for me. Something like a 550Ti might work, but if I can get any lower without loosing as much performance as the 5770, I'd go with it.

Only game I play is Minecraft these days, and if I ever wanted to get anything else, It won't be anything demanding.

Share this post


Link to post
Share on other sites

My 5830 plays nicely enough with Ubuntu..

Perhaps consider downloading and compiling the AMD driver?

Share this post


Link to post
Share on other sites

Instead of doing too much research, I like to go to the famous graphics card ranking to get a quick answer for questions like this. It's a fine rough guide IMO.

http://www.overclock...t-updated-daily (GTX 650 not on the list yet but it's par with GTX 550 Ti)

It sounds like your 5770 is about par with a GTX 550 Ti or GTX 650. SO TBH, I'd say a 560 Ti is NOT too much for you. Of course the old 40nm cards are a poor value. You want a 28nm card now. If it must be nvidia, you can get the new GTX 650 for the same performance you have now, or the GTX 660 for a big-big upgrade.

The GTX 650 is ~USD 110 and the GTX 660 is ~$220 so there really is a big delta between them. The GTX 660 is made to last and it is the current-updated price point as what you have now. The 660 is also so much better that they tend not to compare it to cards in your current performance range anymore.

GTX 650, 660 review: http://www.tomshardw...ark,3297-8.html Your current card is also about par with the 7750 in this review.

Share this post


Link to post
Share on other sites

I am running Debian Wheezy (which Ubuntu 12.04 is based on) on my desktop (with a Saphire Radeon HD 5770). I also had problems with AMD's proprietary fglrx driver. It stopped working when I upgraded from xserver 1.11 to 1.12, before Wheezy stablized (Ubuntu 12.04 is using the latest xserver 1.12 package, the same as Wheezy). Downgrading xserver to the version in Squeeze works, but isn't an ideal solution and can break other packages, such as gnome-shell.

My solution has been to use the open-source radeon driver that is included in the Linux kernel. I was surprised to discover that it works exceptionally well with my Radeon HD 5770. Although they share much of the same underlying technology, such as Gallium 3D, the radeon driver is in a very advanced state compared to the nouveau driver (the open-source nVidia driver). I have not had any problems with the radeon driver in the ~6 months since I switched from the proprietary one. I get descent framerate and graphics acceleration in GNOME 3, Minecraft, VLC, and basically everything else.

Unlike with the proprietary AMD and nVidia graphics drivers, however, you will need to install a couple of packages to get the open-source radeon driver to perform decently. It is usable without most of these packages, but I don't recommend it.


sudo apt-get install libdrm-radeon1 libdrm2 xserver-xorg-video-radeon libgl1-mesa-glx libgl1-mesa-experimental
[/CODE]

Most of these packages are installed by default in Ubuntu 12.04, but I decided to list the essentials anyway. The libgl1-mesa-experimental package is a notable exception. It absolutely will not be installed by default, but is very useful. Don't be scared away by the 'experimental' label: it is, in fact, very stable. And installing it will drastically improve your graphics performance. I noticed the improvement most when my Minecraft framerate went up, but it is noticeable in other areas as well, such as effects rendering in GNOME 3.

If you are indeed set on buying a new nVidia graphics card to use in Linux, you will need the proprietary driver to make full use of your card. The developers of nouveau have done an excellent job reverse-engineering the kludge that is nVidia's proprietary driver, but it is in severely worse condition than the radeon or intel open-source graphics drivers because nVidia provides no assistance, unlike AMD and Intel.

Share this post


Link to post
Share on other sites

Thanks for the help, guys!

I do have a Linux rig. That I just mess with different distro's and different apps. If I ever mess up, I can just reinstall.

ASUS P7P55D-E LX

i5 760 (2.8GHz)

G.Skill RipJaws X 4GB DDR3 1600

Zotac GT440

30GB OCZ Vertex

320GB WD Blue

Seasonic 500W

Aerocool Zero Degree

Arctic Cooling Freezer 7 Pro

Ubuntu 12.04

The GT 440 works great with it. Has a NVIDIA X Server, too. So totally customizable.

Share this post


Link to post
Share on other sites

I asked this on another forum, but didn't get very much feedback.

I currently have a XFX Radeon HD5770.

What I envision, is to go to Linux. Probably Ubuntu. My 5770 does not play kindly with Ubuntu. I tried this on a spare HDD I had. It would not load the propietary driver. It just.. fails.

What I am looking for is a NVIDIA alternative. For me, something like a 560Ti is too much for me. Something like a 550Ti might work, but if I can get any lower without loosing as much performance as the 5770, I'd go with it.

Only game I play is Minecraft these days, and if I ever wanted to get anything else, It won't be anything demanding.

Why in the world are you using Ubuntu? Your priority is to install WIndows 7 and then you are good to go in software sentence.

Share this post


Link to post
Share on other sites

Demon, 99% of my applications are all open source. Windows 7 has no use to me. Ubuntu, IMHO, is much superior to it.

Share this post


Link to post
Share on other sites

Why in the world are you using Ubuntu? Your priority is to install WIndows 7 and then you are good to go in software sentence.

He says to the guy with a penguin avatar :\

Share this post


Link to post
Share on other sites

He says to the guy with a penguin avatar :\

Hehe ;). Well if he's running all his softies of open source like he said, then I guess it's fine.. But I wonder how the graphic stability takes the driver under his OS... I mean how often do you see a software suppport for Ubuntu or Linux? Not often I would say.. people just don't like it (no offense).

Share this post


Link to post
Share on other sites

He says to the guy with a penguin avatar :\

Nice catch, Articuno. :p I just like Tux.

edit: Umm, Demon, Ubuntu has a lot of support for drivers as well as software. Read above, plz. Don't make this a Win 7 vs Ubuntu war...

Share this post


Link to post
Share on other sites

Oh, A1ien, when I say too much I mean the price is too high. I don't want a $200 card that I won't benefit from.

Share this post


Link to post
Share on other sites

Thanks for the help, guys!

I do have a Linux rig. That I just mess with different distro's and different apps. If I ever mess up, I can just reinstall.

ASUS P7P55D-E LX

i5 760 (2.8GHz)

G.Skill RipJaws X 4GB DDR3 1600

Zotac GT440

30GB OCZ Vertex

320GB WD Blue

Seasonic 500W

Aerocool Zero Degree

Arctic Cooling Freezer 7 Pro

Ubuntu 12.04

The GT 440 works great with it. Has a NVIDIA X Server, too. So totally customizable.

I have a quick question. Is this the machine you are referring to in your first post? Did you already switch to an nVidia card or is this a different machine?

Also, I noticed in the specs that you have a SSD, which I'm guessing is your boot drive based on its size. If you haven't optimized anything for your SSD, I would highly recommend it. The Arch Wiki has an excellent article about SSD optimization in GNU/Linux. Although it is geared toward Arch, most of it is directly applicable to Ubuntu. If you would like, I can post my fstab so you can see my configuration (with a boot SSD and a secondary hard drive).

Share this post


Link to post
Share on other sites

Oh, sorry, this is a different system that I posted. I don't have the specs with me atm. I was just applying that AFAIK, NVIDIA has better support. As I have seen.

I'll look at that SSD optimization thing later. Yeah, I boot off it.

Also, on my main system, I do have a Samsung 830 120GB.

Share this post


Link to post
Share on other sites

Oh, sorry, this is a different system that I posted. I don't have the specs with me atm. I was just applying that AFAIK, NVIDIA has better support. As I have seen.

As for graphics driver support, AMD has a much better open-source driver than nVidia does, but while their proprietary driver performs well when it works, it often has problems and is not updated often. nVidia has a poor open-source driver, but their proprietary driver generally works very well and is updated regularly. However, both proprietary drivers are rather kludgey and will break when the Linux/xserver ABI changes, at least until the company decides to update their driver. If you are sticking with stable versions of Ubuntu, however, this shouldn't be a problem.

Share this post


Link to post
Share on other sites

Yeah, I was under the impression of proprietary drivers, not their open source ones.

Sounds good. When I get home I'll try the open source drivers. Currently on my laptop with Ubuntu 12.04. Works like OOTB with my Intel 3000 graphics. Only use it to surf and use Libre Office.

Share this post


Link to post
Share on other sites

After I apply those apt-gets you posted, restarted X, loog out, log in, nothing looks different. Was I supposed to config anything?

BTW, it says libgl1-mesa-experimental cannot be found.

When I try to turn on my second monitor, and apply, I get this:

required virtual size does not fit available size: requested=(3520, 1200), minimum=(320, 200), maximum=(1920, 1920)

and

GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._gnome_2drr_2derror_2dquark.Code3: required virtual size does not fit available size: requested=(3520, 1200), minimum=(320, 200), maximum=(1920, 1920)

Is that just the drivers are not implemented?

Share this post


Link to post
Share on other sites

After I apply those apt-gets you posted, restarted X, loog out, log in, nothing looks different. Was I supposed to config anything?

BTW, it says libgl1-mesa-experimental cannot be found.

When I try to turn on my second monitor, and apply, I get this:

and

Is that just the drivers are not implemented?

There are a couple of things I can think of that may help you.

First, that package that you could not install is essential to descent performance (in particular, it allows you to use Gallium 3D for OpenGL acceleration). I just verified that it is available in Ubuntu 12.04, not just Debian Wheezy. However, you need to have the universe repository enabled for it to be available. The easiest way to do that is using the Ubuntu Software Center. Go to Ubuntu Software Center->Edit->Software Sources ..., check every box under the "Downloadable from the internet" section in the "Ubuntu Software" tab of the Software Sources dialog box. Close Software Center, and do the following:


sudo apt-get update
sudo apt-get purge fglrx*
sudo apt-get autoremove
sudo apt-get install libgl1-mesa-experimental
[/CODE]

Then reboot your computer.

Second, I suspect that your other issues may be related to having an xorg.conf, which fglrx likes but radeon doesn't need. Your monitor issue could be related to the fact that fglrx and radeon parse the monitor setup section of xorg.conf in different ways. (TLDR: radeon is standards compliant, fglrx is not.) Try removing your xorg.conf, then reboot and use System Settings->Displays (the GNOME Control Center utility) to setup your monitors. I have two monitors (both LCD but with different resolutions) running perfectly on my desktop using this method; the setup sounds very similar to yours.

[CODE]
ls -l /etc/X11/ | grep xorg.conf # Check to see if xorg.conf exists.
# Only move the file and reboot if it exists, otherwise its unnecessary.
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.fglrx0
sudo reboot
[/CODE]

Share this post


Link to post
Share on other sites

OK, I got the 2 monitors working. I saw that libg1-mesa-experimental wasn't in the repositories, followed all your instructions. But I did happen to see libg1-mesa-DRI-experimental. So I installed that.

Now, not knowing what the hell I did, rebooted, and both screens were responding the second it showed the desktop. Yes, very low resolution, and mirrored, but I just changed that in display options and got it to right again. no more errors.

Now, another question arises. Why does a full window only work on the right screen? If I put in on the left Acer, and expand it, it goes to the 2nd Samsung monitor.

As so far, are we right as rain? Is it good and installed? I can't remember how to look that up, so I ran lspci. (friend suggested it many times through different hardware and I remembered :p )

01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Juniper [Radeon HD 5700 Series]
01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Juniper HDMI Audio [Radeon HD 5700 Series]

Share this post


Link to post
Share on other sites

You were right, I should have checked instead of doing it all from memory. The package name was libgl1-mesa-dri-experimental; sorry for the confusion.

As for testing your configuration, try the following (which I checked this time, instead of just writing it from memory):


sudo apt-get install mesa-utils # This is not installed by default, but you may already have it.
glxgears # Test your OpenGL framerate.
glxinfo | grep renderer # Should say something like "OpenGL renderer string: Gallium 0.4 on NVA8"
lshw -C video | grep driver # Should say something like "configuration: driver=radeon latency=0"
[/CODE]

However, that is just to test. Your configuration sounds good.

Now, another question arises. Why does a full window only work on the right screen? If I put in on the left Acer, and expand it, it goes to the 2nd Samsung monitor.

It would help to know which desktop environment you're using. If its Unity, I don't know why you are having that problem. Its possible that you could find something in Ubuntu Tweak, which I would recommend checking out anyway.

If your DE is GNOME 3, I had a similar issue. Try turning off the option to use workspaces on only one screen using GNOME Tweak Tool.

Share this post


Link to post
Share on other sites

Oh, man, that makes my night. I just rofled at that. Sorry.

I'm using Unity atm, but I am really considering using Gnome shell. I'll bring up Gnome shell and see if it works any better, I'll report back.

BTW, my main (this) system specs:

ASUS P8H67-M PRO
Intel Core i3 2100 (3.1GHz)
G.Skill RipJaws X 8GB DDR3 1333
128GB Samsung 830
320GB WD Blue
1.5TB WD Black
XFX Radeon HD5770
Corsair TX650

Edit:

glxgears

302 frames in 5.0 seconds = 60.334 FPS
300 frames in 5.0 seconds = 59.878 FPS
300 frames in 5.0 seconds = 59.877 FPS
300 frames in 5.0 seconds = 59.878 FPS
300 frames in 5.0 seconds = 59.877 FPS
300 frames in 5.0 seconds = 59.878 FPS
300 frames in 5.0 seconds = 59.878 FPS

glxinfo

OpenGL renderer string: Gallium 0.4 on AMD JUNIPER

lshw

configuration: driver=radeon latency=0

I'll work on the DE tommorrow. I'm tired, had a long day...

Edit2:

I noticed my GPU fan is a little loud. I tried looking up help for it, but most are from version 10. Since you have the same card, have you noticed this as well?

Share this post


Link to post
Share on other sites

I noticed my GPU fan is a little loud. I tried looking up help for it, but most are from version 10. Since you have the same card, have you noticed this as well?

My fan gets louder than it does in Windows sometimes, but not often. Since my card is a Saphire VaporX (one of Saphire's cards using a custom cooling solution, not one based on AMD's reference designs), the manufacturer may make a difference in my case. In general, you can probably solve your problem by installing (software) temperature sensors or manually configuring your thresholds and fan speed.

It seems to me that lm-sensors is the obvious choice for fan control (and hardware monitoring in general). You can check the Ubuntu Wiki for a slightly outdated (but mostly accurate) guide on setting it up. Fortunately, lm-sensors is not a hard program to understand or configure -- and its fairly well documented. Also, although this Debian Wiki entry isn't for your machine specifically (or even a desktop graphics card), it might help you understand lm-sensors and fan control in Linux a little bit better, from a practical standpoint.

Share this post


Link to post
Share on other sites

I have used lmsensors in the past, but that was a few years ago. I need to brush up on that.

BTW, that screen problem has seemed to have gone away now. Maybe it just needed a restart. But, still, I'm going to test out Gnome shell.

Share this post


Link to post
Share on other sites

Hey, sorry to jump, but I am currently (as the last two days) using Ubuntu 12.10, upgraded from 12.04.

Now, about the GFX fan, I can not quiet it. Even when not in high graphical intense applications, it is still loud.

I did use lm-sensors, and did a detect, but all it found was my CPU and GFX temps. nothing else. This is what I get after the detection and implementing it:

david@david-ubuntu:~$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +36.0?C  (high = +82.0?C, crit = +102.0?C)
Core 0:		 +36.0?C  (high = +82.0?C, crit = +102.0?C)
Core 1:		 +34.0?C  (high = +82.0?C, crit = +102.0?C)

radeon-pci-0100
Adapter: PCI adapter
temp1:	    +65.0?C  

No fan control at all. Could it just be that my XFX card has no PWM options?

Share this post


Link to post
Share on other sites

One of the changes that Canonical made in Ubuntu 12.10 was removing Unity 2D. Part of the reasoning for the move, if I remember correctly, was that they have improved the 3D performance of Unity to the point where it is no longer necessary. It may be that you were previously using Unity 2D but were automatically switched since it is no longer present in the latest Ubuntu release.

While that won't solve your problem, it may help diagnose it. You could try installing the openbox desktop environment (well, window manager if you really want to get technical about it) and selecting that from the LightDM login screen instead of Unity. Since openbox doesn't do any compositing, your graphics card's fans won't spin up if my theory is correct.

As for actually solving the problem, that is a little more difficult. According to the Radeon wiki page on X.Org, there have been many new features added to the kernel driver between Ubuntu 12.04 (Linux 3.2) and Ubuntu 12.10 (Linux 3.5). Take a look at the KMS Power Management Options in particular. According to the wiki, directly controlling the fan speed has been explicitly disabled because it could be dangerous. However, you can choose from two basic power modes and 5 fan profiles.

Also if modifying those settings doesn't seem to have any effect, make sure that kernel mode setting is enabled for your graphics card. To do that, add the following line to your kernel parameters. (Ideally you would append it to the GRUB_CMDLINE_LINUX_DEFAULT line in /etc/default/grub and run 'sudo update-grub' before rebooting.)


radeon.modeset=1
[/CODE]

Share this post


Link to post
Share on other sites

I'll mess with this tomorrow. It's getting late. (11:00 pm cst)

I'll look at OpenBox and see if anything improves.

OK, I looked in that file, I see this snippet:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

now, should I add that radeon thing, or replace it with that "quiet splash"? Also see that grub_cmdline_linux without _Default. Is that something else?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.