Jump to content



Photo

GPU Upgrade/Change


  • Please log in to reply
31 replies to this topic

#16 OP +Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 8
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: #!Crunchbang Debian
  • Phone: HTC ONE V

Posted 14 September 2012 - 19:24

After I apply those apt-gets you posted, restarted X, loog out, log in, nothing looks different. Was I supposed to config anything?

BTW, it says libgl1-mesa-experimental cannot be found.

When I try to turn on my second monitor, and apply, I get this:

required virtual size does not fit available size: requested=(3520, 1200), minimum=(320, 200), maximum=(1920, 1920)


and

GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._gnome_2drr_2derror_2dquark.Code3: required virtual size does not fit available size: requested=(3520, 1200), minimum=(320, 200), maximum=(1920, 1920)


Is that just the drivers are not implemented?


#17 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 14 September 2012 - 23:48

After I apply those apt-gets you posted, restarted X, loog out, log in, nothing looks different. Was I supposed to config anything?

BTW, it says libgl1-mesa-experimental cannot be found.

When I try to turn on my second monitor, and apply, I get this:



and



Is that just the drivers are not implemented?


There are a couple of things I can think of that may help you.

First, that package that you could not install is essential to descent performance (in particular, it allows you to use Gallium 3D for OpenGL acceleration). I just verified that it is available in Ubuntu 12.04, not just Debian Wheezy. However, you need to have the universe repository enabled for it to be available. The easiest way to do that is using the Ubuntu Software Center. Go to Ubuntu Software Center->Edit->Software Sources ..., check every box under the "Downloadable from the internet" section in the "Ubuntu Software" tab of the Software Sources dialog box. Close Software Center, and do the following:

sudo apt-get update
sudo apt-get purge fglrx*
sudo apt-get autoremove
sudo apt-get install libgl1-mesa-experimental

Then reboot your computer.

Second, I suspect that your other issues may be related to having an xorg.conf, which fglrx likes but radeon doesn't need. Your monitor issue could be related to the fact that fglrx and radeon parse the monitor setup section of xorg.conf in different ways. (TLDR: radeon is standards compliant, fglrx is not.) Try removing your xorg.conf, then reboot and use System Settings->Displays (the GNOME Control Center utility) to setup your monitors. I have two monitors (both LCD but with different resolutions) running perfectly on my desktop using this method; the setup sounds very similar to yours.

ls -l /etc/X11/ | grep xorg.conf # Check to see if xorg.conf exists.
# Only move the file and reboot if it exists, otherwise its unnecessary.
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.fglrx0
sudo reboot


#18 OP +Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 8
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: #!Crunchbang Debian
  • Phone: HTC ONE V

Posted 15 September 2012 - 01:51

OK, I got the 2 monitors working. I saw that libg1-mesa-experimental wasn't in the repositories, followed all your instructions. But I did happen to see libg1-mesa-DRI-experimental. So I installed that.

Now, not knowing what the hell I did, rebooted, and both screens were responding the second it showed the desktop. Yes, very low resolution, and mirrored, but I just changed that in display options and got it to right again. no more errors.

Now, another question arises. Why does a full window only work on the right screen? If I put in on the left Acer, and expand it, it goes to the 2nd Samsung monitor.

As so far, are we right as rain? Is it good and installed? I can't remember how to look that up, so I ran lspci. (friend suggested it many times through different hardware and I remembered :p )

01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Juniper [Radeon HD 5700 Series]
01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Juniper HDMI Audio [Radeon HD 5700 Series]


#19 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 15 September 2012 - 02:28

You were right, I should have checked instead of doing it all from memory. The package name was libgl1-mesa-dri-experimental; sorry for the confusion.

As for testing your configuration, try the following (which I checked this time, instead of just writing it from memory):

sudo apt-get install mesa-utils # This is not installed by default, but you may already have it.
glxgears # Test your OpenGL framerate.
glxinfo | grep renderer # Should say something like "OpenGL renderer string: Gallium 0.4 on NVA8"
lshw -C video | grep driver # Should say something like "configuration: driver=radeon latency=0"

However, that is just to test. Your configuration sounds good.

Now, another question arises. Why does a full window only work on the right screen? If I put in on the left Acer, and expand it, it goes to the 2nd Samsung monitor.


It would help to know which desktop environment you're using. If its Unity, I don't know why you are having that problem. Its possible that you could find something in Ubuntu Tweak, which I would recommend checking out anyway.

If your DE is GNOME 3, I had a similar issue. Try turning off the option to use workspaces on only one screen using GNOME Tweak Tool.

#20 OP +Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 8
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: #!Crunchbang Debian
  • Phone: HTC ONE V

Posted 15 September 2012 - 03:19

Oh, man, that makes my night. I just rofled at that. Sorry.

I'm using Unity atm, but I am really considering using Gnome shell. I'll bring up Gnome shell and see if it works any better, I'll report back.

BTW, my main (this) system specs:

ASUS P8H67-M PRO
Intel Core i3 2100 (3.1GHz)
G.Skill RipJaws X 8GB DDR3 1333
128GB Samsung 830
320GB WD Blue
1.5TB WD Black
XFX Radeon HD5770
Corsair TX650

Edit:

glxgears

302 frames in 5.0 seconds = 60.334 FPS
300 frames in 5.0 seconds = 59.878 FPS
300 frames in 5.0 seconds = 59.877 FPS
300 frames in 5.0 seconds = 59.878 FPS
300 frames in 5.0 seconds = 59.877 FPS
300 frames in 5.0 seconds = 59.878 FPS
300 frames in 5.0 seconds = 59.878 FPS

glxinfo

OpenGL renderer string: Gallium 0.4 on AMD JUNIPER

lshw

configuration: driver=radeon latency=0

I'll work on the DE tommorrow. I'm tired, had a long day...

Edit2:

I noticed my GPU fan is a little loud. I tried looking up help for it, but most are from version 10. Since you have the same card, have you noticed this as well?

#21 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 15 September 2012 - 04:33

I noticed my GPU fan is a little loud. I tried looking up help for it, but most are from version 10. Since you have the same card, have you noticed this as well?


My fan gets louder than it does in Windows sometimes, but not often. Since my card is a Saphire VaporX (one of Saphire's cards using a custom cooling solution, not one based on AMD's reference designs), the manufacturer may make a difference in my case. In general, you can probably solve your problem by installing (software) temperature sensors or manually configuring your thresholds and fan speed.

It seems to me that lm-sensors is the obvious choice for fan control (and hardware monitoring in general). You can check the Ubuntu Wiki for a slightly outdated (but mostly accurate) guide on setting it up. Fortunately, lm-sensors is not a hard program to understand or configure -- and its fairly well documented. Also, although this Debian Wiki entry isn't for your machine specifically (or even a desktop graphics card), it might help you understand lm-sensors and fan control in Linux a little bit better, from a practical standpoint.

#22 OP +Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 8
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: #!Crunchbang Debian
  • Phone: HTC ONE V

Posted 15 September 2012 - 13:15

I have used lmsensors in the past, but that was a few years ago. I need to brush up on that.

BTW, that screen problem has seemed to have gone away now. Maybe it just needed a restart. But, still, I'm going to test out Gnome shell.

#23 OP +Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 8
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: #!Crunchbang Debian
  • Phone: HTC ONE V

Posted 26 October 2012 - 00:15

Hey, sorry to jump, but I am currently (as the last two days) using Ubuntu 12.10, upgraded from 12.04.

Now, about the GFX fan, I can not quiet it. Even when not in high graphical intense applications, it is still loud.

I did use lm-sensors, and did a detect, but all it found was my CPU and GFX temps. nothing else. This is what I get after the detection and implementing it:

david@david-ubuntu:~$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +36.0°C  (high = +82.0°C, crit = +102.0°C)
Core 0:		 +36.0°C  (high = +82.0°C, crit = +102.0°C)
Core 1:		 +34.0°C  (high = +82.0°C, crit = +102.0°C)

radeon-pci-0100
Adapter: PCI adapter
temp1:	    +65.0°C  

No fan control at all. Could it just be that my XFX card has no PWM options?

#24 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 26 October 2012 - 03:45

One of the changes that Canonical made in Ubuntu 12.10 was removing Unity 2D. Part of the reasoning for the move, if I remember correctly, was that they have improved the 3D performance of Unity to the point where it is no longer necessary. It may be that you were previously using Unity 2D but were automatically switched since it is no longer present in the latest Ubuntu release.

While that won't solve your problem, it may help diagnose it. You could try installing the openbox desktop environment (well, window manager if you really want to get technical about it) and selecting that from the LightDM login screen instead of Unity. Since openbox doesn't do any compositing, your graphics card's fans won't spin up if my theory is correct.

As for actually solving the problem, that is a little more difficult. According to the Radeon wiki page on X.Org, there have been many new features added to the kernel driver between Ubuntu 12.04 (Linux 3.2) and Ubuntu 12.10 (Linux 3.5). Take a look at the KMS Power Management Options in particular. According to the wiki, directly controlling the fan speed has been explicitly disabled because it could be dangerous. However, you can choose from two basic power modes and 5 fan profiles.

Also if modifying those settings doesn't seem to have any effect, make sure that kernel mode setting is enabled for your graphics card. To do that, add the following line to your kernel parameters. (Ideally you would append it to the GRUB_CMDLINE_LINUX_DEFAULT line in /etc/default/grub and run 'sudo update-grub' before rebooting.)
radeon.modeset=1


#25 OP +Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 8
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: #!Crunchbang Debian
  • Phone: HTC ONE V

Posted 26 October 2012 - 04:16

I'll mess with this tomorrow. It's getting late. (11:00 pm cst)

I'll look at OpenBox and see if anything improves.

OK, I looked in that file, I see this snippet:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

now, should I add that radeon thing, or replace it with that "quiet splash"? Also see that grub_cmdline_linux without _Default. Is that something else?

#26 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 26 October 2012 - 04:28

The GRUB_CMDLINE_LINUX line is different in that it applies to the "recovery" entries as well as the "normal" boot entries. Also, you would append to the GRUB_CMDLINE_LINUX_DEFAULT line in /etc/default/grub instead of replacing it. Not that replacing it altogether would be a bad thing. The splash parameter makes Ubuntu display the splash screen while it is booting. The quiet parameter makes Ubuntu less verbose (in terminal) while it is booting. They are not essential for booting your OS. (The Debian Wheezy installation on my laptop, for instance, has GRUB_CMDLINE_LINUX_DEFAULT="" in /etc/default/grub.)

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.modeset=1"


#27 OP +Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 8
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: #!Crunchbang Debian
  • Phone: HTC ONE V

Posted 26 October 2012 - 18:59

How do you modify the Kernel? I never did this before...

#28 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 26 October 2012 - 23:28

The kernel? You probably don't actually want to replace your kernel, you just want to add a new parameter to your kernel command line.

First, edit /etc/default/grub to have the following line:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.modeset=1"

Second, update your GRUB configuration file to include the new parameter.
$ sudo update-grub

Finally, reboot.
$ sudo reboot

Optionally, if you want to check your command line after you have rebooted, you can run the following:
$ grep 'modeset' /proc/cmdline


#29 OP +Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 8
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: #!Crunchbang Debian
  • Phone: HTC ONE V

Posted 26 October 2012 - 23:40

Out of the last command, I get:

BOOT_IMAGE=/boot/vmlinuz-3.5.0-17-generic root=UUID=356ae727-52af-4eb0-bab9-05cc90d20657 ro quiet splash radeon.modeset=1 vt.handoff=7


#30 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 26 October 2012 - 23:50

Excellent! That's exactly what you want.

Have you confirmed or disproved my theory about why you are experiencing heavy GPU usage (or at least high fan usage)?



Click here to login or here to register to remove this ad, it's free!