Sign in to follow this  
Followers 0
Jen Stone

Maya only loads through the repair option

4 posts in this topic

I have a Gateway DX4822-01.

System Specs:

Intel Pentium E5300 / 2.6 GHz

Dual-Core

64 Bit

CPU Qty 1.0

Max CPU Qty 1.0

Chipset Type Intel G43 Express

Front Side Bus 800.0 MHz

L2 cache - 2.0 MB

Cache Per Processor 2 MB

Ram Size 6.0 GB / 8.0 GB (max)

DDR3 SDRAM

DIMM 240-pin

HDD

Capacity 1.0 x 1.0 TB

Interface Type Serial ATA-300

Spindle Speed 5400.0 rpm

Type Serial ATA - Integrated

Controller Interface Type Serial ATA-300

Type Integrated

Graphics Processor / Vendor Intel GMA X4500 Dynamic Video Memory Technology 5.0

Video Memory 384.0 MB

I installed LinuxMint 13 Maya Cinnamon and (I believe 64 bit version) a few days ago. I cannot get Maya to load. It goes to the dark load screen and just hangs until I force reboot. I have no problem loading Maya through the "repair" option in the grub menu. I select that option, and select the "resume normal boot" option and things work beautifully.

I am mystified as to what the issue is?

I would appreciate any help.

Thanks.

Share this post


Link to post
Share on other sites

Solved it. I had to install the drivers for my graphics card.

Share this post


Link to post
Share on other sites

Based on past experience (and your system specs), I suspect that your system doesn't actually hang, it just fails to bring up your display. Its probably not even xorg that is having a problem, its an issue with KMS and your graphics card.

To test my hypothesis, do the following:

1. At the GRUB 2 boot prompt, highlight the default boot entry (which should be the first one) and press 'E' on your keyboard.

2. After the 'linux' command add the argument 'nomodeset'.

It should look something like this:


linux /boot/vmlinuz-3.2.0-3-amd64 root=UUID=01234567-890a-bcde-f012-34567890abcd ro quiet nomodeset
[/CODE]

[b]3.[/b] Press the 'F10' key to boot using your modified boot command.

If everything boots normally (like when you 'resume normal boot' from recovery mode), then you can apply the fix permanently.

[b]1.[/b] Edit /etc/default/grub to add 'nomodeset' to your GRUB_CMDLINE_LINUX_DEFAULT arguments.

It should look something like this:

[CODE]
GRUB_CMDLINE_LINUX_DEFAULT="quiet nomodeset"
[/CODE]

[b]2.[/b] Apply the changes to your GRUB configuration file.

[CODE]
sudo update-grub
[/CODE]

Feel free to let me know if my theory (and tutorial) was a waste of time. If so, a copy of your /var/log/Xorg.0.log (from a failed boot) would certainly be helpful in diagnosing the problem.

[b]Edit:[/b] I guess I was too slow.

Share this post


Link to post
Share on other sites

Solved it. I had to install the drivers for my graphics card.

What did you install, exactly? Since you have an Intel graphics card, it wasn't proprietary graphics drivers (such as fglrx for AMD graphics cards or nividia for nVidia graphics cards). Did you need to install something such as xserver-xorg-video-intel or libdrm-intel1? I would think both of those would be installed by default. In Debian, I would normally enable the non-free repository and install firmware-linux, but I believe that Mint is based off of Ubuntu, which includes those proprietary firmware blobs directly in their kernel. I'm just curious what you were missing (and it may help someone who stumbles on this thread in the future).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.