Jump to content



Photo

  • Please log in to reply
17 replies to this topic

#16 NateB1

NateB1

    Neowinian Senior

  • Joined: 09-January 07

Posted 01 November 2012 - 03:42

Yep, I get the mobo logo too now, after I updated my BIOS to support Windows 8 UEFI. Thankfully, AsRock has a smallish green logo, and not a gigantic in-your-face logo.

Sadly, my graphics card (EVGA 680 GTX) doesn't support UEFI-GOP, so I can't do the ultra-fast boot option. According to their forums, EVGA plans on releasing an optional firmware upgrade to enable it in their 6xx lineup...


#17 rfirth

rfirth

    Software Engineer

  • Tech Issues Solved: 2
  • Joined: 11-September 09
  • Location: Baton Rouge, Louisiana
  • OS: Windows 8
  • Phone: Nokia Lumia 620

Posted 01 November 2012 - 04:05

Oh! That explains why Surface displays the word "Surface" on the boot screen instead of the new Windows logo.

At least, that's what I've observed in videos... I don't have one (yet!).

#18 +SharpGreen

SharpGreen

    Now with built-in BS detector.

  • Tech Issues Solved: 1
  • Joined: 20-August 04
  • Location: North Carolina
  • OS: Ubuntu 14.04, 12.04 and Windows 8.1
  • Phone: Galaxy Nexus

Posted 15 November 2012 - 19:48

Oh! That explains why Surface displays the word "Surface" on the boot screen instead of the new Windows logo.

At least, that's what I've observed in videos... I don't have one (yet!).

Yea..even Samsung's Intel based Series 7 tablets (or w/e that tablet was that was given out at last year's build) does that.



Click here to login or here to register to remove this ad, it's free!