106 posts in this topic

startx is working for you? Can you open a terminal in gnome and run startx and see what the output is? Before I'd get a new blank X session but now all I get is;

<usual X.org messages>

Initializing built-in extension DRI2

Loading extension GLX

Fatal server error:

no screens found

(EE)

Please consult the The X.Org Foundation support

at http://wiki.x.org

for help.

(EE) Please also check the log file at "/var/log/Xorg.1.log" for additional information.

(EE)

Server terminated with error (1). Closing log file.

xinit: giving up

xinit: unable to connect to X server: Connection refused

xinit: server error

([ 2097.370] (II) NVIDIA(0): NVIDIA GPU GeForce 9600 GT (G94) at PCI:1:0:0 (GPU-0)

[ 2097.370] (--) NVIDIA(0): Memory: 524288 kBytes

[ 2097.370] (--) NVIDIA(0): VideoBIOS: 62.94.0d.00.02

[ 2097.370] (II) NVIDIA(0): Detected PCI Express Link width: 16X

[ 2097.370] (--) NVIDIA(0): Interlaced video modes are supported on this GPU

[ 2097.373] (EE) NVIDIA(GPU-0): EVO Push buffer channel allocation failed

[ 2097.373] (EE) *** Aborting ***

[ 2097.373] (EE) NVIDIA(GPU-0): Failed to allocate EVO core DMA push buffer

[ 2097.373] (EE) *** Aborting ***

[ 2097.373] (EE) NVIDIA(0): Failing initialization of X screen 0)

Also if you open gnome-tweak-tool and go to theme and change the bottom one, 'Current Theme', that works? Here it does nothing, maybe they've modified it so it only changed gnome-shell themes, only changing GTK+ themes does anything. If I use gtk-chtheme then it all works fine.

I set my Arches up so that startX starts a new Cinnamon session, lets me run command line if need be if I just gotta do something quick, or I run startx and it works no problem. Have you tried wiping your xorg.conf file?

Also, I don't have gnome shell so it doesn't let me set that theme (shell theme).

Share this post


Link to post
Share on other sites

Not shell theme no, 'current theme', here;

Also that's weird. I don't have an xorg.conf file, it's setup to detect everything automatically. https://bbs.archlinux.org/viewtopic.php?pid=1187652 is the closest thing I could find and their solution was to go pure systemd, I've got some initscripts still running as legacy but can't really see how that would interefere with it. Will try on laptop in a minute that's pure systemd.

post-160466-0-68548900-1352470033.png

Share this post


Link to post
Share on other sites

Not shell theme no, 'current theme', here;

Also that's weird. I don't have an xorg.conf file, it's setup to detect everything automatically.

What happens if you drop to command line, login as su, and startx as su?

Also, on my screen "Current Theme" says "Shell Theme" and that I can't set it as Gnome Shell isn't installed.

Share this post


Link to post
Share on other sites

Current theme says shell theme? Humm weird, I've got a shell theme above. Do you not have a 'current theme' on your gnome-tweak-tool?

Humm I would drop down to a console session but it would appear ctrl+alt+f2 or any F# key doesn't do anything... strange

EDIT: Weird, I can ctrl+alt+F# fine on the login screen and when I've logged in, but as soon as I try a startx and it fails, I can't ctrl+alt+F# at all until I've logged out and try again there or login again.

On the GDM screen, going to ctrl+alt+F2, logging in as root and doing startx works fine. And just tried logging in again via GDM and going to F2, logging in as normal user and doing startx and both sessions are running in parallel fine, so it's a strange bug, startx isn't working from inside an X session.

Edited by n_K

Share this post


Link to post
Share on other sites

My sound wasn't off when I booted up and GDM ran twit. It was only off when I took that screenshot from Gnome. Herp Derp. Is that really the best you can do?

Share this post


Link to post
Share on other sites

[Thread Cleaned]

Please stay on topic. Personal attacks are uncalled for.

Share this post


Link to post
Share on other sites

As an interesting aside - I just googled "Gnome 3.6 fallback" and came upon this:

I?m writing to inform you that the release team discussed https://live.gnome.o...FixFallbackMode yesterday. We?ve come to the conclusion that we can?t maintain fallback mode in reasonable quality, and are better off dropping it.

We?re now working on organizing this so that it does not create more fallout than necessary. As part of this, I?m reaching out to our distributors to see what parts they care about. We haven?t worked out a detailed plan for 3.8 tasks yet, but the feature page should give you a good idea about what things will be part of the 3.8 plan:

This means that if your antiquated/poorly supported hardware requires fallback mode, you need to switch away from Gnome. Fallback mode is on the way out (scheduled to be dropped entirely in 3.8). Time to either get some decently supported hardware or bite the bullet and switch to a different desktop environment. Blaming Arch for this problem makes absolutely no sense given that you are essentially attempting to run Gnome 3.6 on what is now considered unsupported hardware.

Share this post


Link to post
Share on other sites

I blamed arch/gnome, if gnome are dropping support from 3.8 then I entirely blame gnome.

And what's using gnome in fallback mode got to do with having poorly supported hardware ? So I've got poorly supported hardware because I don't like a glimmed up slow interface that's messy, annoying and unproductive? I use gnome fallback because it's the only decent part of gnome left, so now it's time to remove gnome entirely, thanks for pasting that bit from gnome though, I'll go to the cdesktop environment.

Share this post


Link to post
Share on other sites

I knew that was coming. They have put no effort in fixing or improving fallback mode. I'm removing gnome and installing xfce.

I agree with n_K. The new gnome interface is annoying and unproductive.

Share this post


Link to post
Share on other sites

Also I'm not being funny or anything, but how the hell do you change backgrounds in gnome 3.6 to your own picture? Right click desktop -> change background, opens gnome-control-centre on the background tab and it's got just one large button which you click and you have 3 tabs, go the middle one and the previous pictures I've used are there but I can't add/use any other pictures files, even dragging them in doesn't work? Is this honestly some late april fools joke or what!

Share this post


Link to post
Share on other sites

Everyone should install XFCE. It's not got all that warm snuggly widget stuff, but it does what it says :p

Share this post


Link to post
Share on other sites

Hmm.. I use cinnamon on an older PC which uses fall back and due to using cinnamon it needs gnome... so technically I am not using gnomes de... but will be affected by this.

Share this post


Link to post
Share on other sites

Yeah I like xfce, had it on my sabayon install which I wiped to install arch, pretty gutted I did that now. MATE is good but it's GTK2 and everythings moved away from GTK2 now. I'll have to give this cinnamin a try I think and then decide after that.

Share this post


Link to post
Share on other sites

And what's using gnome in fallback mode got to do with having poorly supported hardware ? So I've got poorly supported hardware because I don't like a glimmed up slow interface that's messy, annoying and unproductive?

So wait - you are using fallback mode by choice not by necessity? Gotta love it. I'll second other people's recommendation for XFCE. It's a solid DE and doesn't require any hardware acceleration.

Share this post


Link to post
Share on other sites

yeah I've been messing with XFCE myself in my new Arch VM (finally got around to learning the new install method). It's a nice DE, just wish i could figure out how to make it look a little nicer. haven't started looking for third party themes yet

other than the look it runs solidly, still not sure whether i like XFCE or Cinnamon more yet though. both have their quirks

Share this post


Link to post
Share on other sites

Also I'm not being funny or anything, but how the hell do you change backgrounds in gnome 3.6 to your own picture? Right click desktop -> change background, opens gnome-control-centre on the background tab and it's got just one large button which you click and you have 3 tabs, go the middle one and the previous pictures I've used are there but I can't add/use any other pictures files, even dragging them in doesn't work? Is this honestly some late april fools joke or what!

click on ur name in the top right hand corner then click settings

in there click background :)

Share this post


Link to post
Share on other sites

Yep if I do this (maybe it's yet another gnome fallback bug) all I see is a large button, if I click it I can change wallpaper to wallpapers in gnome, backgrounds I have or a colour gradient, but I'm not able to add any backgrounds I haven't used previously, dragging them does nothing, there's no menu, etc. :(

Share this post


Link to post
Share on other sites

Have you tried deleting your configs and restarting your X session? There's no way a standard Gnone install would be this broken. Have you checked for any .pacnew files related to Gnome?

Share this post


Link to post
Share on other sites

I haven't checked the backgrounds with a blank gnome/x session but all the other bugs I tried in a brand new arch install on my laptop and were present so I'd assume the background bug is present too. Well, it's not a bug, just there is no way I can see that makes it possible to add your own background!

Share this post


Link to post
Share on other sites

So bunch of gnome updates.. none of which fixed my problem, and actually made it a little more glitchy in a way. Now for some reason some of the icons on my desktop have a White/Grey border around them. Not all of them do, just chromium and monodevelop.

Share this post


Link to post
Share on other sites

Arch sounds like a great os to use lol

Share this post


Link to post
Share on other sites

If I get time to finish off this installer, Shift2's gonna be xfce or fluxbox only, absolutely no gnome in sight (apart from the GTK libraries)

Share this post


Link to post
Share on other sites

isn't decisions like that supposed to be bases on a consensus...

Share this post


Link to post
Share on other sites

Well the consensus says that you should use Gnome in shift.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.