Jump to content



Photo

Removing Desktop Environments

Answered Go to the full post

  • Please log in to reply
9 replies to this topic

#1 Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 10
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Debian Jessie
  • Phone: Samsung Galaxy SIII

Posted 18 November 2012 - 03:26

I have been looking at different desktops, and I did believe that I did uninstall all of them that I didn't care for. I tried XFCE, Openbox, LXDE, Gnome 2.0, etc. But I still see them in the "select desktop environment".

Also, when I shut down or restart, I see the XFCE splash. Something that fully didn't uninstall?

Best Answer +Karl L. , 19 November 2012 - 00:38

To disable the splash image altogether: remove splash from the command line arguments passed to your kernel at boot time in /etc/defaults/grub, then run sudo update-grub and reboot. You will not have any splash screen. This is how I boot all of my Linux systems (because I like to see what is going on in the background while it is booting).

To change the desktop splash to something else entirely, use update-alternatives. (Note: It would be best if this image were moved to somewhere like /usr/share/images, chown to root:root, chmod to 644, and in png or svg format.)

$ sudo update-alternatives --set desktop-splash <path_to_new_splash_here>
Go to the full post



#2 redvamp128

redvamp128

    Neowinian Senior

  • Joined: 06-October 01

Posted 18 November 2012 - 04:18

http://www.ubuntugee...een-themes.html

With that you can change the Splash / Login screen... but removing them from the list I am unsure about.

Unless it is 64 bit OS

otherwise you could try to reinstall- your Favorite DE through package manager-- right click-- reinstall- this should overwrite with the correct splash you wish

You could try command line purged remove

sudo apt-get purge <program>

so it could be sudo-apt-get purgre xfce(hit tab key for auto-complete)

it should default back to a default one

http://askubuntu.com...nd-remove-purge

#3 OP Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 10
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Debian Jessie
  • Phone: Samsung Galaxy SIII

Posted 18 November 2012 - 04:33

That's not my problem. As of now, I have Gnome shell. And it does default to it. So why am I seeing the XFCE mouse pic when shutting down?

#4 redvamp128

redvamp128

    Neowinian Senior

  • Joined: 06-October 01

Posted 18 November 2012 - 04:38

That's not my problem. As of now, I have Gnome shell. And it does default to it. So why am I seeing the XFCE mouse pic when shutting down?


Because it installs it's defaults for the DE which a purgre of the package should clean it out

#5 OP Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 10
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Debian Jessie
  • Phone: Samsung Galaxy SIII

Posted 18 November 2012 - 16:43

when I run that and Tab, I get this:

david@david-ubuntu:~$ xfce4-
xfce4-about				   xfce4-popup-notes
xfce4-accessibility-settings  xfce4-popup-places
xfce4-appearance-settings	 xfce4-popup-windowmenu
xfce4-appfinder			   xfce4-power-information
xfce4-dict					xfce4-power-manager
xfce4-display-settings		xfce4-power-manager-settings
xfce4-keyboard-settings	   xfce4-screenshooter
xfce4-kiosk-query			 xfce4-session
xfce4-mime-settings		   xfce4-session-logout
xfce4-mouse-settings		  xfce4-session-settings
xfce4-notes				   xfce4-settings-editor
xfce4-notes-settings		  xfce4-settings-manager
xfce4-notifyd-config		  xfce4-taskmanager
xfce4-panel				   xfce4-terminal
xfce4-popup-applicationsmenu  xfce4-terminal.wrapper
xfce4-popup-directorymenu	 xfce4-volumed

I don't see xfce4-Common or anything... unless I just overlooked it. Sould I just purge all of these?

#6 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 18 November 2012 - 20:25

Finding/Removing Packages:

The way I check which packages are installed is using aptitude. Try the following to list installed packages for XFCE:
$ aptitude search xfce | grep -E '^i'

You can remove all installed packages for XFCE as follows:
$ sudo aptitude purge $(aptitude search xfce4 | awk '{if($1 == "i") print (($2 == "A") ? $3 : $2)}')


The Other Method:

Changing the splash screen:
That said, while purging the packages will probably resolve your problem, its not the only way to go about it. Try the following to change the splash screen:
$ update-alternatives --list desktop-splash
$ sudo update-alternatives --set desktop-splash <path_to_new_splash_here>

For example, if I wanted to revert the Debian Wheezy splash screen to that of Debian Squeeze, I would do it as follows:
$ update-alternatives --list desktop-splash
/usr/share/images/desktop-base/gnome-splash-curves.png
/usr/share/images/desktop-base/moreblue-orbit-splash.png
/usr/share/images/desktop-base/spacefun-splash.svg
$ sudo update-alternatives --set desktop-splash /usr/share/images/desktop-base/spacefun-splash.svg

Configuring the display manager:
Modifying the list of desktop environments you may choose from at the login screen is heavily dependent your display manager. For example, using slim, I can modify the sessions line in my /etc/slim.conf to suit my needs. Using lightdm or gdm, I can remove the file in /usr/share/xsessions corresponding to the desktop environment that I want to remove. (Purging the package should also remove any files it installed in that directory.)

Finally, if you installed a new display manager and would like to revert, you can easily choose a display manager from all installed alternatives by running the follow command:
$ dpkg-reconfigure lightdm # lightdm may be replaced by the package name of any display manager you have installed, such as gdm, kdm, or slim


#7 OP Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 10
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Debian Jessie
  • Phone: Samsung Galaxy SIII

Posted 18 November 2012 - 21:27

I get this:

update-alternatives: error: no alternatives for desktop-splash

I still get the Xubuntu splash on shutdown/restart. :huh:

Display Manager is fine.

On another note, I am looking at Cinnamon atm. When I hit the corner, and It shows different workspaces, they look all garbled. Although when I click on any workstation, it comes up fine. Now, this happens pretty randomly. One day it can be fine, the next can get garbled.

#8 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 18 November 2012 - 23:06

Since you don't have any alternatives listed for your splash screen, maybe you are still seeing the Xubuntu one because the original Ubuntu one was removed when you installed XFCE. I'm not quite sure which package would contain the desktop splash on Ubuntu, but it is contained in the desktop-base package in Debian. You can set the desktop splash to any image on your computer (not necessarily one installed from the repository) or disable it entirely if you wish.

As for Cinnamon, I know of it but I have never tried it. There are only a few window managers/desktop environments that I have spent enough time in to become familiar: KDE 4.7, GNOME 2.32/MATE 1.4, GNOME 3.4, Unity 5.0, XFCE 4.8, Openbox 3.5, and Awesome 3.4. Of those, I primarily use MATE and Openbox, but I try out other desktop environments on occasion. Cinnamon looks kinda neat, just not enough to entice me to try it yet.

#9 OP Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 10
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Debian Jessie
  • Phone: Samsung Galaxy SIII

Posted 19 November 2012 - 00:32

Tell me, how do you disable it or use a custom image?

#10 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 19 November 2012 - 00:38   Best Answer

To disable the splash image altogether: remove splash from the command line arguments passed to your kernel at boot time in /etc/defaults/grub, then run sudo update-grub and reboot. You will not have any splash screen. This is how I boot all of my Linux systems (because I like to see what is going on in the background while it is booting).

To change the desktop splash to something else entirely, use update-alternatives. (Note: It would be best if this image were moved to somewhere like /usr/share/images, chown to root:root, chmod to 644, and in png or svg format.)
$ sudo update-alternatives --set desktop-splash <path_to_new_splash_here>