Jump to content



Photo

Windows 8- Run everything as Administrator


  • Please log in to reply
52 replies to this topic

#46 guido.dati

guido.dati

    Resident One Post Wonder

  • Joined: 23-February 13

Posted 23 February 2013 - 20:23

It looks like that is exactly the case. The older method of disabling UAC via the slider no longer works. You must edit the registry now. You may not have noticed, but at no point does the UserAccountControlSetting.exe actually ask you for a reboot in Windows 8 when you move the slider to the bottom.


So don't even bother with the slider. Just run PowerShell as Administrator and paste the following to disable UAC:

Set-ItemProperty -Path "HKLM:\Software\Microsoft\Windows\CurrentVersion\Policies\System" -Name "EnableLUA" -Value "0"
shutdown -r -t 0

Thankf for your advice, you solved my problem. I'd say you solved several problems in my machine. For example, I could launch Calibre, but I couldn't read the book with the internal viewer if I didn't runa as administrator the application. Sounds crazy.


#47 olivex

olivex

    Resident One Post Wonder

  • Joined: 28-February 13

Posted 28 February 2013 - 10:24

Actually, as it turns out, what I posted will also break the Microsoft Store. I practically never disable UAC and was unaware of this limitation.

If you entered my registry change to disable UAC, re-enable it with the following command:

PowerShell as Administrator (This requires a restart)

Set-ItemProperty -Path "HKLM:\Software\Microsoft\Windows\CurrentVersion\Policies\System" -Name "EnableLUA" -Value "1" #Default value is 1

shutdown -r -t 0


To enable automatic silent UAC elevation for administrators without breaking the Microsoft Store you should do the following instead.

PowerShell as Administrator (This takes effect immediately)
#The following is equal to the Security Policy "User Account Control: Behavior of the elevation prompt for administrators in Admin Approval Mode" = "Elevate without prompting"
Set-ItemProperty -Path "HKLM:\Software\Microsoft\Windows\CurrentVersion\Policies\System" -Name "ConsentPromptBehaviorAdmin" -Value "0" #Default value is 2

#The following is equal to the Security Policy "User Account Control: Allow UIAccess applications to prompt for elevation without using the secure dekstop" = "Enabled"
Set-ItemProperty -Path "HKLM:\Software\Microsoft\Windows\CurrentVersion\Policies\System" -Name "EnableUIADesktopToggle" -Value "1" #Default value is 0


The two methods do not work the same.
For example, as an admin, I run notepad and edit a file in Program Files folder. With first method, I can save the file. With second method, I can't. I can save the file if I run notepad as administrator.
So, I don't like that the first method breaks Metro store, but the second method doesn't work as expected.
I think this is because notepad is run as a standard user. There is another option 'Behavior of the elevation prompt for standard users', by default it is 'Prompt for credentials'. But I don't know if I set it not to prompt, it will be too risky.

#48 TheLegendOfMart

TheLegendOfMart

    Neowinian Senior

  • Joined: 01-October 01
  • Location: England

Posted 02 March 2013 - 20:36

Is there any way to change root drive protection back to that of Windows 7, I am using programs even when UAC is disabled and I run as administrator still don't have the ability to modify files on the root drive.

#49 zerowalker

zerowalker

    Resident One Post Wonder

  • Joined: 09-March 13

Posted 09 March 2013 - 02:12

I don´t get it to work. If i disable UAC completely, everything i being run in Admin mode, as i want to. But it breaks the Store.

The other method:

#The following is equal to the Security Policy "User Account Control: Behavior of the elevation prompt for administrators in Admin Approval Mode" = "Elevate without prompting"
Set-ItemProperty -Path "HKLM:\Software\Microsoft\Windows\CurrentVersion\Policies\System" -Name "ConsentPromptBehaviorAdmin" -Value "0" #Default value is 2

#The following is equal to the Security Policy "User Account Control: Allow UIAccess applications to prompt for elevation without using the secure dekstop" = "Enabled"
Set-ItemProperty -Path "HKLM:\Software\Microsoft\Windows\CurrentVersion\Policies\System" -Name "EnableUIADesktopToggle" -Value "1" #Default value is 0

Doesn´t seem to make anything run in admin mode like normally.

#50 +techbeck

techbeck

    It's not that I am lazy, it's that I just don't care

  • Tech Issues Solved: 13
  • Joined: 20-January 05

Posted 09 March 2013 - 02:41

group policy or local group policy > Computer configuration > policys > windows >security > local

Silently elevates and dosnt brake the windows store, Good enough for a home network (Y)


Thank you for this. We always disable UAC since it interferes in what we are doing. Was setting up a few Surface Pros and was annoyed that I couldnt use the apps if UAC was off.

#51 Thanal

Thanal

    Resident One Post Wonder

  • Joined: 20-June 13

Posted 20 June 2013 - 05:59

I have been reading this thread, and many of you make good points.  I have never disabled system restore myself, however I could see how you might want to reclaim disk space it takes up especially if you do regular backups.  Most people don't backup their PCs. At least that's been my experience.

 

As for UAC, yeah, it looks like launching things as Administrator by default can NOT be done without breaking lots of Metro apps. You can auto-allow processes to elevate when requested, but several of you want to force everything to be elevated by default.
 

Proceed with caution!  There are plenty of good reasons why UAC exists.  But here are a couple of things you can do.

 

First of all, it's not the shortcut that you'd modify for "run as administrator".  It's the 'properties' on the executable.  This is an important distinction because it means if you set the "Run this program as an administrator" attribute on an executable, it doesn't matter how you run it (from command line, from shortcut, etc.) that program will run as administrator.
 

Secondly, you do not have to modify every program.  A process will automatically be elevated if the parent process is elevated.  So if you always launch your processes from one parent, make that parent run 'as an administrator' and you're set.

 

I can think of three likely UI entry points for launching new processes:
- The Metro screen "search" feature
- The old-school Run box which is still accessible via the [Start]-R key combination
- You might launch processes using a classic start menu such as 'Classic Start Menu'

 

In all three cases, the parent is c:\windows\explorer.exe.

 

Unfortunately, you cannot make explorer "run as administrator" because there are no "properties" exposed for explorer.exe in the UI. However, there are ways to run explorer.exe elevated.  For example:
1. Launch an elevated command prompt  (cmd or powershell)
2. taskkill /im:explorer.exe /f
3. run explorer by typing "start explorer" - or if you're in powershell, you'll type "iex explorer"

This kills the existing explorer process and replaces it with an elevated one.

 

I found a simple tool called "U Are in Control" which makes this a little easier. It will work in Windows 8 RT or full, as it is just scheduled tasks and CMD scripts.  It lets you shift into 'everything is admin' mode when you want to run normally, and switch back into 'everything is normal' mode when you need to launch Metro apps.  When in 'normal' mode, only new processes are run with normal privilege.  Existing processes would still run as admin.

 

 

Attached Files



#52 justmike

justmike

    Neowinian

  • Joined: 01-July 08

Posted 02 December 2013 - 21:22

On a domain PC, as an admin, but having many of the same problems. It looks like only the local admin / owner works for some installs. Once I took ownership of all the files and folders in the install, everything started working.



#53 Kranitz

Kranitz

    Resident One Post Wonder

  • Joined: 09-December 13

Posted 09 December 2013 - 16:53

Set-ItemProperty -Path "HKLM:\Software\Microsoft\Windows\CurrentVersion\Policies\System" -Name "EnableLUA" -Value "0"
shutdown -r -t 0

 

This worked perfectly for me - I was struggling getting things like webex and gotomeeting to run, so I was always futzing around with my settings and having to "run as administrator" wherever possible... Thanks a lot!