Jump to content



Photo

Why is HDMI Not Working for my Monitor?

hdmi nvidia

  • Please log in to reply
9 replies to this topic

#1 Pubudu Kodikara

Pubudu Kodikara

    Neowinian

  • Joined: 16-April 12

Posted 22 November 2012 - 00:24

I just bought a new 23inch Samsung Monitor (S23B370). It have full HD support and also have an HDMI port. I bought a HDMI cable which have HDMI on both ends. I have a VGA (Nvidia 210) which also have an HDMI port. I connected the monitor's HDMI out to the VGA's HDMI port with the new cable and booted. Nothing came. I even set the Monitor's settings to HDMI. But nothing happened. It says check display cable. Why is this? How to fix it? Have I done something wrong?


#2 Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 13
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Debian Jessie
  • Phone: Samsung Galaxy SIII

Posted 22 November 2012 - 00:29

Are you sure your monitor is set to the HDMI setting? Mine has DVI and VGA, and I have to switch between the 2.

#3 jasondefaoite

jasondefaoite

    Neowinian

  • Tech Issues Solved: 2
  • Joined: 04-October 02
  • Location: Ireland - Singapore

Posted 22 November 2012 - 00:33

Boot the PC with both VGA and HDMI connected. Select VGA on the monitor. Once at the desktop, launch the Nividia settings app and enable HDMI output there.

Posted Image

#4 Motoko.

Motoko.

    Neowinian Senior

  • Joined: 04-November 09
  • Location: United States of America
  • OS: Windows 8 Pro

Posted 22 November 2012 - 00:34

It's easy to break an hdmi cable even by bending it.

If you can get another hdmi cable to try it with, see what happens.

#5 OP Pubudu Kodikara

Pubudu Kodikara

    Neowinian

  • Joined: 16-April 12

Posted 22 November 2012 - 00:38

It works with my laptop... but on both PCs, it won't :(

Are you sure your monitor is set to the HDMI setting? Mine has DVI and VGA, and I have to switch between the 2.


Yep... im sure :)

Boot the PC with both VGA and HDMI connected. Select VGA on the monitor. Once at the desktop, launch the Nividia settings app and enable HDMI output there.

Posted Image



Perfect... I'll try and see :) Know how to enable it on Ubuntu?

#6 Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 13
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Debian Jessie
  • Phone: Samsung Galaxy SIII

Posted 22 November 2012 - 01:06

You need to install the drivers from Additional Drivers.

#7 OP Pubudu Kodikara

Pubudu Kodikara

    Neowinian

  • Joined: 16-April 12

Posted 22 November 2012 - 01:34

You need to install the drivers from Additional Drivers.


Already installed :)

#8 Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 13
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Debian Jessie
  • Phone: Samsung Galaxy SIII

Posted 22 November 2012 - 02:45

I think (don't quote me on this) you need the following:

sudo apt-get install nvidia-current nvidia-settings

And then there should be a nvidia controlcenter-like program.

#9 OP Pubudu Kodikara

Pubudu Kodikara

    Neowinian

  • Joined: 16-April 12

Posted 22 November 2012 - 02:49

Thanks a lot for the help everyone! The problem is with the PC's HDMI port. Because of the deign of the casing, the cable won't fit completely. After fixing it, now HD is working! :)

#10 PGHammer

PGHammer

    Neowinian Senior

  • Tech Issues Solved: 1
  • Joined: 31-August 03
  • Location: Accokeek, MD
  • OS: Windows 8 Pro with Media Center x64

Posted 22 November 2012 - 02:57

Thanks a lot for the help everyone! The problem is with the PC's HDMI port. Because of the deign of the casing, the cable won't fit completely. After fixing it, now HD is working! :)


Good!

Why this can be important - in all too many cases, HDMI has a higher (not lower) resolution than any other option.

Example: My Acer H233H.bmid supports 1920x1080 via any of the three video inputs it supports (DVI, D-sub, or HDMI) - however, HDMI is unique in having a 75Hz (standard - not overdriven) setting; the other two inputs have a 60 Hz NI ceiling at that resolution.