Jump to content



Photo

Memory Compatibility H67 chipset


  • Please log in to reply
2 replies to this topic

#1 TheLegendOfMart

TheLegendOfMart

    Neowinian Senior

  • Joined: 01-October 01
  • Location: England

Posted 29 November 2012 - 13:16

I have :-

MSI H67MA-E35 (B3) MATX Board
Core i5 2400 CPU
2x 2Gb DDR3 1600 Ram 1.5v
600W PSU

My mate has just upgraded to faster memory and I got these on the cheap, I know for a fact they work fine.

The memory I got off him is 2x 8Gb DDR3 1600 1.5v.

On MSI website it says it supports up to 16Gb in 2x 8Gb module configuration. I have upgraded to the latest BIOS but when I put the ram in my PC just starts up, doesnt post and shuts down again and just does it in a loop.

I've tried resetting the bios, putting each stick in on its own and both in at same time, but nothing I do works.

I know my CPU only supports max 1333 ram but its been running 1600mhz ram downclocked fine.

Is there something I'm doing wrong?


#2 +PeterUK

PeterUK

    Neowinian Senior

  • Tech Issues Solved: 3
  • Joined: 26-March 07

Posted 29 November 2012 - 16:46

Try one stick and then try that one stick in the other slot.

With your old ram in the BIOS set for 1333MHz set timing for the ram to 9-9-9-24 and voltage to 1.65V then try the other RAM.

#3 OP TheLegendOfMart

TheLegendOfMart

    Neowinian Senior

  • Joined: 01-October 01
  • Location: England

Posted 29 November 2012 - 17:12

Yeah I tried all that, didn't post at all. I know it works cause I took it back to my mates, ended up buying a refurbed Z68 board, hopefully wont have any issues.



Click here to login or here to register to remove this ad, it's free!