Jump to content



Photo

Got a Lumia 920: My thoughts after 48hrs


  • Please log in to reply
77 replies to this topic

#76 OP AR556

AR556

    Neowinian Senior

  • Joined: 07-August 03

Posted 13 December 2012 - 12:17

You mentioned that as your background noise. this isnt 1950 :p


Oh, I had forgotten what I wrote in my original post. I was kidding. Thew it in for laughs :laugh:


#77 Muessig

Muessig

    Neowinian

  • Joined: 30-August 04
  • Location: UK

Posted 13 December 2012 - 20:39

Guys I was hearing about updates for other people but I wasn't getting them for 4/5 days but here's how I solved it.

I'm in the UK and whenever I know there's an update (usually find out from WPCentral) I leave my data on from about 11am through to 5pm. This works flawlessly every time there is an update I get it. The store checks at certain times each day for updates - I've narrowed it down to somewhere between 1-4pm in the afternoon that my device checks. Try it out and see if it works for you too! :D

#78 OP AR556

AR556

    Neowinian Senior

  • Joined: 07-August 03

Posted 14 December 2012 - 11:16

Guys I was hearing about updates for other people but I wasn't getting them for 4/5 days but here's how I solved it.

I'm in the UK and whenever I know there's an update (usually find out from WPCentral) I leave my data on from about 11am through to 5pm. This works flawlessly every time there is an update I get it. The store checks at certain times each day for updates - I've narrowed it down to somewhere between 1-4pm in the afternoon that my device checks. Try it out and see if it works for you too! :D


I had about 10 updates for my newly-replaced phone this morning. Notable were network+, calls and sms and nokia enhancements. Also, I was mistaken in a previous post when I said Nokia Drive wasn't beta. I had forgotten that its not really installed till you open it for the first time. Once I installed it, it was still beta.

Took this phone off the charger yesterday morning and let it sit all day unused. When I got home 9 hours later, it still said 100% charge. No changes were made to settings, no additional apps were installed and no email accounts were set up.