Jump to content



Photo

Linux, as a Whole


  • Please log in to reply
333 replies to this topic

#331 ViperAFK

ViperAFK

    Neowinian Senior

  • Tech Issues Solved: 2
  • Joined: 07-March 06
  • Location: Vermont

Posted 26 January 2013 - 17:36

Funny, but on thi forum alone, every person who's tried to install the proprietary nvidia drivers on ubuntu/Mint has ran into the missing GUI and needing workarounds issue. I've seen it on several computers, all in fact. So I kinda doubt it "works for most" people. I'd say most people never install the proprietary drivers, or they do the horrible workarounds to make them work.


I haven't looked at all those threads, but at least a few of the cases I saw were PEBKAC lol (trying to install the .run file from nvidia/ati instead of using the more reliable solution of using the included automated installer). My old laptop had an AMD card and I was always able to enable it via ubuntu's driver installer. I do agree that the proprietary drivers definitely aren't perfect and tend to be more problematic than the OSS drivers (I chose to go intel on my current laptop so I wouldn't have to deal with them), but I wouldn't say that they just don't work at all for most people based on some forum posts.


#332 HawkMan

HawkMan

    Badass Viking

  • Tech Issues Solved: 3
  • Joined: 31-August 04
  • Location: Norway

Posted 26 January 2013 - 17:37

I've exclusively installed them from repo, and they've without fail, failed.

#333 ViperAFK

ViperAFK

    Neowinian Senior

  • Tech Issues Solved: 2
  • Joined: 07-March 06
  • Location: Vermont

Posted 26 January 2013 - 17:56

I've exclusively installed them from repo, and they've without fail, failed.


Looks like we can blame canonical for this. Apparently the proprietary drivers inexplicably failing when installed using jockey or additional drivers is a somewhat recently introduced ubuntu bug, and the driver installer used to work fine (link also shows how to get the repo drivers working): http://www.dedoimedo...zal-nvidia.html

EDIT: here's the relevent bug(s) for the proprietary drivers failing to install https://bugs.launchp...es/+bug/1068341, https://bugs.launchp...ty/+bug/1070427. Hopefully they get this sorted out soon because it does certainly give a bad impression, and is a pretty bug regression.

#334 Shadowzz

Shadowzz

    Neowinian Senior

  • Joined: 16-April 10
  • Location: Netherlands
  • OS: Windows 8 Pro 64bit
  • Phone: Nokia Lumia 920

Posted 26 January 2013 - 18:11

Linux only works if your among the happy few with properly supported hardware. Outside that its only good/decent use is to use them as servers.
Windows surely has its issues, but Ubuntu for example has quite some issues as well. (I'm more of a Debian fan though). However Ubuntu does push Linux development in a positive aspect, although I'm not a fan of them using Debian Sid packages as their 'stable' packages. And is IMO where most of the issues come from.
Other then that, as long as your within the hardware range of their support. Its a great substitute for Windows.

I tried Ubuntu again last night. My goal was to see if I could get GuildWars 2 running on it following a video posted on YouTube showing a 'how to'.
I fell at the first hurdle which was to install PlayOnLinux. The software is in the software centre but refuses to install due to dependencies I came across a post saying this is a x64 issue. After failing to get it working following forum posts I read I gave up and re-installed with a x86 install. It installed straight away.
I don't want to use a 32bit OS though so re-installed with x64 and will try again tonight to resolve the issue.

Sadly this though is the same story I have with Linux each time I try it. As much as its moved a hell of a lot over the years, and continues to do so I might add, it's still a ball ache for new comers to the OS when things don't work.

Ubuntu for me has done some amazing work for the Linux OS. For me all default desktop environments have been fugly. Ubuntu though is a decent looking OS out of the box. I can't say though I am happy with the Unity launcher and when you search for you installed apps it returns shopping results. To me this is simply another form of advertising.

Sounds like you need to install the 32bit dependencies on the 64bit install. Like Windows, Linux can do both 32bit fully under 64bit. However most distros do not come with these 32bit dependencies by default.



Click here to login or here to register to remove this ad, it's free!