Jump to content



Photo

Windows 8 display completely blank after waking monitor

win8

  • Please log in to reply
4 replies to this topic

#1 Orbiting234

Orbiting234

    Neowinian

  • Joined: 06-January 13

Posted 06 January 2013 - 06:27

Alright, this one has me stumped.

On my desktop PC that I leave on all the time I have the "Turn off the display" set to 30 minutes and works as advertised. The computer itself is never put into a sleep or hibernation state. However upon waking up the display it correctly turns back on the monitor but displays nothing but a black screen. Same on secondary monitor, it is on and outputting nothing more than a black screen. No mouse cursor, no nothing. This worked just fine under Windows 7 with the exact same video driver (tried both AMD Catalyst 12.10 and AMD Catalyst 12.11 Beta11).

Looking around online I see some people having a black screen issue from a full hibernation state but like I said above I don't use hibernation at all. Granted, I can just manually turn off my monitor all the time but eventually I'd wear out that switch and the automatic "Turn off the display" has always been a great feature of Windows operating systems.

Any ideas?


#2 lars77

lars77

    Neowinian

  • Joined: 18-April 08
  • Location: USA

Posted 06 January 2013 - 18:55

Not sure if maybe there's just some issue w/ AMD + Win 8? Or just Win 8 being.. Win 8.

I also get weird display glitches on Win 8 Pro. My desktop has a Radeon HD 7970, currently using the AMD Catalyst 12.10 drivers. My desktop is also always on, but it does turn off the display after 30 mins. One of two things sometimes happens when I "wake" the display by moving the mouse, etc:

A. The display comes back, but the resolution is resized to something ridiculous like 640x480. I have to right-click on the Desktop, bring up "Screen Resolution", then click "Detect", then click OK. This always fixes it. It's like Win 8 forgets what monitor I have plugged in?

B. The display doesn't wake up at all, stays black. When this happens, I haven't found a workaround, I *always* need to turn off the computer. Interestingly, when it's in this state & I press the computer's power button the computer will power off right away. It's like it was busy trying to shut down on its own for some reason & instead of a proper shutdown it hung up?

So yeah, I don't have any solutions, but have seen similar things. Not related, but my Win 8 computer is also doing this weird thing where sometimes it gets stuck repeating a system sound (I think the sound file associated to the New Mail sound?), I have no idea why it's doing it.. restarting the computer seems to fix it temporarily, but I can't figure out if it's Windows or some program in the background, or even if it's from the desktop or from Metro??

Ugh, definitely thinking of switching back to Win 7, never had these issues before! But I'd be curious if you manage to get any further w/ the display issue.

#3 migo

migo

    Neowinian Senior

  • Joined: 02-May 05

Posted 06 January 2013 - 20:11

I have this happen, but only with HDMI output. VGA it's fine. (No DVI). Which output are you using?

#4 OP Orbiting234

Orbiting234

    Neowinian

  • Joined: 06-January 13

Posted 06 January 2013 - 20:46

I have this happen, but only with HDMI output. VGA it's fine. (No DVI). Which output are you using?


DisplayPort and HDMI.

#5 migo

migo

    Neowinian Senior

  • Joined: 02-May 05

Posted 06 January 2013 - 21:40

DisplayPort and HDMI.


Try with VGA and see if it still happens.