Jump to content

28 posts in this topic

Posted

I installed Steam and Steam games to J:\

At a later date, I changed this drive's letter to D:\

J:\ is now a different drive (contains only my music).

When I try to run a game, I get [i]"Failed to start game (missing executable)"[/i]

If I go to the game properties, choose Local Files and Browse Local Files, it creates and takes me to: J:\program files (x86)\steam\steamapps\common\dead island

Of course, this newly created directory that Steam just made is empty.

How can I fix this, without having to re-download the entire games again? (which is what "Verify Integrity of Game Cache" tries to do)

Share this post


Link to post
Share on other sites

Posted

Do this

https://support.steampowered.com/kb_article.php?ref=7710-tdlc-0426

Make sure you have the steamapps folder and steam.exe in a folder and ONLY those files and open steam.exe up and in a couple of min you're good to go!

Share this post


Link to post
Share on other sites

Posted

You could try using Junction Points (Windows implementation of symbolic links) to point Steam to the correct location - so when it looks in the J: drive folder it has created, it gets sent back to your D: drive, where the files actually exist. Failing that, a reinstall may be on the cards.

Share this post


Link to post
Share on other sites

Posted

[quote name='HoochieMamma' timestamp='1357650993' post='595440050']
Do this

[url="https://support.steampowered.com/kb_article.php?ref=7710-tdlc-0426"]https://support.stea...=7710-tdlc-0426[/url]

Make sure you have the steamapps folder and steam.exe in a folder and ONLY those files and open steam.exe up and in a couple of min you're good to go!
[/quote]

Just tried that, it did not work unfortunately. Still getting the same error.

In fact, even after doing this, when I try to run the game, I still get an empty [i]J:\program files (x86)\steam\steamapps\common\dead island[/i] directory created by Steam.

Share this post


Link to post
Share on other sites

Posted

Easiest way is to change the drive letter back.

Share this post


Link to post
Share on other sites

Posted

[quote name='King Mustard' timestamp='1357651071' post='595440056']
Just tried that, it did not work unfortunately. Still getting the same error.

In fact, even after doing this, when I try to run the game, I still get an empty [i]J:\program files (x86)\steam\steamapps\common\dead island[/i] directory created by Steam.
[/quote]

You definitely ONLY had the steamapps folder and steam.exe in a folder called "Steam" nothing else right, deleting everything else except those 2 files/folders right? I have done it tons of times and it always fixes issues if you screw around with drive letters or move the Steam dir completely :/

Share this post


Link to post
Share on other sites

Posted

[quote name='HoochieMamma' timestamp='1357651687' post='595440078']
You definitely ONLY had the steamapps folder and steam.exe in a folder called "Steam" nothing else right? I have done it tons of times and it always fixes issues if you screw around with drive letters or move the Steam dir completely :/
[/quote]

That's definitely what I did. It seems my Steam.exe still has references to J: inside it.

I am going to try moving the SteamApps folder to the root of the drive, uninstalling Steam, cleaning the registry and all references to Steam, re-install, and move the SteamApps folder back.
1 person likes this

Share this post


Link to post
Share on other sites

Posted

Wanted to suggest to reinstall Steam to the new folder location, but seems like you already thought of that.

Share this post


Link to post
Share on other sites

Posted

[quote name='Ryoken' timestamp='1357651128' post='595440062']
Easiest way is to change the drive letter back.
[/quote]

This. Why not just change it back?

Share this post


Link to post
Share on other sites

Posted

[quote name='-Himanshu-' timestamp='1357651938' post='595440092']
This. Why not just change it back?
[/quote]

Why is that your business?

Stay on topic.

Share this post


Link to post
Share on other sites

Posted

[quote name='King Mustard' timestamp='1357652190' post='595440114']
Why is that your business?

Stay on topic.
[/quote]
Because you asked for help and that would be the easiest way to do it?

Share this post


Link to post
Share on other sites

Posted

[quote name='DirtyLarry' timestamp='1357652388' post='595440122']
Because you asked for help and that would be the easiest way to do it?
[/quote]

It's obvious that that would fix it, but since I'm here, it's also obvious I don't want to do that.

I changed it for a reason in the first place, which include buying new drives, moving content around and re-organising my various drives.

Share this post


Link to post
Share on other sites

Posted

[quote name='King Mustard' timestamp='1357652190' post='595440114']
Why is that your business?

Stay on topic.
[/quote]


Don't be rude, man. You're here asking for people's help.

This should have worked: https://support.steampowered.com/kb_article.php?ref=7710-tdlc-0426

I've used backing up/moving the steamapps directory 1/2 a dozen times before and it worked every time.

Share this post


Link to post
Share on other sites

Posted

I tried moving the SteamApps folder to the root of the drive, uninstalling Steam, cleaning the registry and all references to Steam, re-install, and move the SteamApps folder back.

Even now, it's not working [i]and[/i] Steam is still creating the directories I mentioned a few posts above on the J: when I try to run the game.

Where is it still getting this J: reference from? :|

[b]EDIT:[/b] In the game properties, on the Local Files tab, it says "Disk usage 6737 MB on drive J:". Argh.

Share this post


Link to post
Share on other sites

Posted

Maybe look in Steam -> Settings -> Downloads + Cloud -> Steam Library Folders?

Share this post


Link to post
Share on other sites

Posted

[quote name='protocol7' timestamp='1357652845' post='595440140']
Maybe look in Steam -> Settings -> Downloads + Cloud -> Steam Library Folders?
[/quote]

It shows only one, D:\Program Files (x86)\Steam - which is correct.

It seems I'll just have to re-download the game tonight between 00:00 and 08:00 (when I can download freely - I have a 250 GB monthly cap the rest of the time).

I used "Delete Local Game Content" then choose to start the re-download. It asked which directory, I choose D:. I have paused the download until midnight, but at least the Local Files tab now correctly shows "Disk usage: 6737 MB on drive J:"

Share this post


Link to post
Share on other sites

Posted

Seems like it would just be better to put the Steam Drive back, and change the drive letter of the music drive.. Then you don't have to worry about your caps or anything. But if you are insistant on using the new directory, then redownloading is probably your only option.

Share this post


Link to post
Share on other sites

Posted

[quote name='Ryoken' timestamp='1357653415' post='595440154']
Seems like it would just be better to put the Steam Drive back, and change the drive letter of the music drive.. Then you don't have to worry about your caps or anything. But if you are insistant on using the new directory, then redownloading is probably your only option.
[/quote]

It shouldn't be my only option, but it is.

At least it's "solved" now.

Share this post


Link to post
Share on other sites

Posted

[quote name='King Mustard' timestamp='1357652190' post='595440114']
Why is that your business?

Stay on topic.
[/quote]

Because you just mentioned that you just put songs there, which won't require fixed drive letter. You know, sometimes alternatives can work. You know, you could just have given a reason instead of being a hardass.

But, I guess none of this is my business. Bye and a good day to you. :)
1 person likes this

Share this post


Link to post
Share on other sites

Posted

Moving your Steam installation didn't work so your only two options are to: A) Change your drive letter back or B) Re-download your games. If I were you, I would've simply re-downloaded the game. You can leave the download running overnight when your monthly bandwidth is unlimited. And even if your download doesn't finish between midnight and 8 AM, you have a 250 GB limit. I have a 300 GB limit that's shared with six other people in my house and we almost never go past 200 GB.

Share this post


Link to post
Share on other sites

Posted

[quote name='Anaron' timestamp='1357664821' post='595440518']
Moving your Steam installation didn't work so your only two options are to: A) Change your drive letter back or B) Re-download your games. If I were you, I would've simply re-downloaded the game. You can leave the download running overnight when your monthly bandwidth is unlimited. And even if your download doesn't finish between midnight and 8 AM, you have a 250 GB limit. I have a 300 GB limit that's shared with six other people in my house and we almost never go past 200 GB.
[/quote]
My dad uses 100 GB per month of HD Netflix streaming alone, so 250 GB is easily used in our house between him and me.

I was hoping to avoid re-downloading because when I posted the topic, it was 12 hours until
I could begin the download and I wanted to play ASAP :p I'll just be patient.

Share this post


Link to post
Share on other sites

Posted

Junction Points are the easiest way ;)

Share this post


Link to post
Share on other sites

Posted

Hmm, I have changed drive letters in the past, and I've been able to preserve all my Steam games (without having to go through the hassle of re-downloading). You can also just move your entire Steam folder without uninstalling it to a different drive, and just open up Steam to have it configure itself. It's really very easy! Alternatively, you can create a new library on a different (drive/partition), and install future games on the new library. This is a very handy feature for me, since one of my SSD's is dedicated to Steam.

Share this post


Link to post
Share on other sites

Posted

Just want to say it's odd that this didn't work (moving the folder). About 2 weeks ago my Steam games became too much for my SSD. So I copied the SteamApps folder and the Steam exe into "D:\Games\Steam" and deleted the old stuff (on my C drive). I then ran Steam and told it to Install the games I had already downloaded (The ones in SteamApps), it said something along the lines of "detecting existing files", then added the games to my Steam Library showing ready to play. From then on they have worked without issue and without redownloading.

Sounds like your system (or steam) somehow got corrupted if it is stuck looking on that one drive......what would have happened if you removed the J drive completely (temporarily, of course)? It would have had no choice but to look for a new directory since J wouldn't even have existed.

Share this post


Link to post
Share on other sites

Posted

You should be able to fix this problem by going into the appmanifest files in your steamapps directory. These files can be edited with any text editor. Fix any of the "installdir" and/or "appinstalldir" values that are in these files to point to the game's new location. Make sure you restart steam after doing this or close steam before doing it. Unfortunately I don't know why this problem occurs.
2 people like this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.