Sign in to follow this  
Followers 0
longgonebn

My Linux Based Questions

73 posts in this topic

Your a genius. I didn't think that could have been a problem.

I am using PCManFM at the moment, and I tried launching the .deb file in default nautilus and it works like normal.

So I guess the question is, why is PCManFM having an issue and is there any solution? Not the biggest hassle to get these things installed obviously, but I would rather be able to do it from my choice of file manager.

Share this post


Link to post
Share on other sites

Your a genius. I didn't think that could have been a problem.

I am using PCManFM at the moment, and I tried launching the .deb file in default nautilus and it works like normal.

So I guess the question is, why is PCManFM having an issue and is there any solution? Not the biggest hassle to get these things installed obviously, but I would rather be able to do it from my choice of file manager.

pcmanfm does weird things with URI's apparently, its a nice file manager but its given me similar problems in the past (when I try to open a video from a mounted samba share in pcmanfm vlc would spit out a similar error, it would work fine in nautilus).

so it does sound you are indeed running into this bug: https://bugs.launchp...ter/+bug/752376 (pcmanfm is mentioned in the comments). What is strange is that according to the bug report software-center should now support this type of URI :/

EDIT: What version of ubuntu are you using? The fixed released note only mentioned quantal, it may not be fixed in 12.04 which would make sense as to why you still experience the issue.

I'd recommend giving gdebi a shot and see if it lets you open debs from pcmanfm, IMO gdebi is better than software-center for installing local .debs anyway, its much quicker. If it works you could set gdebi as the default for .debs and be good to go!

Share this post


Link to post
Share on other sites

pcmanfm does weird things with URI's apparently, its a nice file manager but its given me similar problems in the past (when I try to open a video from a mounted samba share in pcmanfm vlc would spit out a similar error, it would work fine in nautilus).

so it does sound you are indeed running into this bug: https://bugs.launchp...ter/+bug/752376 (pcmanfm is mentioned in the comments). What is strange is that according to the bug report software-center should now support this type of URI :/

EDIT: What version of ubuntu are you using? The fixed released note only mentioned quantal, it may not be fixed in 12.04 which would make sense as to why you still experience the issue.

I'd recommend giving gdebi a shot and see if it lets you open debs from pcmanfm, IMO gdebi is better than software-center for installing local .debs anyway, its much quicker. If it works you could set gdebi as the default for .debs and be good to go!

Yea I am on 12.04. If it's an issue that's not going to get fixed, I am ok with that. It's not that hard to open up Nautilus and run the .deb file. It's not like I need to do it all the time lol

I'm also not one for installing software that does the same thing as something else already installed, picky I know, but ya know.

Thanks.

Share this post


Link to post
Share on other sites

How do I auto-mount drives on boot up? I have 4 internal media drives that need to be mounted automatically.

I have tried in the past and have caused issues with things. Easiest way possible?

Thanks.

Share this post


Link to post
Share on other sites

I think they should be automatically mounted these days. Either way, if you have to manually mount an internal drive on boot, you can add it to your /etc/fstab file (Ubuntu info: 1, 2).

It goes without saying that you should be careful when editing your fstab file, as you can screw up your system with a bad fstab, although it's nothing that can't be recovered as long as you back up your original fstab.

Share this post


Link to post
Share on other sites

I believe fstab is the way I tried last time. So I'd rather avoid it this time if I could?..

*is this all I have to do?

up a terminal -


  • sudo blkid - note the UUID of the partition you want to mount.

  • sudo nano /etc/fstab - copy the following line to the end of the file - UUID=xxxxyyyy /path/to/partition (add ntfs-3g if it is an NTFS partition) uid=1000,gid=1000,umask=0022,sync,auto,nosuid,rw,nouser 0 0

  • Save the file and restart computer to check.

If so, /path/to/partition would be /media/Shows if that is my drive named Shows? Or is it looking for a full path? And that code doesn't change anything else about the drive right? Just that it now auto mounts on start up...

So for my Shows drive it would be..

UUID=0eaf61f0-f491-465b-af62-a59b350118c3 /media/Shows uid=1000,gid=1000,umask=0022,sync,auto,nosuid,rw,nouser 0

Right..?

Share this post


Link to post
Share on other sites

I think so, although I wouldn't call myself the king of fstab. You'd obviously need to create the directory /media/Shows in advance (as well as for the other drives). You should (IIRC) be able to simply check your changes by adding the line to /etc/fstab and then calling "sudo mount -a" and seeing if it mounts. If it doesn't adjust as necessary until it does.

Share this post


Link to post
Share on other sites

You just confused me.

My drives are mounted, because I clicked on it and mounted it.

What do you mean create the directory before hand....that is the directory of the drive??

Share this post


Link to post
Share on other sites

You just confused me.

My drives are mounted, because I clicked on it and mounted it.

What do you mean create the directory before hand....that is the directory of the drive??

Linux file systems are fairly object based in that a folder on one drive (or appearing there as viewed by the filesystem) can actually be a symlink to an entirely different folder. I generally like to mount a drive as an object, then create a base folder structure on it to link to... if this fits what you want to do, you've got a couple part process.

#1 for the sake of flexibility, I'd mount the drive under /mnt/drivename (pick one) instead of mounting directly to your filesystem.

#2, as Majesticmerc said, use your mounting in fstab so that if you break a mount point, you don't get locked out on reboot. unmount your drive, create the uuid entry in fstab (your line above looks correct to me, change out /media/Shows portion for /mnt/drivename from above.) then call sudo mount -a which should run through your fstab file and attempt mounts. if the feedback it gives you is confusing, just enter "show mount" in terminal and you should see your drive listed.

#3 sudo mkdir /mnt/drivename/Shows (actual data storage location)

#4 cd /media (puts you where you want to link)

#5 ln -s /mnt/drivename/Shows Shows (creates a symlink from this directory to the mounted drive, explicitly named)

I know this is more steps than are actually needed, but gives you the flexibility of moving other directories to the drive for additional storage if needed. for example, /mnt/drivename/Movies, and allowing you to keep the files separate. Personal preference, but I tend to try to error on the side of future flexibility.

Share this post


Link to post
Share on other sites

I honestly didn't understand any of that.

All I know is my drives are under /media and that's it. I don't really want to fiddle around. I guess I am stuck with manual mounting.

The problem is I have programs that have permissions to those locations, the drives as is, if I change something everything is messed up.

Share this post


Link to post
Share on other sites

is it an external drive?

so say you want to mount it to /home/shows

i would try adding

UUID=xxxxyyyy /home/shows ext4 defaults 0 0

change the ext4 if its a different type

for example this is my fstab


UUID=55863616-9993-484a-8112-644e48540019 / ext4 discard,noatime,nodiratime,defaults 1 1
UUID=a413c0d4-5583-42f4-88b1-413e950ee0bd /boot ext4 discard,noatime,nodiratime,defaults 1 2
UUID=bfbcfd6d-2d47-46f0-ba15-cba0bc5ccfbe /home ext4 discard,noatime,nodiratime,defaults 1 2
UUID=1ec148df-8757-4980-a242-f95c40068194 /swap ext4 discard,noatime,nodiratime,defaults 1 2
none /tmp tmpfs defaults 0 0
/dev/sda1 /home/haggis/Storage ext4 defaults 0 0
[/CODE]

Share this post


Link to post
Share on other sites

You just confused me.

My drives are mounted, because I clicked on it and mounted it.

What do you mean create the directory before hand....that is the directory of the drive??

Drives must be mounted in a specific directory, and that directory must exist beforehand. Now if you're mounting the drive through your file browser (e.g. Nautilus, Dolphin, Thunar, PCManFM, etc), this directory will be created automatically, and deleted when you unmount the drive. If you want to mount the drive manually at boot-time, you'll have to create these directories inside /media using mkdir as a super user (i.e. root) while the drives are already unmounted.

Next, create the fstab lines as discussed, and use the "mount -a" command (or mount /media/Shows) as super user to test your fstab. Once everything is working your disks should be mounted on boot.

I'd recommend taking a look at this article on the Arch Linux wiki for a bit more insight on working with fstab: https://wiki.archlinux.org/index.php/Fstab. It's not Arch specific, and very informative IMO.

Share this post


Link to post
Share on other sites

I honestly didn't understand any of that.

All I know is my drives are under /media and that's it. I don't really want to fiddle around. I guess I am stuck with manual mounting.

The problem is I have programs that have permissions to those locations, the drives as is, if I change something everything is messed up.

Heh I'll add a little note to try to relieve your confusion.

In linux, EVERYTHING in your computer is a device. Everything is in /dev. But it's not as simple as opening something up in /dev, it has to be 'mounted', or 'interpreted' with the proper driver.

Now, in Ubuntu, most drives are automatically mounted once you click them in the file manager (And maybe enter your administrator password).

So like the guys are trying to explain before me, if you want to force mount a drive on boot, you need to first make a folder anywhere (Although it's probably better for organisation-sake if you just create one in /media, but that's up to you) and then add the fstab line they mentionned earlier.

To create a folder in anywhere but /home, do sudo mkdir /path/directory (For example, sudo mkdir /media/musicdrive).

Share this post


Link to post
Share on other sites

So right now I manually mount my drive from within PCManFM. Which creates

/media/Media

/media/Shows

/media/Movies

/media/Films

If I want that to happen automatically on start up I would want to unmount the drives and do this.

sudo mkdir /media/Media

sudo mkdir /media/Shows

sudo mkdir /media/Movies

sudo mkdir /media/Films

Then add this line for each at the end of fstab.

UUID=0eaf61f0-f491-465b-af62-a59b350118c3 /media/Shows uid=1000,gid=1000,umask=0022,sync,auto,nosuid,rw,nouser

Then do mount -a to test the new mount points before rebooting? (And no these are all internal drives)

Correct?

Share this post


Link to post
Share on other sites

That is correct, although obviously the uuids will be different. :)

Share this post


Link to post
Share on other sites

If something on my system, a program, uses those drives, accesses /media/Shows etc all the time.

Once this is done, will that program still be able to do that, or will I need to re-add the directory to the application?

I assume it's going to be the same, but want to make sure.

Share this post


Link to post
Share on other sites

I found a ubuntu bug where if you try to install ubuntu over an already installed ubuntu, theres absolutely no problem seeing the wifi password in the clear provided an account has wifi setup on the machine, without entering any user account infos or anything. It pops up during the install for downloading updates... Discovered by accident due to bad installed graphic drivers.

Share this post


Link to post
Share on other sites

I just followed the instructions, when I do sudo mount -a I get the following

mount: unknown filesystem type 'nouser'

mount: unknown filesystem type 'nouser'

mount: unknown filesystem type 'nouser'

mount: unknown filesystem type 'nouser'

Do I need to put ext4 somewhere in those lines?

Like I have

UUID=12498dda-899a-4e48-9d6e-a5372340f3dd /media/Movies uid=1000,gid=1000,umask=0022,sync,auto,nosuid,rw,nouser 0

Should I put

UUID=12498dda-899a-4e48-9d6e-a5372340f3dd /media/Movies ext4 uid=1000,gid=1000,umask=0022,sync,auto,nosuid,rw,nouser 0

Share this post


Link to post
Share on other sites

I just followed the instructions, when I do sudo mount -a I get the following

mount: unknown filesystem type 'nouser'

mount: unknown filesystem type 'nouser'

mount: unknown filesystem type 'nouser'

mount: unknown filesystem type 'nouser'

Do I need to put ext4 somewhere in those lines?

Like I have

UUID=12498dda-899a-4e48-9d6e-a5372340f3dd /media/Movies uid=1000,gid=1000,umask=0022,sync,auto,nosuid,rw,nouser 0

Should I put

UUID=12498dda-899a-4e48-9d6e-a5372340f3dd /media/Movies ext4 uid=1000,gid=1000,umask=0022,sync,auto,nosuid,rw,nouser 0

Sorry, I missed that in your fstab line. Yes, you'll need to add your file system with the line (Linux doesn't/can't autodetect in most cases). Using your example above, you'll need a line like this:

UUID=0eaf61f0-f491-465b-af62-a59b350118c3   /media/Shows	ext4	uid=1000,gid=1000,umask=0022,sync,auto,nosuid,rw,nouser	 0   0
                                                                 ^                                                                   ^
                                                                 |                                                                   |
                                                          File system here                                                    Pass value here

This assumes that your file system is ext4. You'll need to change this depending on the file system (e.g. ntfs-3g, ext3, etc)

Once your drive is automounting, you shouldn't need to do anything to your application, but get back to us if you get stuck of course :)

(Edited: Alignment)

Share this post


Link to post
Share on other sites

So not where I put ext4, move that to after nouser? Why do you have two 0s at the end now?

Also don't know what any of the code means, I found an example somewhere, so not sure if any of it is correct for me.

Share this post


Link to post
Share on other sites

I've fixed the alignment in the example. The file system type goes after the mount directory (e.g. /media/Shows ext4). The second zero is the "pass" value, it just tells fstab that it doesn't need to check the file system at boot time, and just to mount it. This is the default I think, but you should include it anyway to be sure.

I used the format described on the arch wiki:

<file system>        <dir>         <type>    <options>             <dump> <pass>

(link: https://wiki.archlinux.org/index.php/Fstab#File_example

Share this post


Link to post
Share on other sites

I now have this

UUID=12498dda-899a-4e48-9d6e-a5372340f3dd /media/Movies ext4 uid=1000,gid=1000,umask=0022,sync,auto,nosuid,rw,nouser 0 0

Correct?

Share this post


Link to post
Share on other sites

looks right to me. Ensure you have a /meda/Movies folder and it should work.

Share this post


Link to post
Share on other sites

Looks good :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.