Sign in to follow this  
Followers 0

My Linux Based Questions


73 posts in this topic

Posted

It's not working.

UUID=12498dda-899a-4e48-9d6e-a5372340f3dd /media/Movies ext4 uid=1000,gid=1000,umask=0022,sync,auto,nosuid,rw,nouser 0 0

This was taken from an example I found..

uid=1000,gid=1000,umask=0022 do I need this...I see this no where on the archwiki page?

Also, I am user bman....should i be using nouser, or should I put user or users

** I ended up putting this

UUID=12498dda-899a-4e48-9d6e-a5372340f3dd /media/Movies ext4 sync,auto,nosuid,rw,nouser 0 0

And all mounted without issue.

Share this post


Link to post
Share on other sites

Posted

you don't need users because you want it to be open. UID=1000 means that it will be accessible for your user by default (unless overriding policies are set on files) and gid=1000 means that your users group will have access to. So it's more of a permissions thing. You could try and remove those settings, but you may run into permissions (mounted as root) issues.

What is not working?

Share this post


Link to post
Share on other sites

Posted

As I stated above.

With those details it would give error, I removed it and had only

UUID=12498dda-899a-4e48-9d6e-a5372340f3dd /media/Movies ext4 sync,auto,nosuid,rw,nouser 0 0 

And everything mounted without issue, my programs that use it are still working. So it's working.

Thanks guys.

Share this post


Link to post
Share on other sites

Posted

Wikipedia tells me that uid and gid and unmask are for FAT file systems only, which probably explains why they don't work.

If you want to simplify things, try simply using "default" option only (instead of specifying all the options like sync, auto, nosuid, etc manually), and see if that works. Then if it doesn't do what you want, adjust as necessary.

1 person likes this

Share this post


Link to post
Share on other sites

Posted

Thanks guys, awesome help!

Share this post


Link to post
Share on other sites

Posted

glad it's working for you :)

Share this post


Link to post
Share on other sites

Posted

So I got a chance to reboot since doing all that, and everything worked fine, in terms of mounting.

But now, copying or moving files to these drives are VERY slow. A 1GB file would have taken 1 min or less (usually less), it's now like 15 minutes or something, ridiculous!

I am assuming it's the auto mounting that did something, but what could have caused that?

Share this post


Link to post
Share on other sites

Posted

Have you only experienced this with copying to the mount? Also what about copying from or creating a copy of a file on the mount inside the mount itself?

Share this post


Link to post
Share on other sites

Posted

This is moving and copying, to and from any of the drives.

Share this post


Link to post
Share on other sites

Posted

I changed the code to "defaults" instead, rebooted and it's back to normal. Not sure which code was causing the problem but it's all good.

Share this post


Link to post
Share on other sites

Posted

My guess is because you specified "sync" writes, which you don't need for an internal drive. If necessary, you can further boost performance if you add "noatime" as an option, although it won't write "last accessed" times anymore. :)

Share this post


Link to post
Share on other sites

Posted

Yea see I didn't know that. That's what you get for copying stuff from the internet lol

And I was just reading up on noatime, sounds good, but what do you mean by "last accessed"? What exactly will change when using my system?

Also, can I keep defaults, and just add noatime beside it?

Share this post


Link to post
Share on other sites

Posted

Yes, you can just use "defaults,noatime" without issue. Basically, every time you read or write a file, a timestamp in the file inode will be updated. This means that you can view the time that the file was last accessed if necessary. The obvious downside of this is that every read is also a write, and this has a moderate impact on performance.

'noatime' will prevent these access timestamps from being written, which reduces I/O usage, which is good for performance. This is of course at the cost of the last-access time being updated, which can cause issues for some older email clients and such, which rely on the difference between last accessed time and last modified time to determine if an email is unread.

Looking into it though, Ubuntu has made "relatime" a default option for ext file systems since around 2010 anyway (see here), so you'd probably see no benefit from using noatime anyway. The defaults should be just fine ;)

An explanation of noatime vs relatime can be found here: http://linux.koolsolutions.com/2009/01/30/installing-linux-on-usb-part-4-noatime-and-relatime-mount-options/

1 person likes this

Share this post


Link to post
Share on other sites

Posted

Thanks again. :)

Share this post


Link to post
Share on other sites

Posted

you can also use nodiratime aswell :)

Share this post


Link to post
Share on other sites

Posted

I don't think I have asked this hear, and haven't found a good solution anywhere else.

I have the xscreensaver setup and works great. The only issue is that it comes on even with full screen applications running.

Alright, I use VLC that disables it while its open, great,...uh no. The problem with that is even if I have that VLC window minimized or in the small size (not full screen) the screensaver is still disabled, stupid.

Also, that doesn't work for flash sites like you tube.

Any ideas?

Share this post


Link to post
Share on other sites

Posted

I don't think I have asked this hear, and haven't found a good solution anywhere else.

I have the xscreensaver setup and works great. The only issue is that it comes on even with full screen applications running.

Alright, I use VLC that disables it while its open, great,...uh no. The problem with that is even if I have that VLC window minimized or in the small size (not full screen) the screensaver is still disabled, stupid.

Also, that doesn't work for flash sites like you tube.

Any ideas?

The same happens on windows with VLC. I think it is a setting as it disables my windows screenwaver

Share this post


Link to post
Share on other sites

Posted

Yes, the setting I want enabled because it stops the screensaver from happening when watching videos, but it's like it's not smart enough to know that if I have it minimized I want the screensaver to work.

Share this post


Link to post
Share on other sites

Posted

Yes, the setting I want enabled because it stops the screensaver from happening when watching videos, but it's like it's not smart enough to know that if I have it minimized I want the screensaver to work.

I get that on Windows. If I have VLC Open the screensaver doesn't work. Even minimized or without a video loaded.

Share this post


Link to post
Share on other sites

Posted

A new problem, well not new but haven't posted about it.

This has happened before but let it go because it's only once in a blue moon.

Sometimes randomly the VLC Icon on Unity stops working, at first the minimize and restore feature of the button stop working, then eventually there is no icon at all.

I have to reboot to get it to work again. Sometimes it does come back and start working again, but most of the time no.

Ideas, can't seem to find any information about it.

Share this post


Link to post
Share on other sites

Posted

I guess as the rest of the internet, no one here knows either. Alright ignore that for now.

I have Chrome installed and is my main program, I use it for everything. Does anyone know how to properly restart chrome?

When I close Chrome, it's still running in the background, if I look at the System Monitor, its still there. If I try to close all 20 processes it can sometimes cause issues with accounts and stuff, so I don't want to do that, besides it taking long.

I want to be able to restart chrome because after awhile, it uses a lot of resources and kills my fairly old system. Instead of restarting all the time, I'd rather restart chrome.

In Windows, if you exited it, it seemed to close fully, Ubuntu it does not.

Ideas?

Share this post


Link to post
Share on other sites

Posted

I guess as the rest of the internet, no one here knows either. Alright ignore that for now.

I have Chrome installed and is my main program, I use it for everything. Does anyone know how to properly restart chrome?

When I close Chrome, it's still running in the background, if I look at the System Monitor, its still there. If I try to close all 20 processes it can sometimes cause issues with accounts and stuff, so I don't want to do that, besides it taking long.

I want to be able to restart chrome because after awhile, it uses a lot of resources and kills my fairly old system. Instead of restarting all the time, I'd rather restart chrome.

In Windows, if you exited it, it seemed to close fully, Ubuntu it does not.

Ideas?

by default chrome allows extensions to run in the background (even while closed) this could be what you're experiencing when there are still chrome processes running after you close the browser

you can disable this option in settings at the very bottom of the advanced section

Share this post


Link to post
Share on other sites

Posted

No, I do use that feature, I have a few running in the background for a reason.

But, on Windows it had a Chrome Icon beside the clock, if you right click that and exit, Chrome fully closes. Ubuntu does not have that ability.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.