Sign in to follow this  
Followers 0

Windows High DPI (Retina)


65 posts in this topic

Posted

I thought I was the only one experiencing that stupid superbar issue (So I didn't bother to research it)! I'm so glad I'm not. Originally I thought there was something wrong with the machine and then I remembered I had changed the DPI settings. Changed them back and boom, no issue.

My HTPC is connected to a 40" TV. It's insane trying to read all sort of things. In a web browser it's simple to just zoom in/out, but in apps and the Windows GUI is nearly impossible to read sitting back on the couch.

Share this post


Link to post
Share on other sites

Posted

Oh, for some reason 150% causes a LogMeIn host machine to go ape**** when connecting to the remote console - eventually results in BSOD. I have dropped them an email as that's quite a fail.

Share this post


Link to post
Share on other sites

Posted

[quote name='Aergan' timestamp='1359421230' post='595486576']
I can confirm that the superbar is drawn infront of XBMC in fullscreen mode at 150% on both Server 2012 and Windows 8 Pro x64.
[/quote]

What else do you have installed? My install is very barebones and I do not have the 150% issue on Windows 8 Pro x64 or Windows 7 Pro x64

Share this post


Link to post
Share on other sites

Posted

[quote name='mrp04' timestamp='1359422911' post='595486646']
What else do you have installed? My install is very barebones and I do not have the 150% issue on Windows 8 Pro x64 or Windows 7 Pro x64
[/quote]

I can replicate it on a new VM running Windows 8 x64 Enterprise, XMBC Frodo RC3, 150% in addition to my physical machines (I suspected it might have been an Nvidia related issue - it's not).

Switch from XMBC full screen to desktop, launch an explorer explorer then try to get back to XBMC. Resumes full screen with the bar drawn over the top.

OR

Run XMBC as the shell, launch explorer via advanced launcher or task manager.

Share this post


Link to post
Share on other sites

Posted

[quote name='Aergan' timestamp='1359423154' post='595486664']
I can replicate it on a new VM running Windows 8 x64 Enterprise, XMBC Frodo RC3, 150% in addition to my physical machines (I suspected it might have been an Nvidia related issue - it's not).

Switch from XMBC full screen to desktop, launch an explorer explorer then try to get back to XBMC. Resumes full screen with the bar drawn over the top.

OR

Run XMBC as the shell, launch explorer via advanced launcher or task manager.
[/quote]

Interesting. Mine is not doing that. I launched XBMC from Start, then opened an explorer window. Then went back to XBMC. The bar was not on top. I'm using 8, so maybe its fixed on 8.

Here are some screenshots comparing different scalings

[url="http://i.imgur.com/opKImWs.jpg"]125% Vista-Style[/url]

[url="http://i.imgur.com/Xed2RZ9.jpg"]125% XP-Style[/url]

[url="http://i.imgur.com/SKLmNx2.jpg"]135% Vista-Style[/url]

[url="http://i.imgur.com/0Q33v8p.jpg"]150% Vista[/url]

[url="http://i.imgur.com/PuFsCV3.jpg"]150% Vista[/url] showing XBMC

[url="http://i.imgur.com/HFaLhWa.jpg"]150% XP[/url] showing XBMC

[url="http://i.imgur.com/qlzFwD5.jpg"]200% Vista[/url]

[url="http://i.imgur.com/mkmxePZ.jpg"]200% Vista[/url]

[url="http://i.imgur.com/hOpHBFj.png"]Scaling compatibility box[/url]

[url="http://i.imgur.com/QFOaxZb.png"]Notepad++ comparison of screenshot scaled to 200% and NP++ scaled by Windows to 200%[/url]

Pixel-doubling seems to work fine and the programs should look acceptable on a extremely high resolution display.

Yes there is room for improvements.

Share this post


Link to post
Share on other sites

Posted

With my MacbookPro I've had a pretty bad time using Win8, 100% dpi was too small and 200% looked weird

Share this post


Link to post
Share on other sites

Posted

[quote name='Rudy' timestamp='1359426369' post='595486810']
With my MacbookPro I've had a pretty bad time using Win8, 100% dpi was too small and 200% looked weird
[/quote]

Could you post a screenshot of 200%?

Share this post


Link to post
Share on other sites

Posted

[quote name='mrp04' timestamp='1359426440' post='595486818']
Could you post a screenshot of 200%?
[/quote]I don't have it anymore, I've passed the rMBP to my wife and I used her MBA since I got my 27" iMac

Share this post


Link to post
Share on other sites

Posted

200% UI scale should look fine on a "200% density" (This stuff isn't exact, think of it as a fuzz factor) screen, that it doesn't look fine points to underlying issues with how Windows handles it. I know when I've tried experimenting with it in the past UI elements just looked "wrong" (Like they were being scaled incorrectly)

Share this post


Link to post
Share on other sites

Posted

I don't expect that there is any such replies to this topic.
I use Windows 8 Pro with 200% on a rMPB it goes pretty good, however not everything is suitable.
Here are some examples:
Desktop + Origin (very small even if the dpi is set to 200%) http://d.pr/i/fVN6

VLC (dialog box not adapted) http://d.pr/i/GOzp

NSIS (police blur) http://d.pr/i/22Uu

Steam (police blur) http://d.pr/i/GDb8

Kaspersky (adapted interface but font too small) http://d.pr/i/UvRx

Google Chrome (police blur) It should be fixed in a future version of Chrome http://code.google.com/p/chromium/issues/detail?id=149881

For now the only apps that I found partially adapted to Retina screens are Office 2013, VS 2012 (fuzzy icon) and the Metro interface.

Besides, I have another question how to make IE 10 or Chrome displays images x2 Apple's website!

I would put other screenshot later.
2 people like this

Share this post


Link to post
Share on other sites

Posted

I'm blind (figuratively) and I use a 24" display at 1920x1080. Always have had to scale up font size to 150%.

You have to make sure that "Windows XP Style Scaling" is checked or else many applications, like Chrome, look horrible. Other than that it's usually cross platform GUI kits like GTK that have trouble scaling and cause fonts to overflow or be misplaced. It's usually not a problem for me.

Share this post


Link to post
Share on other sites

Posted

[quote name='AJerman' timestamp='1359412780' post='595486340']


I just changed the DPI on my work computer to verify that the same massively annoying bug still exists in Windows 7 DPI scaling. If you change your DPI, the superbar won't ever hide behind an app that's full screen. You have to change the superbar to autohide to get it to go away. This is incredibly annoying on an HTPC that frequently has full screen apps that you don't want to superbar hanging out on. This is more annoying than any of the blurry third party issues. Plus, regardless of who is to blame, there are so many inconsistencies when using high DPI mode in Windows that it's just hard to seriously use. They need to push third parties to update their apps with all these higher resolution screens coming out. It'll be impossible to use an HTPC on a 4k screen without DPI scaling.
[/quote]
That's an app bug not a windows bug. MediaPortal used to do this, but now works properly in hgh dpi.

Share this post


Link to post
Share on other sites

Posted

[quote name='Jeezy4' timestamp='1359436831' post='595487106']
I don't expect that there is any such replies to this topic.
I use Windows 8 Pro with 200% on a rMPB it goes pretty good, however not everything is suitable.
Here are some examples:
Desktop + Origin (very small even if the dpi is set to 200%) [url="http://d.pr/i/fVN6"]http://d.pr/i/fVN6[/url]

VLC (dialog box not adapted) [url="http://d.pr/i/GOzp"]http://d.pr/i/GOzp[/url]

NSIS (police blur) [url="http://d.pr/i/22Uu"]http://d.pr/i/22Uu[/url]

Steam (police blur) [url="http://d.pr/i/GDb8"]http://d.pr/i/GDb8[/url]

Kaspersky (adapted interface but font too small) [url="http://d.pr/i/UvRx"]http://d.pr/i/UvRx[/url]

Google Chrome (police blur) It should be fixed in a future version of Chrome [url="http://code.google.com/p/chromium/issues/detail?id=149881"]http://code.google.c...etail?id=149881[/url]

For now the only apps that I found partially adapted to Retina screens are Office 2013, VS 2012 (fuzzy icon) and the Metro interface.

[b]Besides, I have another question how to make IE 10 or Chrome displays images x2 Apple's website![/b]

I would put other screenshot later.
[/quote]

Thanks for the screenshots (Y)

Regarding the bolded bit, that's a bit tough. IE has always handled this stuff a bit strangely (You'll see similar issues on high-dpi WP devices), and Chrome should get support in a future release (Since WebKit already exposes it to content in a non-standard way). Firefox can handle this (Via standard methods, and the same JS extension WebKit uses), but it's half disabled by default due to issues.

Interesting that Steam has issues since that uses DirectWrite (and by extension, Direct2D, hopefully), and that supports resolution independence by default, so they've either broken it, or are using some strange rendering method that breaks it.

Edit: O, for the rest of the stuff, disabling XP style scaling should "help" (It'll just be pixel doubled then, so blurry but scaled properly)

Share this post


Link to post
Share on other sites

Posted

[quote name='mrp04' timestamp='1359425116' post='595486748']
Interesting. Mine is not doing that. I launched XBMC from Start, then opened an explorer window. Then went back to XBMC. The bar was not on top. I'm using 8, so maybe its fixed on 8.

Yes there is room for improvements.
[/quote]

I'm using Windows 8, it's not fixed and quite easy to trigger.

150% Non-XP

Share this post


Link to post
Share on other sites

Posted

Again, it's a problem with XBMC. they need to fix their code and add support for high DPI. MP used to have the same issue, which has since been fixed for the last 6-12 months, not sure.

Tell XBMC to fix their broken code, or change to a working properly coded MC solution. both MediaPortal and Plex have no problem with the taskbar in High DPI.

Share this post


Link to post
Share on other sites

Posted

Citrix Receiver is also broken, Hyper-V Console, Active Directory Administration Center and occasionally Server Manager.

In Windows 7, this issue is hard to reproduce unless you move the super bar to the top of the screen.

In Windows 8, the way the super bar is composited onto the desktop has changed and they are not providing backwards compatibility to some common methods of detecting what the desktop space area is.

Share this post


Link to post
Share on other sites

Posted

[quote name='HawkMan' timestamp='1359447384' post='595487240']
Again, it's a problem with XBMC. they need to fix their code and add support for high DPI. MP used to have the same issue, which has since been fixed for the last 6-12 months, not sure.

Tell XBMC to fix their broken code, or change to a working properly coded MC solution. both MediaPortal and Plex have no problem with the taskbar in High DPI.
[/quote]

Although I don't doubt XBMC is buggy, this happens to me as well and I don't even use or have XBMC installed. This is triggered for me whenever I go to full screen mode for any video online. Including but not limited to Youtube.

Share this post


Link to post
Share on other sites

Posted

with what browser, never had this issue on any videos in a browser, just specific programs, which don't support high dpi modes.

Share this post


Link to post
Share on other sites

Posted

[quote name='HawkMan' timestamp='1359456108' post='595487378']
with what browser, never had this issue on any videos in a browser, just specific programs, which don't support high dpi modes.
[/quote]

With Chrome. To be honest I haven't tested with any other browser.

Share this post


Link to post
Share on other sites

Posted

I really never see this on my HTPC at 150% with XBMC or even on my desktop when I set it to 125%, 135%, 150%, and 200%. XBMC 12 RC3 always stayed on top of the bar.
I've also used N64 emulator and YouTube in IE without issue.

Share this post


Link to post
Share on other sites

Posted

[quote name='HawkMan' timestamp='1359439554' post='595487152']
That's an app bug not a windows bug. MediaPortal used to do this, but now works properly in hgh dpi.
[/quote]

Is it or is it something that apps have found a workaround for? It seems to me like it shouldn't have happened in the first place, and maybe that's why many apps don't have the issue now when they used to, because they are fixed now. Either way, maybe I'll give it a try again, but there are still so many reasons why DPI scaling seems so poor. Fonts are terribly ugly, even when they aren't scaled and blurry, and it's Microsoft's ecosystem. I know they can't control third parties, but they can push them to support high DPI better. It's time.

Perhaps I can get some more interesting screenshots...
1 person likes this

Share this post


Link to post
Share on other sites

Posted

Fonts are blurry in programs that aren't programmed to support DPI scaling.

it's been said several times in this thread, the apps need to support it. 125%, 150% and the rest looks perfectly fine on all apps that are made to support it. apps that don't support it simply get scaled and look blurry.

Share this post


Link to post
Share on other sites

Posted

[quote name='AJerman' timestamp='1359481586' post='595488160']
Is it or is it something that apps have found a workaround for? It seems to me like it shouldn't have happened in the first place, and maybe that's why many apps don't have the issue now when they used to, because they are fixed now. Either way, maybe I'll give it a try again, but there are still so many reasons why DPI scaling seems so poor. Fonts are terribly ugly, even when they aren't scaled and blurry, and it's Microsoft's ecosystem. I know they can't control third parties, but they can push them to support high DPI better. It's time.

[b]Perhaps I can get some more interesting screenshots...[/b]
[/quote]

Well those were famous last words if I've ever said them.

Changed my resolution to native (3840x2400) and DPI to 150% to take a look at some things. Changing my screen resolution and DPI caused explorer to stop responding. Explorer not responding caused me to do a ctrl-alt-del to try to open task manager to restart it. Clicking task manager caused my entire computer to hang. My hung computer caused me to have to turn it off by holding the power button. Holding the power button to turn it off managed to corrupt my system drive. This caused me to spend an hour trying to recover it, only to remember the entire hard drive is encrypted (work) and there was no way to unlock it and then boot into recovery software, so I was screwed. Changing my screen resolution and DPI tanked my entire work computer. Thanks Microsoft and AMD!! Keep up the awesome work.

And of course a reformat and reinstall wouldn't be so bad.... if it weren't pulling OS image files from completely across the country. Instead reinstalling took 4 hours. God dammit I hate computers sometimes.

Now it's 9 PM and I'd like to go home.

Share this post


Link to post
Share on other sites

Posted

You may have noticed as soon as you go up the DPI to 100% above the cursor pixelated.
There is a solution for those interested : http://sourceforge.net/projects/cursorchanger/
Must admit, the system is still not optimized for Hi-Res.

Share this post


Link to post
Share on other sites

Posted

[quote name='theyarecomingforyou' timestamp='1359407397' post='595486112']
Microsoft really needs to move over to vector art and allow users to freely scale the interface to their choosing (...)[/quote]

That's precisely what they did with WPF, for all it's worth.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.