Jump to content
Sign in to follow this  
Followers 0

Odd Ubuntu problem

20 posts in this topic

Posted

I have been running Ubuntu on this system for awhile now, but I've always gotten these errors, but everything seems to work OK, so I forgot about it.

After waking up the computer from sleep, I get this:

[IMG]http://i188.photobucket.com/albums/z105/mindovermaster/IMG_0268_zps3e29f195.jpg[/IMG]

Now, there's only one thing that I think it MIGHT be. My gamepad/QJoyPad. Is there anyway I can run a test on exactly what it is? Or are these errors stored anywhere?

Tomorrow I'm gunna revamp this system, put Debian Wheezy on it, due to the new motherboard/CPU.

So unless this repeats itself with Debian, I really wanna know what this error means.

Share this post


Link to post
Share on other sites

Posted

I was inclined to say that error message is the result of a failing hard drive, but I don't think that's the case anymore. Depending on what the errno is, it could be a kernel bug or BIOS bug. Check the bug reports [url="https://bugs.launchpad.net/ubuntu/+source/linux/+bug/256637"]here[/url], [url="http://comments.gmane.org/gmane.linux.kernel/1247563"]here[/url], and [url="https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.22/+bug/162536"]here[/url] for more details than you probably wanted.

You can get a copy of your boot log by looking at [i]/var/log/dmesg[/i]. (GNOME Log Viewer is often another convenient way to view your system logs.)

Share this post


Link to post
Share on other sites

Posted

Ata2 is the 3rd parallel device on the system and COMRESET is a command to force a reset on the device.

What is the output of,

# fdisk -l

EDIT: You can use dmesg but I would trim it down.

# cat /var/log/dmesg | grep "ata"

Share this post


Link to post
Share on other sites

Posted

[CODE]
david@david-ubuntu:~$ fdisk -l
david@david-ubuntu:~$ cat /var/log/dmesg | grep "ata"
[ 0.000000] Memory: 8141008k/9428992k available (6718k kernel code, 1059668k absent, 228316k reserved, 6452k data, 932k init)
[ 0.169079] PEBS disabled due to CPU errata.
[ 0.266331] libata version 3.00 loaded.
[ 0.659994] ata1: SATA max UDMA/133 abar m2048@0xfe705000 port 0xfe705100 irq 44
[ 0.660067] ata2: SATA max UDMA/133 abar m2048@0xfe705000 port 0xfe705180 irq 44
[ 0.660140] ata3: SATA max UDMA/133 abar m2048@0xfe705000 port 0xfe705200 irq 44
[ 0.660213] ata4: SATA max UDMA/133 abar m2048@0xfe705000 port 0xfe705280 irq 44
[ 0.660285] ata5: DUMMY
[ 0.660349] ata6: SATA max UDMA/133 abar m2048@0xfe705000 port 0xfe705380 irq 44
[ 0.978902] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[ 0.979000] ata6: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[ 0.979084] ata4: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[ 0.979167] ata3: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[ 0.979244] ata6.00: ATAPI: ASUS DRW-2014L1T, 1.00, max UDMA/66
[ 0.979327] ata2: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[ 0.979464] ata4.00: ATA-8: OCZ-VERTEX, 1.6, max UDMA/133
[ 0.979531] ata4.00: 125045424 sectors, multi 1: LBA48 NCQ (depth 31/32), AA
[ 0.979639] ata6.00: configured for UDMA/66
[ 0.979794] ata3.00: ATA-9: SAMSUNG SSD 830 Series, CXM03B1Q, max UDMA/133
[ 0.979885] ata3.00: 250069680 sectors, multi 16: LBA48 NCQ (depth 31/32), AA
[ 0.980374] ata3.00: configured for UDMA/133
[ 0.981085] ata1.00: ATA-8: WDC WD5000AAKS-00E4A0, 05.01D05, max UDMA/133
[ 0.981152] ata1.00: 976773168 sectors, multi 16: LBA48 NCQ (depth 31/32), AA
[ 0.981415] ata4.00: configured for UDMA/133
[ 0.981552] ata2.00: ATA-8: WDC WD1501FASS-00W2B0, 05.01D05, max UDMA/133
[ 0.981635] ata2.00: 2930277168 sectors, multi 16: LBA48 NCQ (depth 31/32), AA
[ 0.982436] ata1.00: configured for UDMA/133
[ 0.984708] ata2.00: configured for UDMA/133
[ 1.021480] Write protecting the kernel read-only data: 12288k
[ 1.268491] EXT4-fs (sdd1): mounted filesystem with ordered data mode. Opts: (null)
[/CODE]

Share this post


Link to post
Share on other sites

Posted

ATA2 = Western Digital

Share this post


Link to post
Share on other sites

Posted

(errno=-16)

Didn't show that well in the picture. :p

Share this post


Link to post
Share on other sites

Posted

is your bios sata mode set to AHCPI or COmpatability?

Share this post


Link to post
Share on other sites

Posted

I do not know. I have it set to AHCI if that is what you mean.

Share this post


Link to post
Share on other sites

Posted

thats what i meant sorry typo lol

it seems to be a problem with the sata mode and a bug

have a search on google

Share this post


Link to post
Share on other sites

Posted

I see bugchecks even back to 2010, so It's a known bug, at least...

Share this post


Link to post
Share on other sites

Posted

On the drive - what is the jumper set to?

Share this post


Link to post
Share on other sites

Posted

It's a SATA drive, no jumpers.

Share this post


Link to post
Share on other sites

Posted

YES sorry - that was shown in the data.

Share this post


Link to post
Share on other sites

Posted

Try setting your sata mode to Compatibility see if you still get the errors

Share this post


Link to post
Share on other sites

Posted

I don't think setting the hard drive mode to compatibility is a good solution. Although it may mitigate the problem, you will get worse performance from the disk, and some advanced caching features present on modern hard drives won't be available. (Worse yet, if it is an SSD you will shorten the life of the disk because TRIM won't be enabled.) The bug reports I linked to above seem to indicate its a firmware bug, not a kernel bug. Make sure you have the most up-to-date BIOS for your machine, and update the firmware on the disk if it is an SSD.

[b]Edit:[/b] Also, any time you run a partitioning tool (such as fdisk, gdisk, parted, or gparted) you should run it as root, even if its only being used to list partitions. Some people use the '$' symbol in front of commands to indicate they can be run as a normal user and the '#' symbol to indicate they should be run as superuser. I think that is why tim_s wrote '# fdisk -l' instead of 'sudo fdisk -l'.

Share this post


Link to post
Share on other sites

Posted

It was purely for ruling out anything and making 100% sure it was the same bug

Share this post


Link to post
Share on other sites

Posted

[quote name='Haggis' timestamp='1360602373' post='595515262']
It was purely for ruling out anything and making 100% sure it was the same bug
[/quote]

Although I agree with you in theory, that actually wouldn't confirm anything in this case. Whether its a kernel bug or firmware bug (despite the fact that its likely the latter), using a different communications protocol more-or-less negates the effect. Since the firmware is emulating ATA instead of its native AHCI, a different software stack is in use in the firmware. To communicate with the hard disk using this protocol, the kernel will load a different driver (or at least use a different part of the same driver). Although there will obviously be some of the same code used in both firmware and the kernel, because one cannot be tested without the other (on the same hardware, at least), its not useful for debugging. Therefore I assumed that you were suggesting changing the hard disk mode to compatibility as a mitigation technique, not a testing procedure. I apologize for my misinterpretation, but I still stand by my point that it will not help debug the problem.

Share this post


Link to post
Share on other sites

Posted

Well, yeah, I read around and changing from AHCI will[i] temporarily[/i] fix it, but is no guarantee to the fix.

Share this post


Link to post
Share on other sites

Posted

OK, It's doing it again, on my same WD Black 1.5TB drive. Could it have been wrongly formatted?

Looking at ATA4:

[CODE]
david@david-desktop:~$ cat /var/log/dmesg | grep "ata4"
[ 0.484776] ata4: SATA max UDMA/133 abar m2048@0xf7e16000 port 0xf7e16280 irq 43
[ 0.804201] ata4: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[ 0.806485] ata4.00: ACPI cmd ef/10:06:00:00:00:00 (SET FEATURES) succeeded
[ 0.806487] ata4.00: ACPI cmd f5/00:00:00:00:00:00 (SECURITY FREEZE LOCK) filtered out
[ 0.806488] ata4.00: ACPI cmd b1/c1:00:00:00:00:00 (DEVICE CONFIGURATION OVERLAY) filtered out
[ 0.808607] ata4.00: ATA-8: WDC WD1501FASS-00W2B0, 05.01D05, max UDMA/133
[ 0.808610] ata4.00: 2930277168 sectors, multi 16: LBA48 NCQ (depth 31/32), AA
[ 0.811492] ata4.00: ACPI cmd ef/10:06:00:00:00:00 (SET FEATURES) succeeded
[ 0.811496] ata4.00: ACPI cmd f5/00:00:00:00:00:00 (SECURITY FREEZE LOCK) filtered out
[ 0.811499] ata4.00: ACPI cmd b1/c1:00:00:00:00:00 (DEVICE CONFIGURATION OVERLAY) filtered out
[ 0.813656] ata4.00: configured for UDMA/133
[/CODE]

I'm back to Ubuntu after being on Debian for about a week, really not for me.

Share this post


Link to post
Share on other sites

Posted

[quote name='Mindovermaster' timestamp='1361668093' post='595539578']
OK, It's doing it again, on my same WD Black 1.5TB drive. Could it have been wrongly formatted?
[/quote]

It is very unlikely the problem is due to the way you partitioned for formatted it. From your latest dmesg log it still looks like a firmware problem. Its possible that a newer kernel has a work-around for the bug (assuming that it is actually a firmware-related problem), but I don't really have any new suggestions. If you're running Precise, you could try installing the backported Quantal kernel (3.5), but I have no evidence that will resolve anything.

[quote name='Mindovermaster' timestamp='1361668093' post='595539578']
I'm back to Ubuntu after being on Debian for about a week, really not for me.
[/quote]

Use what you like best. I'm not here to start a crusade. (In fact "No Distro Trolling is allowed" is boldly stated in the "Guidelines & pointers for this section" post pinned at the top of our subforum. Even if I was not of that persuasion to begin with I would still respect the rules of the forum.)

[b]Edit:[/b] I find it pretty ironic that the sentence immediately after I stated that I had no more suggestions is a suggestion. I plead the fifth.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.