Sign in to follow this  
Followers 0

win8 Unable to change UAC settings

19 posts in this topic

Posted

Is this some weird bug or am I missing something? I am not able to enter and change my UAC settings at all. When I click Change setting in Action Center or Change User Account Control settings under User Accounts, nothing happens. At all. I click the link and there is no response from Windows. Any ideas what's causing this?

I run Windows 8 Pro x64, all latest updates.

Share this post


Link to post
Share on other sites

Posted

Try this: http://pcsupport.abo...sfc-scannow.htm

It sounds like you have corrupted system files.

Another thing you can try is schedule your system with chkdsk to check file system errors. Right click C: drive, Properties->Tools and Check Now. Leave default options.

Disclaimer: Use it at your own risk and I take no responsibility if things get worse. Back up your data or make sure you can boot your system with live media (Win PE, Linux Live distributions etc) and backup your work in case something goes wrong.

Share this post


Link to post
Share on other sites

Posted

Thanks for suggestions. I tried sfc /scannow and it did find some error and fixed them. Unfortunately that didn't fix this one (I did restart).

Regarding chkdsk, I am not able to run it via the regular Properties - Tools method; I get the same issue as with changing account settings - I click Check and there is no response at all. What commands should I use if I want to run it via Command Prompt?

I really don't want to reinstall the OS. :(

Share this post


Link to post
Share on other sites

Posted

There's always the option to Refresh or Reset your PC. Bear in mind that Refresh will keep your documents while Reset won't.

Share this post


Link to post
Share on other sites

Posted

Ok it looks like your problem is related to rundll32 related functionality. It is commonly used to bring up dialog boxes such as the one you attempted to bring up.

It is possible that malware has attached to the process (which would happen every time Windows starts) and is making your system misbehave.

To schedule a disk check before Windows is loaded:

- Search for cmd.exe on your start screen (or Start menu)

- Right click and select "Run As Administrator" - I think on Windows 8 systems the option appears on the bottom of the screen

- Run chkdsk /F

- When asked if you want to schedule the disk to be checked the next time the system starts, answer Yes

If all this fails, you can try a system restore (that may potentially make things worse) but use it as a very last option.

Try Avira Live CD or BitDefender Live CD to check your system. Not sure if they support EFI but if your system has BIOS emulation enabled or is BIOS based, the standard live ISOs should work.

Share this post


Link to post
Share on other sites

Posted

Another thing you can try.

Bring up the Task Manager and select the "Start Up" tab (I think that's where they moved it)

Turn of everything that's automatically starting and restart

If the problem is fixed, enable one thing at a time until it breaks again and you'll know where the problem is

It is also possible that a corrupted resident AV process is blocking rundll32 from doing its job properly.

Turn off 24/7 resident AV software and try again. If no success, restart and try again. Just make sure the resident AV is permanently turned off because the next time the system starts, it may start up again depending on the config. You can re-enable it again.

Share this post


Link to post
Share on other sites

Posted

I tried chkdsk but that didn't change anything. Scanned the PC with Windows Defender/MSE, Malwarebytes and Spybot and nothing was found. Before I remove programs from startup, note that I seem to get the following error when I try to disable Windows Defender - "The activation requires a display name to be present under the CLSID key". Could this be related to the issue at hand?

Share this post


Link to post
Share on other sites

Posted

Hmm, that is quite weird. How did you try to disable Windows Defender? I don't know if it is related to the error but you can try disabling Windows defender via the services.msc utility - that is if you can bring it up on the screen. If you can then try this:

- Type services.msc (on your Start Screen or Start Menu if you use a third party one)

- Locate Windows Defender

- Double click on it

- Set Startup Type to Disabled

If you cannot access services.msc

Launch cmd.exe as admin and type the following command. This will disable the Windows Defender service:

sc config WinDefend start= "disabled"

Restart the PC.

To re-enable the service:

sc config WinDefend start= "auto"

See how you go.

Share this post


Link to post
Share on other sites

Posted

I tried disabling it via Settings - Administrator and then it gave me the error message.

I disabled WD via services.msc but that didn't change anything. Interesting thing though - almost all services have the following in the Description column - Failed to Read Description. Error Code: 2. Unfortunately the only solution I googled was to use sfc /scannow but that doesn't find any issues.

I disabled all startup items but that had no impact either. :/

Share this post


Link to post
Share on other sites

Posted

I'm assuming you have local admin rights?

Share this post


Link to post
Share on other sites

Posted

You know, when it comes to accesses and rights, I am dumb as a brick. Under User Accounts I'm an "Administrator". Should I check that somewhere else?

Basically, I installed Windows 8 with the default settings and didn't change anything afterwards. At least not that I know of.

Share this post


Link to post
Share on other sites

Posted

Perhaps the owner of the C: drive got changed accidently?

Open windows explorer, right click on C: and click properties. Then click the security tab and click advanced. What is shown as the owner? On my win8 x64, trustedinstaller is the owner.

Share this post


Link to post
Share on other sites

Posted

Found this registry edit for Windows 8. Use at your own risk.

To turn off your UAC, Open your windows registry (regedit) and go there : HKEY_LOCAL_MACHINE\SOFTWARE\Mi

Share this post


Link to post
Share on other sites

Posted

It looks like something is seriously messed up with his settings. Unable to bring up dialog boxes, Failed to Read Description. Error Code: 2 etc.

I think the best thing to do is a clean install. Format the partition and re-install Windows. Just back everything up.

Did you upgrade from Windows 7? Clean install is the way, never upgrade from an existing installation if you want to avoid issues and gain maximum efficiency.

Share this post


Link to post
Share on other sites

Posted

tweaking.com

Share this post


Link to post
Share on other sites

Posted

Perhaps the owner of the C: drive got changed accidently?

Open windows explorer, right click on C: and click properties. Then click the security tab and click advanced. What is shown as the owner? On my win8 x64, trustedinstaller is the owner.

Same Trustedinstaller for me as well.

It looks like something is seriously messed up with his settings. Unable to bring up dialog boxes, Failed to Read Description. Error Code: 2 etc.

I think the best thing to do is a clean install. Format the partition and re-install Windows. Just back everything up.

Did you upgrade from Windows 7? Clean install is the way, never upgrade from an existing installation if you want to avoid issues and gain maximum efficiency.

Eh, a reinstall does seems like an option at this point. Just when I have set everything so nicely up... ugh. I guess I'll have the opportunity to check out the new Refresh functionality of Windows 8.

And it's not an upgrade. I always do a format/clean install when installing an OS.

Share this post


Link to post
Share on other sites

Posted

I encountered this problem last month after an windows update i think. I had Win 8 x64 Enterprised. I decided to do a clean install of windows and i installed Windows 8 Pro x64. After a month, same problem. I don't know what's so wrong...

Share this post


Link to post
Share on other sites

Posted

I encountered this problem last month after an windows update i think. I had Win 8 x64 Enterprised. I decided to do a clean install of windows and i installed Windows 8 Pro x64. After a month, same problem. I don't know what's so wrong...

Same problem here. When I log in on safe mode everything is normal.

Share this post


Link to post
Share on other sites

Posted

Same problem here. When I log in on safe mode everything is normal.

After a while and some heavy google searching  managed to track the problem, tested it and solved it by system restore. I have an AMD video card and when i used AMD uninstall tool to uninstall the old driver it messed up all my windows 8 settings. If the uninstall is made from Control Panel everything works normal. This seems to be a known bug and it seems to appear also if you use Windows Defender. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.