Jump to content


Unable to change UAC settings


  • Please log in to reply
18 replies to this topic

#1 gkl



  • Joined: 04-August 05
  • Location: Latvia

Posted 10 March 2013 - 09:09

Is this some weird bug or am I missing something? I am not able to enter and change my UAC settings at all. When I click Change setting in Action Center or Change User Account Control settings under User Accounts, nothing happens. At all. I click the link and there is no response from Windows. Any ideas what's causing this?

I run Windows 8 Pro x64, all latest updates.

#2 rwx



  • Joined: 24-February 08

Posted 10 March 2013 - 09:20

Try this: http://pcsupport.abo...sfc-scannow.htm

It sounds like you have corrupted system files.

Another thing you can try is schedule your system with chkdsk to check file system errors. Right click C: drive, Properties->Tools and Check Now. Leave default options.

Disclaimer: Use it at your own risk and I take no responsibility if things get worse. Back up your data or make sure you can boot your system with live media (Win PE, Linux Live distributions etc) and backup your work in case something goes wrong.

#3 OP gkl



  • Joined: 04-August 05
  • Location: Latvia

Posted 10 March 2013 - 10:20

Thanks for suggestions. I tried sfc /scannow and it did find some error and fixed them. Unfortunately that didn't fix this one (I did restart).

Regarding chkdsk, I am not able to run it via the regular Properties - Tools method; I get the same issue as with changing account settings - I click Check and there is no response at all. What commands should I use if I want to run it via Command Prompt?

I really don't want to reinstall the OS. :(

#4 Buendia



  • Joined: 09-February 09

Posted 10 March 2013 - 10:46

There's always the option to Refresh or Reset your PC. Bear in mind that Refresh will keep your documents while Reset won't.

#5 rwx



  • Joined: 24-February 08

Posted 10 March 2013 - 10:57

Ok it looks like your problem is related to rundll32 related functionality. It is commonly used to bring up dialog boxes such as the one you attempted to bring up.

It is possible that malware has attached to the process (which would happen every time Windows starts) and is making your system misbehave.

To schedule a disk check before Windows is loaded:

- Search for cmd.exe on your start screen (or Start menu)
- Right click and select "Run As Administrator" - I think on Windows 8 systems the option appears on the bottom of the screen
- Run chkdsk /F
- When asked if you want to schedule the disk to be checked the next time the system starts, answer Yes

If all this fails, you can try a system restore (that may potentially make things worse) but use it as a very last option.

Try Avira Live CD or BitDefender Live CD to check your system. Not sure if they support EFI but if your system has BIOS emulation enabled or is BIOS based, the standard live ISOs should work.

#6 rwx



  • Joined: 24-February 08

Posted 10 March 2013 - 11:23

Another thing you can try.

Bring up the Task Manager and select the "Start Up" tab (I think that's where they moved it)
Turn of everything that's automatically starting and restart
If the problem is fixed, enable one thing at a time until it breaks again and you'll know where the problem is

It is also possible that a corrupted resident AV process is blocking rundll32 from doing its job properly.

Turn off 24/7 resident AV software and try again. If no success, restart and try again. Just make sure the resident AV is permanently turned off because the next time the system starts, it may start up again depending on the config. You can re-enable it again.

#7 OP gkl



  • Joined: 04-August 05
  • Location: Latvia

Posted 10 March 2013 - 14:37

I tried chkdsk but that didn't change anything. Scanned the PC with Windows Defender/MSE, Malwarebytes and Spybot and nothing was found. Before I remove programs from startup, note that I seem to get the following error when I try to disable Windows Defender - "The activation requires a display name to be present under the CLSID key". Could this be related to the issue at hand?

#8 rwx



  • Joined: 24-February 08

Posted 10 March 2013 - 20:58

Hmm, that is quite weird. How did you try to disable Windows Defender? I don't know if it is related to the error but you can try disabling Windows defender via the services.msc utility - that is if you can bring it up on the screen. If you can then try this:

- Type services.msc (on your Start Screen or Start Menu if you use a third party one)
- Locate Windows Defender
- Double click on it
- Set Startup Type to Disabled

If you cannot access services.msc

Launch cmd.exe as admin and type the following command. This will disable the Windows Defender service:

sc config WinDefend start= "disabled"

Restart the PC.

To re-enable the service:

sc config WinDefend start= "auto"

See how you go.

#9 OP gkl



  • Joined: 04-August 05
  • Location: Latvia

Posted 11 March 2013 - 02:25

I tried disabling it via Settings - Administrator and then it gave me the error message.

I disabled WD via services.msc but that didn't change anything. Interesting thing though - almost all services have the following in the Description column - Failed to Read Description. Error Code: 2. Unfortunately the only solution I googled was to use sfc /scannow but that doesn't find any issues.

I disabled all startup items but that had no impact either. :/

#10 Tegument



  • Joined: 08-May 03
  • Location: Morton, IL
  • OS: Windows 8.1 & Windows Phone 8

Posted 11 March 2013 - 02:31

I'm assuming you have local admin rights?

#11 OP gkl



  • Joined: 04-August 05
  • Location: Latvia

Posted 11 March 2013 - 18:19

You know, when it comes to accesses and rights, I am dumb as a brick. Under User Accounts I'm an "Administrator". Should I check that somewhere else?

Basically, I installed Windows 8 with the default settings and didn't change anything afterwards. At least not that I know of.

#12 Farscape


    Resident One Post Wonder

  • Joined: 11-March 13

Posted 11 March 2013 - 18:56

Perhaps the owner of the C: drive got changed accidently?

Open windows explorer, right click on C: and click properties. Then click the security tab and click advanced. What is shown as the owner? On my win8 x64, trustedinstaller is the owner.

#13 cropcircles



  • Joined: 31-October 04

Posted 11 March 2013 - 19:23

Found this registry edit for Windows 8. Use at your own risk.

To turn off your UAC, Open your windows registry (regedit) and go there : HKEY_LOCAL_MACHINE\SOFTWARE\Mi­crosoft\Windows\CurrentVersion­\Policies\System , set the value "EnableLUA" to 0 , and restart your system.

#14 rwx



  • Joined: 24-February 08

Posted 12 March 2013 - 07:58

It looks like something is seriously messed up with his settings. Unable to bring up dialog boxes, Failed to Read Description. Error Code: 2 etc.

I think the best thing to do is a clean install. Format the partition and re-install Windows. Just back everything up.

Did you upgrade from Windows 7? Clean install is the way, never upgrade from an existing installation if you want to avoid issues and gain maximum efficiency.

#15 Shiranui



  • Tech Issues Solved: 2
  • Joined: 24-December 03

Posted 12 March 2013 - 08:29


Click here to login or here to register to remove this ad, it's free!