Jump to content



Photo

Crazy Nvidia driver install problems...


  • Please log in to reply
11 replies to this topic

#1 SyntheticVirusZ

SyntheticVirusZ

    The one The only

  • Joined: 26-March 02
  • Location: Iowa City, IA
  • OS: Windows 10 Technical Preview
  • Phone: Samsung ATIV S Neo

Posted 20 March 2013 - 00:06

So every time i go to install the drivers for my Nvidia GeForce GTX 650 Ti card my system goes nuts and it always ends with an unusable black screen. I've tried to install them through Windows Update and off Nvidia's website including the beta drivers they have on there. This is a fresh install no less... My motherboard does have a onbored video chipset, could that be the cause of the problem? Thanks for any help as always guys!


#2 OP SyntheticVirusZ

SyntheticVirusZ

    The one The only

  • Joined: 26-March 02
  • Location: Iowa City, IA
  • OS: Windows 10 Technical Preview
  • Phone: Samsung ATIV S Neo

Posted 20 March 2013 - 01:37

So looking around I found this https://forums.gefor...-fresh-install/, I'm just not so sure I want to destroy another install trying something that might now work... What do you guys think?

#3 Hum

Hum

    totally wAcKed

  • Tech Issues Solved: 12
  • Joined: 05-October 03
  • Location: Odder Space
  • OS: Windows XP, 7

Posted 20 March 2013 - 01:39

on-board video should be disabled in the BIOS settings.

Maybe you have the incorrect driver for your card, and Windows 8 ... ?

#4 OP SyntheticVirusZ

SyntheticVirusZ

    The one The only

  • Joined: 26-March 02
  • Location: Iowa City, IA
  • OS: Windows 10 Technical Preview
  • Phone: Samsung ATIV S Neo

Posted 20 March 2013 - 01:42

Maybe you have the incorrect driver for your card, and Windows 8 ... ?

Wish it was that easy but it's the right driver when I download it from NVidia's website, also I get the same error downloading the driver from Windows Update. If anybody is wondering my motherboard is a ASRock Z77 Extreme4.

#5 Hum

Hum

    totally wAcKed

  • Tech Issues Solved: 12
  • Joined: 05-October 03
  • Location: Odder Space
  • OS: Windows XP, 7

Posted 20 March 2013 - 01:44

Be sure to consult the motherboard manual, and check all BIOS settings.

#6 Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 13
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Debian Jessie
  • Phone: Samsung Galaxy SIII

Posted 20 March 2013 - 02:00

Has to be in I/O configuration in BIOS, to further help.


From manual:


3.4.2 North Bridge Configuration


Primary Graphics Adapter

This allows you to select [Onboard], [PCI] or [PCI Express] as the boot

graphic adapter priority. The default value is [PCI Express].



#7 OP SyntheticVirusZ

SyntheticVirusZ

    The one The only

  • Joined: 26-March 02
  • Location: Iowa City, IA
  • OS: Windows 10 Technical Preview
  • Phone: Samsung ATIV S Neo

Posted 20 March 2013 - 02:08

Ugh! Windows Update installed the drivers on its own so it black screened on me again... Also I noticed that I could see and move the mouse courser around and I can get into Safe Mode as well. I really feel like this problem has nothing to do with the bios guys but I might be wrong

#8 OP SyntheticVirusZ

SyntheticVirusZ

    The one The only

  • Joined: 26-March 02
  • Location: Iowa City, IA
  • OS: Windows 10 Technical Preview
  • Phone: Samsung ATIV S Neo

Posted 20 March 2013 - 02:15

When I uninstalled the drivers Windows Update installed while I was in Safe Mode it started working again... This is defiantly a problem between the drivers and Windows itself... :/

#9 OP SyntheticVirusZ

SyntheticVirusZ

    The one The only

  • Joined: 26-March 02
  • Location: Iowa City, IA
  • OS: Windows 10 Technical Preview
  • Phone: Samsung ATIV S Neo

Posted 21 March 2013 - 17:36

God damn it... I have my TV as well as my PC monitor hooked into my video card. When I installed the drivers for some reason it would send the signal to the TV, of course it took me a good day to realize this... Thanks for the help anyway guys!

#10 Circaflex

Circaflex

    Neowinian Senior

  • Tech Issues Solved: 2
  • Joined: 18-August 02
  • Location: California
  • OS: 8 x64, 7 x64, Mountain Lion, Ubuntu
  • Phone: shamu

Posted 21 March 2013 - 18:00

there is a fix but its a pain in the butt but here it goes:

Reboot into safemode with networking
Download the newest driver from nvidia.com for your card
use control panel to remove nvidia drivers
*optional step: use driversweeper to get rid of everything nvidia display related*
This is very important, unplug your internet/disable internet connections
Reboot into normal mode
Install nvidia driver and select advanced, then check clean install
once it finishes, reboot
restore internet connection


EDIT looks like you resolved it, any chance you can edit your original title to show SOLVED?

#11 +Zlip792

Zlip792

    Neowinian Senior

  • Tech Issues Solved: 16
  • Joined: 31-October 10
  • Location: Pakistan
  • OS: Windows 8.1 Pro 64-bit
  • Phone: Nokia C3-00 (8.70 firmware)

Posted 21 March 2013 - 19:53

Do you tired updating your motherboard BIOS?
Also if your are overclocking your system then revert back to default and do it, and also reset BIOS to default.
Which brand or vendor GTX 650 Ti you have?

#12 OP SyntheticVirusZ

SyntheticVirusZ

    The one The only

  • Joined: 26-March 02
  • Location: Iowa City, IA
  • OS: Windows 10 Technical Preview
  • Phone: Samsung ATIV S Neo

Posted 21 March 2013 - 22:18

Yup everything is fixed! Also I'm sorry but I don't think I can edit my title, if a mod wants to do that or close the topic that would be great! Once again thanks guys for the help! :)