Jump to content



Photo

ubuntu VPN


  • Please log in to reply
2 replies to this topic

#1 Original Poster

Original Poster

    Systems Developer

  • Tech Issues Solved: 1
  • Joined: 15-July 08
  • Location: my room
  • OS: windows 7/8, Kali, ubuntu, OSx 10.9
  • Phone: Android

Posted 20 March 2013 - 14:53

I am trying to create a VPN but i am having some issues ... when running the following commands:


source vars
./clean-all
./build-ca

I keep getting
"please edit the "vars" script to reflect your configuration , then source it with "source ./vars""

... i have done all of this why wont it work ;(


#2 fusi0n

fusi0n

    Don't call it a come back

  • Tech Issues Solved: 3
  • Joined: 08-July 04
  • OS: OSX 10.9\Elementary OS
  • Phone: LG G3

Posted 20 March 2013 - 15:03

Can you most more info? What VPN Server are you trying to use? Or is this for a Client?

Ah, it looks like you are trying to use openvpn,

From the Ubuntu Forums, try this
1. Restart the PC
2. Open the terminal and type sudo su to log in as root
3. move to the easy-rsa directory (on mine, the files are in easy-rsa/2.0/)
4. type mkdir keys
5. type source ./vars
6. type ./clean-all
7. type ./build-ca

this seemed to work for everyone having issues in that thread..

#3 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 20 March 2013 - 20:41

The TLS-enabled VPN section of the OpenVPN page on the Debian wiki should help. It explains how to generate your keys and integrate them into your server.conf.