Jump to content



Photo

Sound card stopped working.


  • Please log in to reply
15 replies to this topic

#1 Kreuger

Kreuger

    Neowin's Local Grouch

  • Joined: 29-December 03
  • Location: Ontario, Canada

Posted 25 March 2013 - 12:06

So a couple of days ago, I had my laptop hooked up to my tv via HDMI. I used pavucontrol to disable sound on my laptop and play it through the tv. I changed it back when I was done. Can't remember if I used it right away. Last night I tried to use it and it didn't work. I opened pavucontrol again and switched to the configuration tab where there had previously been a drop down menu allowing me to choose what device to output my sound through. Now there's nothing. It says no card available for configuration. When I open asoundconf-gtk it only has "PCH" and selecting that does nothing either.


#2 n_K

n_K

    Neowinian Senior

  • Tech Issues Solved: 3
  • Joined: 19-March 06
  • Location: here.
  • OS: FreeDOS
  • Phone: Nokia 3315

Posted 25 March 2013 - 12:13

Sounds like pulseaudio isn't running, try start-pulseaudio or whatever the command is.
I have problems with pulseaudio on my old dell, for some reason or another (I do not know why) but pulseaudio refuses to start when I login.

#3 OP Kreuger

Kreuger

    Neowin's Local Grouch

  • Joined: 29-December 03
  • Location: Ontario, Canada

Posted 25 March 2013 - 16:05

Apparently it's running.

kreuger@Kreuger-Lenovo-B570:~$ pulseaudio -D
E: [pulseaudio] main.c: Daemon startup failed.
kreuger@Kreuger-Lenovo-B570:~$ pulseaudio --log-level=4 --log-target=stderr
I: [pulseaudio] main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: [pulseaudio] main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
D: [pulseaudio] core-rtclock.c: Timer slack is set to 50 us.
D: [pulseaudio] core-util.c: RealtimeKit worked.
I: [pulseaudio] core-util.c: Successfully gained nice level -11.
I: [pulseaudio] main.c: This is PulseAudio 2.1
D: [pulseaudio] main.c: Compilation host: i686-pc-linux-gnu
D: [pulseaudio] main.c: Compilation CFLAGS: -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security -Wall -W -Wextra -pipe -Wno-long-long -Wvla -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing -Wwrite-strings -Wno-unused-parameter -ffast-math -Wp,-D_FORTIFY_SOURCE=2 -fno-common -fdiagnostics-show-option
D: [pulseaudio] main.c: Running on host: Linux i686 3.5.0-24-generic #37-Ubuntu SMP Thu Feb 7 05:32:22 UTC 2013
D: [pulseaudio] main.c: Found 4 CPUs.
I: [pulseaudio] main.c: Page size is 4096 bytes
D: [pulseaudio] main.c: Compiled with Valgrind support: no
D: [pulseaudio] main.c: Running in Valgrind mode: no
D: [pulseaudio] main.c: Running in VM: no
D: [pulseaudio] main.c: Optimized build: yes
D: [pulseaudio] main.c: FASTPATH defined, only fast path asserts disabled.
I: [pulseaudio] main.c: Machine ID is dede8c4d051e0d61ea80ff9f00000007.
I: [pulseaudio] main.c: Session ID is dede8c4d051e0d61ea80ff9f00000007-1364227283.451700-911705375.
I: [pulseaudio] main.c: Using runtime directory /home/kreuger/.pulse/dede8c4d051e0d61ea80ff9f00000007-runtime.
I: [pulseaudio] main.c: Using state directory /home/kreuger/.pulse.
I: [pulseaudio] main.c: Using modules directory /usr/lib/pulse-2.1/modules.
I: [pulseaudio] main.c: Running in system mode: no
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.



#4 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 26 March 2013 - 15:07

n_K's Pulse Audio suggestion is certainly one possibility. I don't know why the daemon would develop problems after switching audio outputs, but since restarting the daemon is fairly easy to do its probably worthwhile to try that first. It's likely that the daemon failed to start when you last tried it because you didn't try starting it as root. (pa_pid_file_create() could easily have failed due to lack of permissions. As a developer I can definitely understand how "daemon is already running" could cryptically indicate an unanticipated error case; however I have no knowledge of the Pulse Audio codebase and cannot verify that assumption.)

If you are running Debian, Ubuntu, or another Debian derivative the first command below will let you properly (re)start the Pulse Audio service and the second will provide you with an easy way to check that the service is enabled on boot.
sudo service pulseaudio restart
sudo rcconf


#5 OP Kreuger

Kreuger

    Neowin's Local Grouch

  • Joined: 29-December 03
  • Location: Ontario, Canada

Posted 27 March 2013 - 04:42

sudo service pulseaudio restart

This gave me this output:

kreuger@Kreuger-Lenovo-B570:~$ sudo service pulseaudio restart
stop: Unknown instance:
pulseaudio start/running, process 3282


The second one said:

kreuger@Kreuger-Lenovo-B570:~$ sudo rcconf
rcconf needs dialog or whiptail.
kreuger@Kreuger-Lenovo-B570:~$



#6 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 27 March 2013 - 15:44

Restarting the service looks like it worked correctly, but the Pulse Audio service was not started at the time. (That's why stopping the service failed but starting it succeeded.) As for the second issue, install dialog, whiptail, or both so that you can use rcconf.

sudo apt-get install dialog whiptail
sudo rcconf


#7 OP Kreuger

Kreuger

    Neowin's Local Grouch

  • Joined: 29-December 03
  • Location: Ontario, Canada

Posted 28 March 2013 - 16:11

So I ran that and I see two things related to alsa. Am I looking to enable those and PulseAudio?

#8 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 29 March 2013 - 02:44

So I ran that and I see two things related to alsa. Am I looking to enable those and PulseAudio?


Probably. It would be more helpful if I knew exactly which services they are though.

#9 OP Kreuger

Kreuger

    Neowin's Local Grouch

  • Joined: 29-December 03
  • Location: Ontario, Canada

Posted 29 March 2013 - 04:18

alsa-store and alsa-restore.

#10 OP Kreuger

Kreuger

    Neowin's Local Grouch

  • Joined: 29-December 03
  • Location: Ontario, Canada

Posted 30 March 2013 - 17:12

Guess I'll try the ubuntu forums.

#11 OP Kreuger

Kreuger

    Neowin's Local Grouch

  • Joined: 29-December 03
  • Location: Ontario, Canada

Posted 02 April 2013 - 14:31

No luck over there either. I hate having to boot into Win7 to watch videos. :(

#12 OP Kreuger

Kreuger

    Neowin's Local Grouch

  • Joined: 29-December 03
  • Location: Ontario, Canada

Posted 04 April 2013 - 12:58

Using this guide, I've made an output log of trying to use pavucontrol to get sound. Maybe someone can find an issue there?

#13 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 04 April 2013 - 15:23

From the log it looks like PulseAudio is trying to route audio via HDMI instead of through your ICH6 card. Try this suggestion (from here):

I went to Multimedia->Pulse Audio Volume Control then click on the Configuration tab, then set "High Definition Audio Controller" to "Off" and made sure "Built-in Audio" was set to "Analog Stereo Output".

You might then want to check the "Output Devices" tab and make sure the port is set right and it isn't muted and the volume is turned up.

Mine all looked fine in alsamixer and everywhere else before I did this as well, but as soon as I disabled the other controller, sound came on right away.



#14 OP Kreuger

Kreuger

    Neowin's Local Grouch

  • Joined: 29-December 03
  • Location: Ontario, Canada

Posted 05 April 2013 - 12:12

I went to Multimedia->Pulse Audio Volume Control then click on the Configuration tab, then set "High Definition Audio Controller" to "Off" and made sure "Built-in Audio" was set to "Analog Stereo Output".

You might then want to check the "Output Devices" tab and make sure the port is set right and it isn't muted and the volume is turned up.

Mine all looked fine in alsamixer and everywhere else before I did this as well, but as soon as I disabled the other controller, sound came on right away.



This opens pavucontrol which I've stated already has nothing under the configuration tab. It tells me "no cards available".

#15 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 05 April 2013 - 15:13

I don't have too much experience with PulseAudio or the sound stack in Linux in general. I don't think I'm going to be able to help you any more if that last suggestion didn't work. I know how frustrating it is when something - such as HDMI audio - only works with the proprietary driver, which is why I have entirely avoided proprietary drivers in Linux for a couple years. My experience has been much better. While open-source drivers don't always support all the features their proprietary counterparts (at least not immediately), they are generally infinitely more reliable in my experience. Sorry that I couldn't help. Good luck.