Jump to content



Photo

How to permanently disable libraries in Windows 8?


  • This topic is locked This topic is locked
88 replies to this topic

#1 jebus197

jebus197

    Neowinian

  • Joined: 08-March 07

Posted 06 April 2013 - 23:15

OK, the title says it all. "How do I permanently disable libraries in Windows 8?" I won't go into details why I want to do it, as there are many. But mostly it's because the libraries feature is causing icons to not automatically refresh after they are deleted.

I did manage to disable it briefly via regedit, after following some guides on-line, but it came back after a reboot.

Also the guides that are available for disabling this feature in Windows 7, don't appear to work on Windows 8.

All suggestions are welcome.


#2 OP jebus197

jebus197

    Neowinian

  • Joined: 08-March 07

Posted 06 April 2013 - 23:40

This looks like a challenge for only the ubergeeks among us. I have looked extensively and I can find no reference to how to permanently disable libraries in Windows 8. Indeed I believe this might even be a 'design feature' where Microsoft may have known that people in the past may have tried to disable the feature via regedit and they don't want users doing this. So even if you edit the registry, MS may have rigged it that Libraries will be aromatically re-enabled anyway?

But surely system admins would like to be able to turn this feature on and off as they please?

#3 NightScreams

NightScreams

    Neowinian

  • Joined: 16-October 12

Posted 07 April 2013 - 00:31

short answer is you can't actually disable it or remove it's function, it's too tightly integrated. You can disable explorer and shell something else or you can use another file manager...i suggest the latter. Plenty of good free ones out there

#4 TPreston

TPreston

    Neowinian Senior

  • Tech Issues Solved: 1
  • Joined: 18-July 12
  • Location: Ireland
  • OS: Windows 8.1 Emterprise & Server 2012R2/08R2 Datacenter
  • Phone: Nokia Lumia 1520 Black

Posted 07 April 2013 - 01:20

You can delete the default library's the files library-ms or something similar are located in %appdata%

#5 OP jebus197

jebus197

    Neowinian

  • Joined: 08-March 07

Posted 07 April 2013 - 16:55

There must be a way? Surely? What I in fact have is very intermittent behaviour. Sometime the libraries feature will show up and prevent me from deleting folders (as above), sometimes it will vanish. I presume this is due to the registry keys I have already edited. Is there no one here who can come up with a concerted single guide to disable the feature entirely?

#6 HawkMan

HawkMan

    Neowinian Senior

  • Tech Issues Solved: 4
  • Joined: 31-August 04
  • Location: Norway
  • Phone: Noka Lumia 1020

Posted 07 April 2013 - 17:05

Libraries tie into everything in Windows 8, short answer is you can't, long answer would just be a detailed version of that.

#7 OP jebus197

jebus197

    Neowinian

  • Joined: 08-March 07

Posted 07 April 2013 - 17:10

Well that's a lot of cr*p then. It was a simple reg hack in Windows 7. Why would MS attempt to force feed us this feature in Windows 8? What happened to the principle of allowing system admins to configure things appropriately for their environment? What at least is the name of the libraries service? I hate being told I can't do something that was perfectly possible and desirable in some scenarios in previous OS versions.

You used to be able to disable it in group policy, but I can't find it there either I think.

#8 CJ33

CJ33

    Neowinian

  • Joined: 03-February 03

Posted 07 April 2013 - 17:25

I hate being told I can't do something that was perfectly possible and desirable in some scenarios in previous OS versions.


sorry guy for the sad news. maybe its easier to realize this by experience instead (of being told)? Windows 7 is always an option if Windows 8 is too abhorrent.

#9 BannanaNinja

BannanaNinja

    Neowinian

  • Joined: 14-February 11
  • Location: US
  • OS: Windows 8.1
  • Phone: Windows Phone 8

Posted 07 April 2013 - 17:26

I suspect its because Modern apps can only access files in the libraries (unless the user specifies one in a file picker) and therefore they need to be around. Internally, Windows Phone 8 uses the same libraries as well. Like previously stated, they are baked deep into the OS.

#10 +Brandon Live

Brandon Live

    Seattle geek

  • Joined: 08-June 03
  • Location: Seattle, WA

Posted 07 April 2013 - 17:31

This is like asking how to disable folders. The question doesn't make sense.

It sounds like you've already introduced several problems by mucking with internal system data and state (i.e. in the registry). You might consider a system restore or PC Refresh/Reinstall to fix that.

But mostly it's because the libraries feature is causing icons to not automatically refresh after they are deleted.


This doesn't make sense. I suggest stepping back and asking for help with your original problem (with some more detail).

#11 OP jebus197

jebus197

    Neowinian

  • Joined: 08-March 07

Posted 07 April 2013 - 17:53

I already did. Check my other post regarding regarding this topic. I know exactly what I'm talking about thanks.Please stop telling people to do major restorative work to resolve relatively simple problems. It isn't helpful. It doesn't make you look nearly as clever as you might think.

#12 OP jebus197

jebus197

    Neowinian

  • Joined: 08-March 07

Posted 07 April 2013 - 18:01

If it was so darn impossible, how come I could do it in Windows 7? I get that some folks are claiming that it is now 'hard baked' into the OS, but MS have stated that the libraries feature hasn't changed at all between Windows 7 and Windows 8. I'm sure there may be a few small .reg key changes here or there and that this is more likely to be what I'm missing, but the Windows 7 machine I upgraded from had libraries already disabled. Upgrading to Windows 8 re-enabled them.

How about editing library locations, or getting the library indexer to point to an empty/unused location, or something of that order? If It's a service what exactly might the service be called?

#13 HawkMan

HawkMan

    Neowinian Senior

  • Tech Issues Solved: 4
  • Joined: 31-August 04
  • Location: Norway
  • Phone: Noka Lumia 1020

Posted 07 April 2013 - 18:13

You know, because windows 8 isn't windows 7, in windows 7 libraries where barely implemented. Windows 8 is a whole new OS, and it uses libraries throughout the OS, not just superficially.

So no there's not big or small reg changes you can do. You'd need to rip out most of what makes Windows 8 windows 8.

#14 OP jebus197

jebus197

    Neowinian

  • Joined: 08-March 07

Posted 07 April 2013 - 18:17

Well I can see how that might be the case. But I will still look for a work around. I have no evidence beyond your word that this is the case currently however. How are you so sure or are you simply making assumptions?

I would do the usual routine about being p*ssed off and about wanting to change to an OS where my hands aren't tied and I'm not forced to do things someone else's way. But I have to keep my IT skills current and none of the jobs I do will care about how I feel about MS products. I have previously disabled libraries as a fix for a number of scenarios. I need it as a fix in my own case right now. But if you guys are right (and right now I think that's only an if) then this may no longer be possible.

#15 xendrome

xendrome

    In God We Trust; All Others We Monitor

  • Tech Issues Solved: 9
  • Joined: 05-December 01
  • OS: Windows 8.1 Pro x64

Posted 07 April 2013 - 18:17

I already did. Check my other post regarding regarding this topic. I know exactly what I'm talking about thanks.Please stop telling people to do major restorative work to resolve relatively simple problems. It isn't helpful. It doesn't make you look nearly as clever as you might think.


http://www.neowin.ne...s-not-updating/

Is your previous topic, do a FRESH LOAD already. You already said your Windows 7 load prior to the Upgrade was highly "customized" which is the cause of your problems... mine works fine, everyone else's works fine, so go do a fresh load and move on please.