Jump to content



Photo

  • Please log in to reply
13 replies to this topic

#1 Elliot B.

Elliot B.

    Over 12 years on Neowin

  • Tech Issues Solved: 4
  • Joined: 16-August 01
  • Location: West Midlands, UK
  • OS: Windows 8.1
  • Phone: Samsung Galaxy S5

Posted 07 April 2013 - 17:34

I live in a house with multiple people, and I want to share a folder that only my partner can access.

How do I do this?

Currently, when I right-click on a folder and choose "Share with" and "Specific people...", I only get the options of myself, Guest and Everyone.

I've used Everyone and she can access the folder with no issues, but this of course means anyone on the network can view the folder contents.

Side note: I don't use a password to access Windows on my PC.


#2 +BudMan

BudMan

    Neowinian Senior

  • Tech Issues Solved: 86
  • Joined: 04-July 02
  • Location: Schaumburg, IL
  • OS: Win7, Vista, 2k3, 2k8, XP, Linux, FreeBSD, OSX, etc. etc.

Posted 07 April 2013 - 17:42

If you want to limit who can access then create an account on your machine called share or their name, etc. And then set a password on this account, then you can set permissions permissions on this folder for that account - they would then auth with that account to access your shares remotely and would have the access you have given that account.

#3 OP Elliot B.

Elliot B.

    Over 12 years on Neowin

  • Tech Issues Solved: 4
  • Joined: 16-August 01
  • Location: West Midlands, UK
  • OS: Windows 8.1
  • Phone: Samsung Galaxy S5

Posted 07 April 2013 - 18:18

If you want to limit who can access then create an account on your machine called share or their name, etc. And then set a password on this account, then you can set permissions permissions on this folder for that account - they would then auth with that account to access your shares remotely and would have the access you have given that account.

OK, I have created a Local, passworded account on my PC.

Then I went to "Share with" and "Specific people..." and her account appears.

Now how can she remotely access the shared folder using her laptop, mate?

#4 lunamonkey

lunamonkey

    Ten years on Neowin.

  • Joined: 28-May 03
  • Location: Swindon, England

Posted 07 April 2013 - 18:20

OK, I have created a Local, passworded account on my PC.

Then I went to "Share with" and "Specific people..." and her account appears.

Now how can she remotely access the shared folder using her laptop, mate?


\\YourPC\YourShare

Assuming that your Windows Folder Sharing is enabled in Network centre, and you've allowed the firewall option for the same.

They can then either map drives or like mine, they will magically* appear.




*Not Magic

Attached Images

  • Untitled.png


#5 OP Elliot B.

Elliot B.

    Over 12 years on Neowin

  • Tech Issues Solved: 4
  • Joined: 16-August 01
  • Location: West Midlands, UK
  • OS: Windows 8.1
  • Phone: Samsung Galaxy S5

Posted 07 April 2013 - 18:30

"You do not have permission to access \\ELLIOT-PC\Pictures. Contact your network administrator to request access.

For more information about permissions, see Windows Help and Support"

:(

#6 lunamonkey

lunamonkey

    Ten years on Neowin.

  • Joined: 28-May 03
  • Location: Swindon, England

Posted 07 April 2013 - 18:47

When you right click and set security, there is windows permissions, but also permission in the sharing options. Make sure they are in both security + permissions. (I've got everyone enabled, but you just put your required users).

Attached Images

  • Untitled.png


#7 OP Elliot B.

Elliot B.

    Over 12 years on Neowin

  • Tech Issues Solved: 4
  • Joined: 16-August 01
  • Location: West Midlands, UK
  • OS: Windows 8.1
  • Phone: Samsung Galaxy S5

Posted 07 April 2013 - 18:58

Still not working :/

I have attached some screenshots to this post - does everything look correct to you?

eb_sharewtriin1.png

eb_sharewtriin2.png

eb_sharewtriin3.png

#8 lunamonkey

lunamonkey

    Ten years on Neowin.

  • Joined: 28-May 03
  • Location: Swindon, England

Posted 07 April 2013 - 19:02

Is it called Photos or Pictures?

Yep, unless it's possible for the Everyone setting to take precedence? Not sure.

What about your Network center? You checked filewall? Can you access the share locally to yourself?

Attached Images

  • advanced sharing.png
  • all networks.png


#9 OP Elliot B.

Elliot B.

    Over 12 years on Neowin

  • Tech Issues Solved: 4
  • Joined: 16-August 01
  • Location: West Midlands, UK
  • OS: Windows 8.1
  • Phone: Samsung Galaxy S5

Posted 07 April 2013 - 19:31

I have no firewall (the Firewall service is disabled).

The folder I am trying to share is located at E:\My Pictures. It's not a system folder, just my own folder.

\\ELLIOT-PC\My Pictures works fine on my PC.

#10 lunamonkey

lunamonkey

    Ten years on Neowin.

  • Joined: 28-May 03
  • Location: Swindon, England

Posted 07 April 2013 - 19:40

That's a different variation again? :s

You have 'Photos' in the screen shot, and 'Pictures' in the error message you posted.

What happens if you just type \\Elliot-PC\ on the guest? Do you get the lists of shares, like this?

Attached Images

  • shares.png


#11 episode

episode

    Neowinian Fanatic

  • Tech Issues Solved: 3
  • Joined: 11-December 01

Posted 07 April 2013 - 19:40

1) Don't use spaces in shares. Just a bad practice.
2) Don't use the name of something that may exist normally in Windows - Documents, Pictures, Videos, Music - for example in Windows 7.

Make the share (and folder name, if you want) just 'Pics' so they would do \\elliot-pc\pics

If that doesn't work, try mapping the drive (under computer -> Map Network Drive) and check the 'connect as a different user' option. Then fill in the user information you created. If the username is the same on the other PC but the passwords are different between the two, you may have an issue there.

#12 OP Elliot B.

Elliot B.

    Over 12 years on Neowin

  • Tech Issues Solved: 4
  • Joined: 16-August 01
  • Location: West Midlands, UK
  • OS: Windows 8.1
  • Phone: Samsung Galaxy S5

Posted 07 April 2013 - 19:46

Now when I try to access \\Elliot-PC\ on her laptop, it brings up a password screen.

I enter Triin as the username and enter the password that was set for the Triin account on my PC - but it still doesn't connect.

EDIT: Mapping a network drive worked for fine for this folder. However, if I want to share 5 folders, there would be 5 mapped drives, which would be messy.

#13 lunamonkey

lunamonkey

    Ten years on Neowin.

  • Joined: 28-May 03
  • Location: Swindon, England

Posted 07 April 2013 - 19:50

Now when I try to access \\Elliot-PC\ on her laptop, it brings up a password screen.

I enter Triin as the username and enter the password that was set for the Triin account on my PC - but it still doesn't connect.


Try your account on the laptop (on that same password screen) just for fun. Then at least it might narrow it down.

I doubt it will let you though seeing as you don't have a password. ..... Maybe sharing is messing up because of that. hmmm....

#14 +BudMan

BudMan

    Neowinian Senior

  • Tech Issues Solved: 86
  • Joined: 04-July 02
  • Location: Schaumburg, IL
  • OS: Win7, Vista, 2k3, 2k8, XP, Linux, FreeBSD, OSX, etc. etc.

Posted 07 April 2013 - 20:49

You can not be authed to a machine with more than 1 account - you prob authed as guest at first.

Clear all sessions to the machine doing the sharing from the machine wanting to access the share - and then access the machine \\machinename and auth with the correct username and password that has access you want to use.

Its easier if you just use the same username and password on both machines.