Jump to content



Photo

freezing on boot


  • Please log in to reply
7 replies to this topic

#1 Haggis

Haggis

    Neowinian Senior

  • Tech Issues Solved: 15
  • Joined: 13-June 07
  • Location: Near Stirling, Scotland
  • OS: Debian 7
  • Phone: Samsung Galaxy S3 LTE (i9305)

Posted 10 April 2013 - 08:02

ok guys when i boot up i get to the desktop but then the system freezes for around two mins

i get these messages in dmesg

[   53.158388] SELinux: initialized (dev proc, type proc), uses genfs_contexts
[   55.822073] sd 6:0:0:0: [sdc] Test WP failed, assume Write Enabled
[   55.825696] sd 6:0:0:0: [sdc] Asking for cache data failed
[   55.825703] sd 6:0:0:0: [sdc] Assuming drive cache: write through
[  107.533980] sd 6:0:0:0: [sdc] Test WP failed, assume Write Enabled
[  107.536740] sd 6:0:0:0: [sdc] Asking for cache data failed
[  107.536749] sd 6:0:0:0: [sdc] Assuming drive cache: write through
[  159.247858] sd 6:0:0:0: [sdc] Test WP failed, assume Write Enabled
[  159.250129] sd 6:0:0:0: [sdc] Asking for cache data failed
[  159.250140] sd 6:0:0:0: [sdc] Assuming drive cache: write through

so the error is with sdc

now my fstab lokes like this



UUID=85f32258-abfd-4be3-b811-ee3c29374b4d /					   ext4	defaults,discard,noatime,nodiratime		1 1
UUID=61aea991-ee93-422f-8e48-791d95c11bdd /boot				   ext4	defaults,discard,noatime,nodiratime		1 2
UUID=ea98ec6e-6a6c-48bb-9cf4-646fa6984764 /home				   ext4	defaults,discard,noatime,nodiratime		1 2
UUID=3a180335-d90e-48c7-840f-2097f9c49a8f swap					swap	defaults,discard,noatime,nodiratime		0 0
none /tmp tmpfs defaults 0 0
/dev/sda1 /home/haggis/Storage ext4 defaults 0 0


the lines staring UUID are on sdb and the /dev/sda1 obviously on sda

i have no sd cards, usb stick etc plugged in and i am now stumped

any ideas?


#2 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 10 April 2013 - 13:45

This looks like your issue exactly: http://askubuntu.com...e-write-enabled It's a confirmed bug in Ubuntu 12.04 (but may also be present in other distributions, such as Fedora).

On an unrelated note, it would probably be a good idea to mount your storage drive by UUID instead of dev name. You can get the UUID of sda1 as follows:
ls -l /dev/disk/by-uuid | grep sda1 | grep -oE '([A-Za-z0-9]+[\-])+[A-Za-z0-9]+'

Changing the "0 0" to "1 2" in your sda1 mount options so that the partition is periodically checked for consistency on boot wouldn't be a bad idea either.

#3 ViperAFK

ViperAFK

    Neowinian Senior

  • Tech Issues Solved: 3
  • Joined: 07-March 06
  • Location: Vermont

Posted 10 April 2013 - 13:59

Does your machine have a realtek SD card reader? If so it looks like this bug: https://bugzilla.red...g.cgi?id=769747

#4 OP Haggis

Haggis

    Neowinian Senior

  • Tech Issues Solved: 15
  • Joined: 13-June 07
  • Location: Near Stirling, Scotland
  • OS: Debian 7
  • Phone: Samsung Galaxy S3 LTE (i9305)

Posted 10 April 2013 - 14:57

Thanks xorangekiller i will fix that later

ViperAFK: it sure is (had to check online as not at computer) so will check into this too

#5 OP Haggis

Haggis

    Neowinian Senior

  • Tech Issues Solved: 15
  • Joined: 13-June 07
  • Location: Near Stirling, Scotland
  • OS: Debian 7
  • Phone: Samsung Galaxy S3 LTE (i9305)

Posted 10 April 2013 - 15:49

if i find the driver thats knocking it off

can i just do


$sudo modprobe -r ums_realtek

and then this to reenable?

$sudo modprobe ums_realtek

#6 ViperAFK

ViperAFK

    Neowinian Senior

  • Tech Issues Solved: 3
  • Joined: 07-March 06
  • Location: Vermont

Posted 10 April 2013 - 16:07

if i find the driver thats knocking it off

can i just do


$sudo modprobe -r ums_realtek

and then this to reenable?
$sudo modprobe ums_realtek


to stop it at boot in fedora 18 I believe you can do the following:

Edit your /etc/default/grub file and look for a line that starts with GRUB_CMDLINE_LINUX= and append your rd.driver.blacklist=ums_realtek parameter to the end of what is there. And then run grub2-mkconfig -o /boot/grub2/grub.cfg

#7 OP Haggis

Haggis

    Neowinian Senior

  • Tech Issues Solved: 15
  • Joined: 13-June 07
  • Location: Near Stirling, Scotland
  • OS: Debian 7
  • Phone: Samsung Galaxy S3 LTE (i9305)

Posted 10 April 2013 - 16:16

awesome will give it a bash when i get home

read a workaround is to put a SD card in the slot

so will try that first to try and confirm it is the card reader

#8 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 10 April 2013 - 22:22

You could blacklist the driver on the GRUB command line, but that's probably not the best solution. I definitely recommend that you blacklist it in modprobe.d. For example:

sudo modprobe -r ums_realtek
sudo touch /etc/modprobe.d/blacklist-realtek.conf
echo 'blacklist ums_realtek' | sudo tee /etc/modprobe.d/blacklist-realtek.conf