Jump to content



Photo

how do i write this in pseudocode?

pseudocode python coding

  • Please log in to reply
15 replies to this topic

#1 jacobace

jacobace

    Neowinian

  • Joined: 26-April 13

Posted 26 April 2013 - 03:22

i understand this is not vb or c++ or anything, i used a program called python and its pretty simple to understand if someone could help me write it in pseudocode that would be awesome thankyou.


#version 0.0.5
class Game:

# Initialises variables
def __init__(self):
self._exit = False

# Array of known commands
self._commands = {
'go': self._go,
'quit': self._quit,
"look" : self._look}

# Array of go sub commands, used by _go
self._commands_go = {"north": self._go_north,
"south" : self._go_south,
"east" : self._go_east,
"west" : self._go_west,
"up" : self._go_up,
"down" : self._go_down}

# Method for parsing command, if it gets "comamnd" returns ("command",None)
@staticmethod
def parse_command(string):
index = string.find(' ')
if index < 0:
return (string, None)
return (string[:index], string[index+1:])

# This is main method; the only one which should be called from outside
# It will just read data from input in never ending loop and parse commands
def run(self):
while not self._exit:
src = input('> ')
(command,args) = Game.parse_command( src)

# Do we have this command, execute it
if command in self._commands:
self._commands[command](args)
else:
print("huh?")


#######################################################
############## All game commands go here ##############
#######################################################
def _quit(self,args):
self._exit = True
print("OK ... but a small part of you may never leave until you have personally saved Muirfieland from the clutches of evil .. Bwahahahahahah (sinister laugh)")

def _look(self,args):
print("You see nothing but endless void stretching off in all directions")

# movement handling, will get executed when user types 'go ...' and '...' will be in arg
def _go(self,args):
if args is None:
print("please tell me more",)
return False

# splits sub command and arguments
(command,args) = Game.parse_command(args)
if command not in self._commands_go:
print( "Sorry, I'm afraid I can't do that !")
return False

self._commands_go[command](args)
return True

# directions
def _go_north(self, args):
print("You wander of in the direction of north")

def _go_south(self, args):
print("You wander of in the direction of south")

def _go_east(self, args):
print("You wander of in the direction of east")

def _go_west(self, args):
print("You wander of in the direction of west")

def _go_up(self, args):
print("You wander of in the direction of up")

def _go_down(self, args):
print("You wander of in the direction of down")

#runs the game
game = Game()
game.run()


#2 Kami-

Kami-

    ♫ d(-_-)b ♫

  • Tech Issues Solved: 3
  • Joined: 28-July 08
  • Location: SandBox

Posted 26 April 2013 - 07:12

Sounds like you want us to do your homework...

#3 Nick H.

Nick H.

    Neowinian Senior

  • Tech Issues Solved: 17
  • Joined: 28-June 04
  • Location: Switzerland

Posted 26 April 2013 - 07:26

If you understand the code that you have pasted then there should be no need for us to write the pseudocode for you. As a general rule in development, the pseudocode comes before the real code in an attempt to keep you focused. If you understand the code above then you can just break down what it does in to simple English.

#4 XerXis

XerXis

    Neowinian Senior

  • Tech Issues Solved: 2
  • Joined: 13-February 06
  • Location: Belgium

Posted 26 April 2013 - 07:39

strange question, I agree with Intrinsica. To write it in pseudocode you just have to describe what it does in normal english without elaborating too much. It's not like there is an accepted standard for pseudocode, because that would make it code ;)

#5 OP jacobace

jacobace

    Neowinian

  • Joined: 26-April 13

Posted 26 April 2013 - 09:07

If you understand the code that you have pasted then there should be no need for us to write the pseudocode for you. As a general rule in development, the pseudocode comes before the real code in an attempt to keep you focused. If you understand the code above then you can just break down what it does in to simple English.


no its not my homework...
i agree with what your saying but ive already written out the code..
just a few questions, do define something in pseudocode do you "dim" it in pseudocode?

heres what ive got so far.
class game
dim _init_(self):
  self._exit = false
  self._command = { "go" : self._go, "quit" : self._quit, "look" : self._look}
  self._commands_go = {"north" : self._go_north, "south" : self._go_south, "east" : self._go_east, "west" : self._go_west, "up" : self._go_up, "down" : self._go_down}
@staticmethod
dim parser(string):
  index = string. find (" ")
  if index < 0 then
   return (string, none)
  end if
  return (string(:index), string(index+1:))
dim run(self):
   while not self._exit:
   src = input("> "
   (command,args) = game.parse_command(src)
  
   if command in self._commands then
    self._commands[command](args)
   else:
    print("huh?")
   end if
dim_quit(self,args):
  self._exit = true
  print("OK ... but a small part of you may never leave until you have personally saved Muirfieland from the clutches of evil .. Bwahahahahahah (sinister laugh)")
dim _look(self,args):
  print("You see nothing but endless void stretching off in all directions")
dim_go(self,args):
   if args is none then
    print("please tell me more")
    return false
   end if
  (command,args) = game.parse_command(args)
  if command not in self._commands_go then
   print("Sorry, I'm afraid I can't do that !")
   return false
  end if
  self._commands_go[command](args)
  return true
dim _go_north(self, args):
		  print("You wander of in the direction of north")
dim _go_south(self, args):
		  print("You wander of in the direction of south")
dim_go_east(self, args):
		  print("You wander of in the direction of east")
dim_go_west(self, args):
		  print("You wander of in the direction of west")
dim_go_up(self, args):
		  print("You wander of in the direction of up")
dim_go_down(self, args):
		  print("You wander of in the direction of down")
game = game()
game.run()



#6 Nick H.

Nick H.

    Neowinian Senior

  • Tech Issues Solved: 17
  • Joined: 28-June 04
  • Location: Switzerland

Posted 26 April 2013 - 09:16

Ok, a fair start. But here's the thing: I try to think of pseudocode like when I'm trying to explain to an end user what I'm doing and they don't understand computers. It's sort of in between actual code and pure English.

For example:

Request value for int from user
if int > 5
goto [step 2]
else
goto [step 3]

[step 2] = say "Hello"

[step 3] = say "Leave me alone"

From that you can understand what is happening in the code without having to be a programmer. Note that the above example isn't the best in the world, but hopefully it helps to get the idea across.

#7 OP jacobace

jacobace

    Neowinian

  • Joined: 26-April 13

Posted 26 April 2013 - 10:22

Ok, a fair start. But here's the thing: I try to think of pseudocode like when I'm trying to explain to an end user what I'm doing and they don't understand computers. It's sort of in between actual code and pure English.

For example:

Request value for int from user
if int > 5
goto [step 2]
else
goto [step 3]

[step 2] = say "Hello"

[step 3] = say "Leave me alone"

From that you can understand what is happening in the code without having to be a programmer. Note that the above example isn't the best in the world, but hopefully it helps to get the idea across.


i understand what you're saying, but I'm defining and using classes, not if statements

#8 Nick H.

Nick H.

    Neowinian Senior

  • Tech Issues Solved: 17
  • Joined: 28-June 04
  • Location: Switzerland

Posted 26 April 2013 - 10:41

i understand what you're saying, but I'm defining and using classes, not if statements

You're right, but I'm also not going to write out your pseudocode for you. ;)

At the top of your code you set your commands and sub-commands.
Next it looks like you're waiting for the user to input a command.
Once the input has been given, the program jumps to the necessary location to execute the result.

The above is more English than it is pseudocode, and you would also want to provide more detail about each of the commands on the last section.

There's no need to think in classes and arrays for pseudocode (at least, in my mind). The whole point of pseudocode is that it is a way for anyone to understand what the program is doing at each step, almost like the commenting that you already added in the code itself.

#9 saltysaltybk

saltysaltybk

    Neowinian

  • Joined: 30-March 07

Posted 26 April 2013 - 11:08

This is homework- my school sniffer is in full force.

#10 +GreenMartian

GreenMartian

    Neowinian Senior

  • Joined: 28-August 04
  • Location: adelaide, au

Posted 26 April 2013 - 11:50

Pseudocode is usually used so non-programmers can understand what a piece of code does, or to express to a programmer what his/her code should do, without actually knowing any programming language.

Your 'pseudocode' looks like you just replaced 'def' with 'dim', and 'if... :' with 'if...then'.
Ask yourself this; would a non-programmer even know what 'dim' is?

You say your code is a class and some functions. I say it could very easily be expressed in a series of if statements.

Get user input
If input 1st word = "go" then
  If input 2nd word = "north" then
	print "wandering north"
  else if input 2nd word = "south" then
	print "wandering south"
  ...
  end 2nd word check
else if input 1st word = "look"
  print "you see nothing"
...
end 1st word check

I'm sure if you give that to your mom, she'd probably grasp what the code is trying to do.

#11 OP jacobace

jacobace

    Neowinian

  • Joined: 26-April 13

Posted 26 April 2013 - 12:09

Pseudocode is usually used so non-programmers can understand what a piece of code does, or to express to a programmer what his/her code should do, without actually knowing any programming language.

Your 'pseudocode' looks like you just replaced 'def' with 'dim', and 'if... :' with 'if...then'.
Ask yourself this; would a non-programmer even know what 'dim' is?

You say your code is a class and some functions. I say it could very easily be expressed in a series of if statements.

Get user input
If input 1st word = "go" then
  If input 2nd word = "north" then
	print "wandering north"
  else if input 2nd word = "south" then
	print "wandering south"
  ...
  end 2nd word check
else if input 1st word = "look"
  print "you see nothing"
...
end 1st word check

I'm sure if you give that to your mom, she'd probably grasp what the code is trying to do.


oh ok, i always through pseudocode was mean for "non programmers" to understand YOUR code, not how it works

This is homework- my school sniffer is in full force.


im just doing purely a out of my own curiosity, yes im in year 12 software design and development, and i need to know pseudocode but my skills arent exactly very good, so i got an existing program which was a project and im using that as an example.

#12 saltysaltybk

saltysaltybk

    Neowinian

  • Joined: 30-March 07

Posted 26 April 2013 - 12:20

Pseudocode is whatever you make it- As far as I can remember there are no hard and fast rules.

#13 +GreenMartian

GreenMartian

    Neowinian Senior

  • Joined: 28-August 04
  • Location: adelaide, au

Posted 26 April 2013 - 12:22

oh ok, i always through pseudocode was mean for "non programmers" to understand YOUR code, not how it works


Well, pseudocode doesn't really have a rigid definition. You can do whatever you like, depending on the target audience.

If you're trying to explain a program you just wrote to your mom, then you probably want to express it in REALLY simple terms as I did above.

If you're trying to explain the code to a fellow programmer unfamiliar to Python, you could probably use some jargons from a language that he understands, and simplify the code (e.g. don't even bother including the 'self' argument. It doesn't contribute to what the code does).

It's a bit like public speaking; know your audience, and how much to 'dumb it down' so they understand what you're talking about.

#14 Andre S.

Andre S.

    Asik

  • Tech Issues Solved: 14
  • Joined: 26-October 05

Posted 26 April 2013 - 13:21

Well, pseudocode doesn't really have a rigid definition. You can do whatever you like, depending on the target audience.

I wish they had told us that in university back when they started asking for programs in "pseudocode"... Everyone was so confused as to what to write exactly!

#15 OP jacobace

jacobace

    Neowinian

  • Joined: 26-April 13

Posted 26 April 2013 - 13:43

I wish they had told us that in university back when they started asking for programs in "pseudocode"... Everyone was so confused as to what to write exactly!


thats exactly how i feel!!,like we went over pseudocode in class, but everyone has there weaknesses and unfortunatly pseudocode is mine, and i suppose the "form" of pseudocode we learned was different because i cant find that 'form' on the internet or anything. which is why im asking people for help.

I wish they had told us that in university back when they started asking for programs in "pseudocode"... Everyone was so confused as to what to write exactly!


i mostly dont learn software from websites and help, i learn from examples and i see how they do it and pick up techniques/theory from that