Jump to content



Photo

serious help on wamp/xampp


  • Please log in to reply
6 replies to this topic

#1 SlayerS_BoxeR

SlayerS_BoxeR

    Neowinian

  • Joined: 10-December 12
  • OS: OS X Mavericks
  • Phone: Iphone 5

Posted 04 May 2013 - 07:07

I was trying for both, but can't get into apache server
I even changed the port 80 to 81 and port 442 to 443/4.

So When I type the localhost, it fails

I was searching, then I noticed how it deals with IIS. So I tried installing it, but it failed. I even checked the Windows Process Activation Service BOX, but I was not able to install.

I'm trying to use php/mysql from my home

Any help please


#2 +Seahorsepip

Seahorsepip

    http://seapip.com

  • Tech Issues Solved: 16
  • Joined: 23-January 11
  • Location: Netherlands
  • OS: Windows 8.1 Pro
  • Phone: Nexus 5

Posted 05 May 2013 - 12:02

Are you sure that your isp allows to host websites trough port80?

#3 n_K

n_K

    Neowinian Senior

  • Tech Issues Solved: 3
  • Joined: 19-March 06
  • Location: here.
  • OS: FreeDOS
  • Phone: Nokia 3315

Posted 05 May 2013 - 12:05

Are you sure that your isp allows to host websites trough port80?

Errr, what? Localhost will work reguardless of your ISP blocking ports or not.

Open cmd and do netstat -a and also check task manager, is apache running? Do you have a firewall?

#4 Kami-

Kami-

    ♫ d(-_-)b ♫

  • Tech Issues Solved: 2
  • Joined: 28-July 08
  • Location: SandBox

Posted 07 May 2013 - 11:36

Did you actually 'Start Apache Service' from the menus?

#5 ajcdotme

ajcdotme

    General Nitwit

  • Joined: 17-November 11
  • Location: Ligonier, PA
  • OS: OSX, Centos 6, Ubuntu, SmartOS, Windows Server
  • Phone: Nokia Lumia 822

Posted 07 May 2013 - 11:41

Run xampp control center as admin, then start apache from the control center and see if it actually starts.

Also, try using http://127.0.0.1 as your address instead of localhost if this isn't a clean or well protected install. It's possible for malware or other (possibly legit) programs to have modified your .hosts file to point localhost at another ip address.

Admittedly the latter is far-fetched, but always good to check the simple things :)

#6 Lathanielt

Lathanielt

    Daniel

  • Joined: 06-August 06
  • Location: Windhoek
  • OS: Windows 8 Professional
  • Phone: Android Gingerbread

Posted 07 May 2013 - 11:45

Run xampp control center as admin, then start apache from the control center and see if it actually starts.

Also, try using http://127.0.0.1 as your address instead of localhost if this isn't a clean or well protected install. It's possible for malware or other (possibly legit) programs to have modified your .hosts file to point localhost at another ip address.

Admittedly the latter is far-fetched, but always good to check the simple things :)


I agree with the above post, and also check for applications that may be making use of the same port mappings, on my machine the usual suspect is Skype. If you do have it, just change the connection settings under advanced.

#7 +Seahorsepip

Seahorsepip

    http://seapip.com

  • Tech Issues Solved: 16
  • Joined: 23-January 11
  • Location: Netherlands
  • OS: Windows 8.1 Pro
  • Phone: Nexus 5

Posted 10 May 2013 - 09:12

If you use localhost don't use port 80, that will never work since quite a few applications use it already, skype as example.
try port 8888 or 8887 example: http://localhost:8888

If you don't want too much hassle install easyphp, way easier to setup lol

Errr, what? Localhost will work reguardless of your ISP blocking ports or not.

Oops my bad >.>



Click here to login or here to register to remove this ad, it's free!