Sign in to follow this  
Followers 0
devnulllore

Windows 8 and Admin Rights

16 posts in this topic

Hi,

I've looked around and found no concrete explanation of what to do to fix this issue. I finally gave in and bought Windows 8 Pro x64 and I turned off UAC as I always do. My profile is administrator but no matter what I do, if it requires admin rights, I either get the annoying message asking if I want to continue with admin rights or I just get stopped. For example with 7-zip if I use the context menu to drag and extract it fails saying this function needs elevated privileges. I have tried adding run as admin to all the exe files for 7-zip but that Fixes nothing. I think I am just missing some small setting.

Can anyone fix this?

Thanks!

Share this post


Link to post
Share on other sites

Disabled or silenced UAC? The suppression method used by the drag and drop action still hasn't been addressed by 7Zip to my knowledge (as it creates a temp copy in a protected location - a no no)

I'll wager it works normally if you used the builtin Administrator account. Or give your user ownership of the temp location and 'Allow' full control.

Share this post


Link to post
Share on other sites

try HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System

EnableLUA =0

Reboot

2 people like this

Share this post


Link to post
Share on other sites

try HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System

EnableLUA =0

Reboot

This will completely disable UAC, however it also disables all Metro apps, so it's a trade-off.

Share this post


Link to post
Share on other sites

Ok, this is going beyond the posted issue now. I can't even add or remove add ins for Outlook anymore. It keeps saying adding or removing Outlook add ins requires an administrator.

My account is set as admin so how do I fix it so Windows 8 knows I am?

Cheers,

Share this post


Link to post
Share on other sites

Ok, this is going beyond the posted issue now. I can't even add or remove add ins for Outlook anymore. It keeps saying adding or removing Outlook add ins requires an administrator.

My account is set as admin so how do I fix it so Windows 8 knows I am?

Cheers,

Oh quirk with Outlook; If you change the state of UAC after Outlook was installed then it goes all funny

Share this post


Link to post
Share on other sites

Oh quirk with Outlook; If you change the state of UAC after Outlook was installed then it goes all funny

Well no that's just part of the problem. Every time I do something that requires admin rights, even as an admin, I have to give MYSELF permission to do it.

I just want to be able to do any admin required stuff without either having to give myself permission or getting stopped altogether.

Thanks,

Share this post


Link to post
Share on other sites

I would say firstly reset UAC settings by going to "User Account Control Settings". Move the slider to never notify, press ok, go back in and set back to normal level.

Open up "local security policy"

Local policy > security options

Change the policy called "user account control: behaviour of the elevation prompt for administrators in admin approval mode" to "elevate without prompting" then reset computer.

This should fix things for you.

Share this post


Link to post
Share on other sites

HI,

Yes that is already set. I am now at wits end. By all accounts I have full admin rights but errors pop up all over the place saying, this or that can't be done as you may not have sufficient privileges. Last night I was installing a game and it kept crashing saying the thing about unable to create file you may not have sufficient privileges. I had to go into the install folder and add 'run as administrator' to all the executables compatibility settings just to get it installed.

What is going on?

Thanks again for any help!

Share this post


Link to post
Share on other sites

NTFS permissions != UAC. By default it wont let you copy files into system directory's and program files. If you do have a game or something and you want to edit its config files a lot edit the ntfs permissions for that games folder or just the config files folder and give your account full control

Run Gpedit.msc and set

b40f44286fa348857a8277b89e61d75c.png

instead of disableing UAC

Finally verify your account is a member of the administrators group in local users and groups lusrmgr.msc

Share this post


Link to post
Share on other sites

NTFS permissions != UAC. By default it wont let you copy files into system directory's and program files. If you do have a game or something and you want to edit its config files a lot edit the ntfs permissions for that games folder or just the config files folder and give your account full control

Run Gpedit.msc and set

b40f44286fa348857a8277b89e61d75c.png

instead of disableing UAC

Finally verify your account is a member of the administrators group in local users and groups lusrmgr.msc

Ok, UAC is back on and those settings in the GPE are set as you specified now. I will let you know how it works.

Thanks,

Share this post


Link to post
Share on other sites

Ok, wow, that made things worse. Now everything I try to do, install anything or copy files etc.. gets stopped and most of the time I get no other option but to cancel the action. I have literally crippled my use with those changes. What can I do now?

Thanks,

Share this post


Link to post
Share on other sites

A repair install probably because that shouldnt be happening, its not misconfiguration.

Share this post


Link to post
Share on other sites

A repair install probably because that shouldnt be happening, its not misconfiguration.

Yeah, I tried that last night but it got to 1% the rebooted and said there was a problem. I clicked 'find a fix' and it chugged along for an hour then did nothing. I am going to do an Acronis Restore. I did a backup as soon as I activated and installed all my updates and drivers.

Thanks so much!

Share this post


Link to post
Share on other sites

Yeah, I tried that last night but it got to 1% the rebooted and said there was a problem. I clicked 'find a fix' and it chugged along for an hour then did nothing. I am going to do an Acronis Restore. I did a backup as soon as I activated and installed all my updates and drivers.

Thanks so much!

Sorry it didn't work for you. I am sure you could of started with a new user account and everything would of been OK. The issue is that so many programs anticipate UAC that they no longer work without it. The other problem is that you usually need to turn UAC off before you install a lot of stuff on the system.

Share this post


Link to post
Share on other sites

Group Policy->Windows Settings->Security Settings->Local Policies->Security options->User Account Control: Run all administrators in admin approval mode<-Disabled

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.