Sign in to follow this  
Followers 0
cork1958

[Debian] -Longhaul is borken in this configuration

22 posts in this topic

Did some searching around and found the site below which explains a bug and the work around for the message Long Haul is broken in this configuration. Don't even have a clue as to what long haul is, but I do see that message when booting up Wheezy on this junk Everex Impact I have here!

http://womble.decadent.org.uk/blog/warning-debian-70-wheezy-on-via-c3-and-cyrix-iii-systems.html

http://planet-search.debian.org/cgi-bin/search.cgi?terms=Ben+Hutchings

if you do not currently use the 'longhaul' module, you should blacklist it by creating e.g. /etc/modprobe.d/blacklist-longhaul.conf containing the line:

blacklist longhaul

OK. I admit I'm totally illiterate at what exactly that means and how do it!

HELP, please!!

Thank you

Share this post


Link to post
Share on other sites

What in the blue hell is longhaul? Anyways, according to the first link it only applies if you have these chipsets: Via C3 and Cyrix III.

Share this post


Link to post
Share on other sites

Good question as to what it is and I am working on a Via C3!!

Actually,

It's a C7, I do believe?

Share this post


Link to post
Share on other sites
What in the blue hell is longhaul? Anyways, according to the first link it only applies if you have these chipsets: Via C3 and Cyrix III.

Right -- if I recall, Longhaul is a CPU throttling/powersaving setup designed by VIA for a few of the Cyrix/C3 processors.. not sure on C7 but probably.

Share this post


Link to post
Share on other sites

I have never seen that message, but I have also never used the hardware mentioned in that post. If you really need to blacklist that module on your machine (which is ONLY on VIA C3 and Cyrix III systems) do the following:


sudo -s
touch /etc/modprobe.d/blacklist-longhaul.conf
echo "blacklist longhaul" >> /etc/modprobe.d/blacklist-longhaul.conf
reboot
[/CODE]

On a side note, you should consider Ben Hutchings an expert on the Debian kernel. He is one of the principal members of the Debian Kernel Team.

Share this post


Link to post
Share on other sites

Any insight as what long haul is before I do anything? I'm still searching around and not finding very much useful stuff, at least to me!

I definitely didn't like what that one link says about it possibly damaging the hardware! Even if it is junk!!

Everything seems to be working all right though.

Thanks

Edit:

Just found this, http://lists.alioth....May/018970.html and is says disable long haul by default.

Author: benh

Date: Thu May 9 01:25:13 2013

New Revision: 20063

Log:

[i386] cpufreq / Longhaul: Disable driver by default (Closes: #707047)

Added:

dists/wheezy/linux/debian/patches/features/all/cpu-devices/cpufreq-Longhaul-Disable-driver-by-default.patch

Modified:

dists/wheezy/linux/debian/changelog

dists/wheezy/linux/debian/patches/series

Modified: dists/wheezy/linux/debian/changelog

==============================================================================

--- dists/wheezy/linux/debian/changelog Thu May 9 00:41:03 2013 (r20062)

+++ dists/wheezy/linux/debian/changelog Thu May 9 01:25:13 2013 (r20063)

@@ -98,6 +98,7 @@

(Closes: #705655)

* bug script: Remove broken sound functions (Closes: #705619)

* [i386/486] udeb: Add lxfb to fb-modules (Closes: #705780)

+ * [i386] cpufreq / Longhaul: Disable driver by default (Closes: #707047)

-- Ben Hutchings <ben at decadent.org.uk> Wed, 27 Mar 2013 14:10:40 +0000

How do I check if it's disabled?

Share this post


Link to post
Share on other sites

Any insight as what long haul is before I do anything? I'm still searching around and not finding very much useful stuff, at least to me!

I definitely didn't like what that one link says about it possibly damaging the hardware! Even if it is junk!!

Everything seems to be working all right though.

Thanks

Although I have heard of Longhaul before today, Max Norris says that it provides CPU throttling and power management for VIA processors, and Wikipedia seems to back him up.

Share this post


Link to post
Share on other sites

Coincidentally,

I just opened synaptics and checked for updates. Although Wheezy has been on this machine for a few days, it just got an update for the Via display driver.

OpenChrome is a project for the development of free and open-source drivers

for the VIA UniChrome video chipsets.

Originally called the 'snapshot' release, since it was a snapshot of an

experimental branch of the unichrome cvs code, this is a continued development

of the open source unichrome driver (from http://unichrome.sf.net) which

also incorporates support for the unichrome-pro chipsets.

Support for hardware acceleration (XvMC) for all chipsets has subsequently

been ripped out of the unichrome.sf.net driver. Therefore your only option if

you wish to make use of the acceleration features of your VIA chip with free

and open-source drivers is to use this version of the driver.

That Wiki says C7 also.

Do I dare use that driver?

Share this post


Link to post
Share on other sites

Coincidentally,

I just opened synaptics and checked for updates. Although Wheezy has been on this machine for a few days, it just got an update for the Via display driver.

OpenChrome is a project for the development of free and open-source drivers

for the VIA UniChrome video chipsets.

Originally called the 'snapshot' release, since it was a snapshot of an

experimental branch of the unichrome cvs code, this is a continued development

of the open source unichrome driver (from http://unichrome.sf.net) which

also incorporates support for the unichrome-pro chipsets.

Support for hardware acceleration (XvMC) for all chipsets has subsequently

been ripped out of the unichrome.sf.net driver. Therefore your only option if

you wish to make use of the acceleration features of your VIA chip with free

and open-source drivers is to use this version of the driver.

That Wiki says C7 also.

Do I dare use that?

It seems worthwhile to try it. It is exceedingly rare for drivers to permanently damage hardware or firmware (such action is usually the result of a hardware or firmware bug anyway), so the worst that will happen is you will irreparably break your installation and have to reinstall. The driver seems to be in the Debian repository, so proceed at your own risk.

Share this post


Link to post
Share on other sites

Thanks for that vote of confidence there! :laugh:

Unfortuantely,

I've had my share of video drivers screwing up my Linux installs in the past and why I'm leary of this!

Does that info I posted above in post #6 mean that Long Haul is disabled by default on this setup?

Share this post


Link to post
Share on other sites

Maybe, assuming that is still the current configuration. You can find out if it is loaded on your system, though.


modprobe | grep longhaul
[/CODE]

Share this post


Link to post
Share on other sites

This is what I get when running that command regularly and using sudo:

cork@debian:~/Desktop$ modprobe | grep longhaul

bash: modprobe: command not found

cork@debian:~/Desktop$ sudo modprobe | grep longhaul

[sudo] password for cork:

Error: missing parameters. See -h.

cork@debian:~/Desktop$

cork@debian:~/Desktop$ sudo modprobe | grep longhaul -h

Error: missing parameters. See -h.

Assuming that it's either disabled or simply not installed/running?

Share this post


Link to post
Share on other sites

Well, here goes that update along with all the others that just came through today!

If I'm not back in a few, you know I'm reinstalling something, maybe!!

Thanks

Edit:

Well, I'm back and didn't have to reinstall anything!! May try that

sudo -s

touch /etc/modprobe.d/blacklist-longhaul.conf

echo "blacklist longhaul" >> /etc/modprobe.d/blacklist-longhaul.conf

reboot

later tonight or tomorrow.

Thanks again!!

Share this post


Link to post
Share on other sites

This is what I get when running that command regularly and using sudo:

cork@debian:~/Desktop$ modprobe | grep longhaul

bash: modprobe: command not found

cork@debian:~/Desktop$ sudo modprobe | grep longhaul

[sudo] password for cork:

Error: missing parameters. See -h.

cork@debian:~/Desktop$

cork@debian:~/Desktop$ sudo modprobe | grep longhaul -h

Error: missing parameters. See -h.

Assuming that it's either disabled or simply not installed/running?

Oops. That was my fault. I fat fingered the command. The actual command should have been:


lsmod | grep longhaul
[/CODE]

The module definitely won't be loaded now because you blacklisted it, meaning that you will not get any output from the command I just posted.

Share this post


Link to post
Share on other sites

If youre not sure what it is, you likely don't need it.

Share this post


Link to post
Share on other sites

If youre not sure what it is, you likely don't need it.

That is not true in the least. When it comes to system components, if you don't know EXACTLY what it is you should NOT remove it! Removing system components you don't understand is never a good idea. Your statement holds true only for desktop applications, in most cases.

Share this post


Link to post
Share on other sites

That is not true in the least. When it comes to system components, if you don't know EXACTLY what it is you should NOT remove it! Removing system components you don't understand is never a good idea. Your statement holds true only for desktop applications, in most cases.

I never said to remove anything.

Share this post


Link to post
Share on other sites
Oops. That was my fault. I fat fingered the command. The actual command should have been:
 lsmod | grep longhaul [/CODE]

The module definitely won't be loaded now because you blacklisted it, meaning that you will not get any output from the command I just posted.

I haven't blacklisted long haul yet, as I mentioned in a couple posts back. Some what afraid to seeing as how that junk machine is running as good as it is.

You just nailed the EXACT reason I half despise the command line though. Even with my skinny fingers and the fact I DO know how to type, it's simply to easy to screw stuff up using it! Almost nothing worse than an "Oops" when using the command line!

I still have a link to this thread in my e-mail, so maybe will check into this long haul issue after the holiday. About to get out of here and go camping for the weekend! :)

Thanks

Share this post


Link to post
Share on other sites

FWIW,

Yes, I'm still checking into this!

When I run that command

lsmod | grep longhaul

I get absolutley nothing using sudo or not. I don't see where I replied to that last time you replied after you fat fingered the command. ;)

Share this post


Link to post
Share on other sites

FWIW,

Yes, I'm still checking into this!

When I run that command

lsmod | grep longhaul

I get absolutley nothing using sudo or not. I don't see where I replied to that last time you replied after you fat fingered the command. ;)

If you get nothing after running that command it means the longhaul module is not loaded. If you have not blacklisted it yet, there is no need to.

Share this post


Link to post
Share on other sites

Right on! :)

EXACTLY what I was thinking and gathering from the multi-million searches I've done since starting this topic.

Issue solved

Thanks again

Share this post


Link to post
Share on other sites

Sheesh!!

Just noticed how I had "broken" spelled it topic title!! :rofl: :wacko:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.