Jump to content



Photo

Battlefield 3: What's going on...?


  • Please log in to reply
9 replies to this topic

#1 Synthetic

Synthetic

    The one The only

  • Joined: 26-March 02
  • Location: Iowa City, IA
  • OS: Windows 8.1 Pro
  • Phone: iPhone 5s

Posted 20 June 2013 - 23:04

Has anybody ever seen this before? It only happens here and there but it's really annoying when it does. It's the only game on my system that shows any sings of a problem so I don't really feel like it's hardware related. Exiting and firing the game back up fixes it and like I said it's very random.What The Shit Land.jpg Looks almost normal when I'm in the waterWhat The Shit Water.jpg




#2 TheExperiment

TheExperiment

    Reality Bomb

  • Tech Issues Solved: 1
  • Joined: 11-October 03
  • Location: Everywhere
  • OS: 8.1 x64

Posted 20 June 2013 - 23:06

I assume you've checked your drivers...you might bump your system cooling or check for dust in the machine, or both.



#3 Slammers

Slammers

    Neowinian

  • Joined: 30-April 08

Posted 20 June 2013 - 23:08

I was having the exact same problem for about 2 weeks a couple of months back. It was always after an hour or two playing so I presumed it was just artifacts from overheating. Stopping the game for 10mins always fixed it. It randomely stopped happening though. I suppose make sure your drivers are up to date and check your temps. Are you running recording software while you play? 



#4 TheExperiment

TheExperiment

    Reality Bomb

  • Tech Issues Solved: 1
  • Joined: 11-October 03
  • Location: Everywhere
  • OS: 8.1 x64

Posted 20 June 2013 - 23:10

My friend claims the latest NV drivers are causing issues - http://modcrash.com/...s/#.UcOLgPnrzK5



#5 Andrew G.

Andrew G.

    Once More 'Round the Sun

  • Tech Issues Solved: 9
  • Joined: 14-September 03

Posted 20 June 2013 - 23:10

I've heard the latest Nvidia drivers are causing issues like this. Roll back to an old version.



#6 OP Synthetic

Synthetic

    The one The only

  • Joined: 26-March 02
  • Location: Iowa City, IA
  • OS: Windows 8.1 Pro
  • Phone: iPhone 5s

Posted 24 June 2013 - 01:24

Sorry I haven't responded sooner! Thanks for the advice guys!



#7 Silpheed2K

Silpheed2K

    Neowinian

  • Joined: 30-September 05

Posted 24 June 2013 - 07:45

I'm having the same issue but I think it may be overheating and dust. I'm going to take my video card apart and clean the vents. My computer has been traveling to lots of places that kick up a lot of dust.

There's video tutorials on YouTube if you're interested just look something like 'clean/fix overheating video card'

#8 Jeroen S.

Jeroen S.

    Neowinian Vigilante

  • Tech Issues Solved: 1
  • Joined: 22-October 05
  • Location: The Netherlands
  • OS: Windows 8.1
  • Phone: iPhone 5

Posted 24 June 2013 - 07:49

Me and one of my brothers are having this same issue as well. With the drivers that were released before the latest nVidia driver and with the latest one. I've never had this issue with driver version 295.73 though but the game runs much more smoother with the latest drivers. I do believe it's something to do with the drivers though because I'm not experiencing this issue in any other game, not even in Crysis 3.

#9 Silpheed2K

Silpheed2K

    Neowinian

  • Joined: 30-September 05

Posted 28 June 2013 - 11:17

Cleaned my Video card and still had issues. Looks like I gotta take it apart and replace my video cards thermal paste. I feel that should fix this issue I'm having. Mine is clearly an overheating issue and yours looks like the same to me.

#10 duddit2

duddit2

    Neowinian Senior

  • Tech Issues Solved: 1
  • Joined: 24-January 10
  • Location: Manchester UK
  • OS: Windows 8 Pro

Posted 28 June 2013 - 11:28

Yeah first thing I'd think of is overheating with this kind of corruption, seen it a while ago on an overclocked card of mine a day before it melted :(