Sign in to follow this  
Followers 0

54 posts in this topic

Posted

So after being a long time apple user and long time iTunes hater :p... I managed to sell my iphone 4 and bought a samsung galaxy S4, did the same for my other half...

 

Keep in mind, this is a brand new, no-root, default phone.

 

The issue basically is notifications, for whatsapp ( at the moment since I haven't set up anything else that requires push, besides gmail).  The issue is once I turned the screen off, either manually or by itself. whatsapp notifications randomly stop arriving until I turned on the screen, completely close the app and open it again, the same goes for 2 other devices ( 3 in total).

 

Device #1. new s4, 

Device #2 new s4

Device #3 Samsung galaxy young running 4.1.2 JB.

 

 

Now, device #3 belongs to a friend of mine who told of these issues a couple of months ago, however I did pay attention as I just figured it was network connection or wifi or whatever be it.

 

I've googled the hell out of this and it is apparently an android issue:

 

 

 

The problem is this: 

http://code.google.com/p/android/issues/detail?id=42272

It has been known for a while, a problem with ARP packages

 

Other links Ive found googling:

 

http://www.whatsapp.com/faq/en/android/20887936

 

http://forum.xda-developers.com/showthread.php?p=32965641

 

and several other phones as well:

 

tp://forum.xda-developers.com/showthread.php?t=1579094 - Galaxy Nexus
http://forums.androidcentral.com/google-nexus-4/230767-gmail-push-notifications-significantly-delayed.html - Nexus 4
http://androidforums.com/samsung-galaxy-s3/642422-galaxy-s3-late-notifications.html - HTC Evo 
http://forums.androidcentral.com/motorola-droid-x/55101-push-data-notification-delay.html - Motorola Droid X
http://androidforums.com/samsung-epic-4g-touch/523520-notification-delay.html - Galaxy S2
http://androidforums.com/samsung-galaxy-s3/642422-galaxy-s3-late-notifications.html - Samsung Galaxy S3
http://androidforums.com/sprint-hero-support-troubleshooting/11381-gmail-email-notification-delay.html - HTC Hero
http://www.droidforums.net/forum/motorola-droid/2722-delayed-notifications.html - Motorola Droid

 

 

 

it's not telco related in my case, because i had NO ISSUES on my iphone 4 nor my best half's  4s. 

 

 

Anyway, hopefully someone here has been through something similar and been able to fix it?

Share this post


Link to post
Share on other sites

Posted

healthy bump or morel like desperate bump

Share this post


Link to post
Share on other sites

Posted

I believe there is a way for Wi-fi to not be idle when screen turns off, I dont know if there is a setting for this for 3G though.

Share this post


Link to post
Share on other sites

Posted

Yep, as Shahrad has said, Android by default will disconnect from WiFi to conserve power, so that's probably what's happening. Check your (advanced) wireless settings to make sure wireless isn't going into sleep mode - you can keep WiFi continually 'on' so it receives notifications.

Share this post


Link to post
Share on other sites

Posted

I've been noticing a similar situation happening with my Galaxy Nexus. Reading your post prompted me to investigate, and I think I may have found a solution to my own, and possibly your problem.

I've just un-ticked the circled option in the Advanced Wi-Fi Settings. If you have this option, then give it a try. I'll see how this setting change goes for me.

dB7jgXx.png

Share this post


Link to post
Share on other sites

Posted

It may be a WhatsApp issue too... I have a BBZ10 and a couple of my friends have WP, and it's happened to both of us at times too. At the moment mine is fine, a few updates later, but for a while it would only pick up new notifications if I went into the app. Same for the WP people at other times in the "update cycle" as it were.

 

You may be able to tweak your device settings to fix it, not saying it's definitely the case, but keep it mind it may be the app itself too (or if it isn't now it might be later).

Share this post


Link to post
Share on other sites

Posted

congrats on the S4, im still on my S2 and still loving the experience. As others have said check under advanced wifi settings. One thing tho, I have noticed lately lag on gtalk messages coming through, no sure if this is the same issue, but anyways...  :s Maybe these issues are fixed with 4.3 update, who knows :D

Share this post


Link to post
Share on other sites

Posted

I believe there is a way for Wi-fi to not be idle when screen turns off, I dont know if there is a setting for this for 3G though.

I have wifi when screen is on "always"

I believe there is a way for Wi-fi to not be idle when screen turns off, I dont know if there is a setting for this for 3G though.

yup, same as above, I have wifi set to "always on"

 

Yep, as Shahrad has said, Android by default will disconnect from WiFi to conserve power, so that's probably what's happening. Check your (advanced) wireless settings to make sure wireless isn't going into sleep mode - you can keep WiFi continually 'on' so it receives notifications.

Again, same as above.

 

I've been noticing a similar situation happening with my Galaxy Nexus. Reading your post prompted me to investigate, and I think I may have found a solution to my own, and possibly your problem.

I've just un-ticked the circled option in the Advanced Wi-Fi Settings. If you have this option, then give it a try. I'll see how this setting change goes for me.

dB7jgXx.png

 

Don't have that  option on 4.2.2

It may be a WhatsApp issue too... I have a BBZ10 and a couple of my friends have WP, and it's happened to both of us at times too. At the moment mine is fine, a few updates later, but for a while it would only pick up new notifications if I went into the app. Same for the WP people at other times in the "update cycle" as it were.

 

You may be able to tweak your device settings to fix it, not saying it's definitely the case, but keep it mind it may be the app itself too (or if it isn't now it might be later).

The weird thing is, it didn't happen on my iPhone 4 and my GFs 4s, So i'm guessing the issue would be whatsapp on android, however if you check my OP, I even did their recommend solutions for the issue.

 

congrats on the S4, im still on my S2 and still loving the experience. As others have said check under advanced wifi settings. One thing tho, I have noticed lately lag on gtalk messages coming through, no sure if this is the same issue, but anyways...  :s Maybe these issues are fixed with 4.3 update, who knows :D

Why has google let this go to 4.2.2 for such a simple thing, yet basic in modern phones/apps... is really, mind boggling.

 

I used to be an iPhone user, however apples lockdown and iTunes drove me nuts ( Jailbreaking sorta eased it and there was media monkey for alternative...).

 

 

I think I forgot to clarify, this happens both with WIFI and 3G/edge connection.

Things i've tried:

1. Select GSM mode only (WCDMA disabled).

2. Always on Wifi (when screen is off).

3. update samsung push services ( pretty useless as it for samsung services only, but you never know...).

 

 

As I said in my OP several friends as well running different android devices have the same issue (galaxy Young, S2), So either our Telco ###### up with android or whatsapp for android has issues. From my googling in my OP, it would appear to be an android issue :/

Share this post


Link to post
Share on other sites

Posted

I did read the OP :) and am not sure if the issue I am describing is the same. No doubt it's an issue with either the version of Android you have, or the version of WA that is out on Android at the moment. Just giving you the heads up. WA is, in general, not the most stable app ever >.<

Share this post


Link to post
Share on other sites

Posted

I did read the OP :) and am not sure if the issue I am describing is the same. No doubt it's an issue with either the version of Android you have, or the version of WA that is out on Android at the moment. Just giving you the heads up. WA is, in general, not the most stable app ever >.<

Agreed it was extremely nasty in the first versions for iOS, push didn't even work properly.

 

 

Could you perhaps detail exactly what your issues are?

Share this post


Link to post
Share on other sites

Posted

Don't have that  option on 4.2.2

My Galaxy Nexus is running 4.2.2 too, although I guess Samsung maybe left that option out of TouchWiz?

As it's happening on mobile data too, then perhaps this option may not help anyway.

Share this post


Link to post
Share on other sites

Posted

I don't know about WhatsApp but Hangouts pushes just fine on 3G and WIFI. My gf uses WhatsApp in Germany and I've never heard her complain about that. It's the default over there because you get like 200 SMS per month! :o

 

I use Hangsouts with her of-course and we have no issues with that.

Share this post


Link to post
Share on other sites

Posted

My Galaxy Nexus is running 4.2.2 too, although I guess Samsung maybe left that option out of TouchWiz?

As it's happening on mobile data too, then perhaps this option may not help anyway.

Guess so, dumb ass samsung.

Yeah it happens both with wifi or mobile data :/

 

I don't know about WhatsApp but Hangouts pushes just fine on 3G and WIFI. My gf uses WhatsApp in Germany and I've never heard her complain about that. It's the default over there because you get like 200 SMS per month! :o

 

I use Hangsouts with her of-course and we have no issues with that.

Yeah I get 200 sms per month... unlimited SMS costs $5 + tax.

 

Well gmail notifications seem to work well, the problem apparently is only with whatsapp.

 

Apparently it's a widespread issue with android:

 

https://www.google.hn/search?q=whatsapp+delayed+in+galaxy&oq=whatsapp+delayed+in+galaxy&aqs=chrome.0.57.5097j0&sourceid=chrome&ie=UTF-8

Share this post


Link to post
Share on other sites

Posted

You did notice that the bug says it happens when the wifi IS set to always on, not the other way around, right? So setting "Keep wifi on during sleep" to Always is how you help reproduce this defect, not avoid it. I would start by turning that off, though that shouldn't be on by default on Android anyway I don't believe. I've never seen this issue personally, but I've also never used WhatsApp, so I can't provide more insight on that.

Share this post


Link to post
Share on other sites

Posted

You did notice that the bug says it happens when the wifi IS set to always on, not the other way around, right? So setting "Keep wifi on during sleep" to Always is how you help reproduce this defect, not avoid it. I would start by turning that off, though that shouldn't be on by default on Android anyway I don't believe. I've never seen this issue personally, but I've also never used WhatsApp, so I can't provide more insight on that.

Nope, it happens both with Wifi or mobile data.

 

http://forum.xda-developers.com/sitesearch.php?q=whatsapp%20delay

 

A very widespread issue...

Seriously how this is a bug in 4.2.2 is beyond me... :/

Share this post


Link to post
Share on other sites

Posted

Im just about giving up, at least on whatsapp anyway... this is my last go on it...

 

http://forum.xda-developers.com/showthread.php?t=2356042

 

(Though using their search as posted in my above replies,  it is apparently a widespread issue).

Share this post


Link to post
Share on other sites

Posted

No this is NOT a bug that affects all of Android 4.2.2. Whatsapp has worked perfectly on my Galaxy Nexus with 4G and WiFi connections. We are actually field testing it at work to see how it works for broadcasting messages. Since this is a rather common issue, I will let the other team know.

Share this post


Link to post
Share on other sites

Posted

Nope, it happens both with Wifi or mobile data.

 

http://forum.xda-developers.com/sitesearch.php?q=whatsapp%20delay

 

A very widespread issue...

Seriously how this is a bug in 4.2.2 is beyond me... :/

Right, my point being, Issue 42272 you linked to is a defect about ARP requests when wifi is set to always on and the device is asleep, so this isn't related to your issue.

 

Also, I see you have a number of links to similar notification issues, but I've never heard anyone have these issues on any phone with any version. The issue with notifications is that people may not necessarily know how they have them set up properly. Do they have them set for push? Do they have them set to sync on a timer? I've never seen any issues with anything set to push. It sounds to me like you're looking at more of an issue with Whatsapp than Android. Can you verify your sync and notification settings for that app? I've never used it so I can't help there as much.

 

Have you checked out the steps listed here: http://www.whatsapp.com/faq/android/20887936 including making sure background data is on, no power savers are turning off sync while sleep, and no task killers are installed killing the background task? Edit: Nevermind, you did say you saw that, and I assume you checked everything it mentioned.

Share this post


Link to post
Share on other sites

Posted

Right, my point being, Issue 42272 you linked to is a defect about ARP requests when wifi is set to always on and the device is asleep, so this isn't related to your issue.

 

Also, I see you have a number of links to similar notification issues, but I've never heard anyone have these issues on any phone with any version. The issue with notifications is that people may not necessarily know how they have them set up properly. Do they have them set for push? Do they have them set to sync on a timer? I've never seen any issues with anything set to push. It sounds to me like you're looking at more of an issue with Whatsapp than Android. Can you verify your sync and notification settings for that app? I've never used it so I can't help there as much.

To be honest i'm new on android, alls I did was install whastapp, like I did on iOS.  I haven't found specific app push settings like there are on iOS on the galaxy s4.

Share this post


Link to post
Share on other sites

Posted

To be honest i'm new on android, alls I did was install whastapp, like I did on iOS.  I haven't found specific app push settings like there are on iOS on the galaxy s4.

Okay, let me install it and see if I see anything interesting.

Share this post


Link to post
Share on other sites

Posted

Okay, let me install it and see if I see anything interesting.

Cool! Thanks a lot for the help!

 

Also, on the 42272 it's just a link I found with a somewhat related issue...

Share this post


Link to post
Share on other sites

Posted

Hmm.... I don't see any specific sync settings for for Whatsapp really. The only entry in the sync menu is for contacts. I'm not really sure what to tell you, but I haven't seen this issue with other apps personally. I'd go through your settings and make sure background data is turned on and everything on your phone. That could vary a little from phone to phone, but a good first place to start would be the top of the settings page with all the communications settings.

Share this post


Link to post
Share on other sites

Posted

Hmm.... I don't see any specific sync settings for for Whatsapp really. The only entry in the sync menu is for contacts. I'm not really sure what to tell you, but I haven't seen this issue with other apps personally. I'd go through your settings and make sure background data is turned on and everything on your phone. That could vary a little from phone to phone, but a good first place to start would be the top of the settings page with all the communications settings.

yeah I fiddled around looking for any other setting I might have missed.

 

I wrote to whatsapp support as last resort, got an automated response, i'll update see how it goes:

 

 

 

Snip my full name :p

Jul 08 13:28 (PDT)

Hi,

I just recently switched to a samsung galaxy s4 ( two actually, one for me,

one for GF), before that we used iphone 4 and 4s, never had an issue with

whatsapp notifications until I switched this passed friday. The issue is

once the phone goes into sleep mode, be it mobile data or wifi, I have to

force close the app and open again to receive notifications that I got

hours ago if I don't continously check.

I've googled the hell out of it and found your FAQ, as well as plenty other

sites with the same issue except no solution.

From your FAQ:

1. tried re-installing directly from direct download link (

http://www.whatsapp.com/android/current/WhatsApp.apk) and not from play

store

2. tried rebooting.

3. notifications are set properly

4. google+ is disabled ( hangouts) ( tried enabling it, same result)

5. Wifi is set to always on.

Note this is on stock, brand new phones and apparently it's a wide spread

issue:

http://forum.xda-developers.com/showthread.php?t=2356052

http://forum.xda-developers.com/showthread.php?t=2351753

http://www.neowin.net/forum/topic/1163306-android-notifications-woes-with-whatsapp/

 

Anyway, emailing you guys, because I've basically given up google searching

and asking in forums.

 

Their automated response was:

 

 

Hi,

Thanks for contacting WhatsApp. We are working on answering everyone's question as soon as possible. In the meantime, please look at our FAQ to see if your question is answered there.

FAQ page: http://www.whatsapp.com/faq/

Below are the answers to some commonly asked questions:

1. What are WhatsApp's subscription fees?

http://www.whatsapp.com/faq/en/general/23014681

2. Why can't I connect to WhatsApp?

http://www.whatsapp.com/faq/en/general/21092998

3. Can I recover deleted messages?

http://www.whatsapp.com/faq/en/general/21197296

If you submitted a suggestion, thank you very much for sharing your feedback. Please note that we cannot comment specifically about plans and developments, but we value your feedback and have taken note of your suggestion.

To add any updates to your request, please respond to this email. We are here to help!

Thanks!

WhatsApp Support Team

Interested in translating for us? Please visit http://translate.whatsapp.com

Take a look at our FAQ: http://www.whatsapp.com/faq/

Share this post


Link to post
Share on other sites

Posted

Snip

Serves you right for getting rid of your iDevices and getting android. May you burn in hell :p

TO anyone else reading this, please note, this is an internal joke between me and my friend and not anything else.

Share this post


Link to post
Share on other sites

Posted

 

 

wait, you work for whatsapp? no wonder! :laugh:

 

(I hope that people get that was a joke :shifty: )

 

 

Seriously though, man I gave up on apple and tags, you've no idea the time I've spent properly tagging my music just so iTunes decides whether it wanted to carry the tags over or not :angry: Then there's device openness, I like been able to drag an drop, connecting anywhere... etc. Hey... I held up with iphone 3Gs, 4, 4s, until another brand managed to catch up in music quality!

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.