Jump to content



Photo

Could "Windows\twain_32" folder name-cause printer scan proble

vista

  • Please log in to reply
No replies to this topic

#1 Cheryl_27

Cheryl_27

    Neowinian

  • Joined: 09-January 07

Posted 09 July 2013 - 22:02

Using Vista x64. I had problems scanning w/ new HP O.J. Pro 8600 after installing (on HP machine). Everything pointed to "error establishing communication," or "cannot find device." A pretty common problem that most DON'T fix easily. There was no problem w/ printer / router / computer network connection. Everybody recognized everybody & had strong signal (when wireless). The scanning software may not have FOUND the correct drivers for scanning, drivers missing / corrupted.

 

Can some users check THEIR Vista (or other Windows) folders & the folder name & path of the waitwain.ds file as well as the printer's own files in that folder, if any?

 

Reading articles on fixes, came across scanning drivers & the Vista - C:\Windows\Twain\waitwain.ds file being mentioned. As well as hardware's (HP printer) own drivers it may place there. I've now uninstalled the HP software / drivers & preparing to reinstall.

 

One issue I see is there are 2 SIMILAR folders - where the name difference may be causing issues?

One is named \Windows\Twain32\ - that folder is EMPTY. Many refer to "Twain" as the correct folder name where wiatwain.ds is (it's not, on my system).  Others mention twain_32.

 

Another folder just below, is \Windows\twain_32 - with an underscore. Wiatwain.ds is located here, plus a couple of fairly old hp files (w/ no extension). Also appears to be 2 HP? subfolders, created by some HP printer, at some point: C:\Windows\twain_32\hpsj_0000 & another ...\hpsj_0001. Both folders have one file (now) - "hpjs_0000.ds & hpjs_0001.ds.

 

No idea which "twain" folder name is correct & if that's causing problems.

The "Twain32" folder (empty) was created right around the time I ordered / bought this HP computer.

 

The "twain_32" (w/ underscore) folder "created on" date = Waitwain.ds file's creation date - 11/2/2006 - BOTH much older than this computer.  Not sure how that's possible.

 

NOTE: What ever caused the HP scanning problem, if it was a Windows issue, it didn't bother an Epson All In One printer's scanning function. The Epson may have used completely different files / method for scanning, but had no issues.

Thanks.