Sign in to follow this  
Followers 0
LouisMoore16

MKI9200 - Vauxhall Astra H 2005

2 posts in this topic

I've bought the Parrot MKI9200 with the PC000043AA too.

I've connected the ISO cable to my CD30 radio/CD player and the radio/CD player is working fine. I connected all the cables to the ISO adaptor and the blue box, however when I plug the small screen into the blue box the screen won't turn on. I turn the engine on and it still don't work.

I tried seeing if when I connect the iPhone connector to my phone it would charge it up which it won't. I've tried swapping the orange and the red cables around and still no work.

The power is going through the ISO cable as it powering the head unit, but for some reason it doesn't seem that the power is going to the blue box

Any suggestion?

http://dbinstall.parrot.com/pdf.php?adapter=PC000043AA&ck=MKI9200〈=GB

Share this post


Link to post
Share on other sites

Have you checked whether the switched live is in the right place? When I installed a stereo in my parent's Astra I had to take a switched live from the cigarette lighter if I remember correctly.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.