Jump to content



Photo

Realtek NIC not working after resume from sleep

windows 8.1

  • Please log in to reply
10 replies to this topic

#1 awergh

awergh

    Neowinian

  • Joined: 07-March 12

Posted 22 July 2013 - 14:01

It was a fresh install of 8.1 preview and not an upgrade. It seems that whenever I resume from sleep the Realtek Gigabit PCIe onboard NIC wont work at all.

Ping will just give me a general failure. The only fix is to uninstall the NIC and let windows redetect it and it will work again.

 

This also even happens if I disable the NIC and renable it in network connections. Different drivers seem to make no difference whether the Realtek or MS driver so dunno what I can do to fix that.

Motherboard is GA-Z68X-UD3R-B3 but I can't see any reason why I have the problem on this board but not on an older board with a similar realtek nic. I mean I can live with the problem but it is a little bit annoying to have to reinstall the NIC every day.




#2 RottGutt

RottGutt

    I'm a geek. Deal with it.

  • Joined: 21-November 01
  • Location: Colorado
  • OS: OS X 10.9.3/10.10, iOS 7, DSM 5.0

Posted 24 July 2013 - 14:31

Try going into Device Manager and open the NIC's settings window. Go to the Power tab and un-check "allow computer to turn off this device" and/or "allow computer to put this device to sleep", then reboot. I usually do this to all my machines.

#3 RottGutt

RottGutt

    I'm a geek. Deal with it.

  • Joined: 21-November 01
  • Location: Colorado
  • OS: OS X 10.9.3/10.10, iOS 7, DSM 5.0

Posted 24 July 2013 - 16:06

2cs9y6o.jpg



#4 OP awergh

awergh

    Neowinian

  • Joined: 07-March 12

Posted 25 July 2013 - 06:37

Pretty sure I tried that at some point but I didn't restart after doing that so I guess I'll see how I go later.



#5 ZeroSeven

ZeroSeven

    NeoDevil

  • Joined: 23-July 02

Posted 07 August 2013 - 09:12

Experiencing exactly the same issue here with my built in Realtek NIC, on a Gigabyte G31-S2L. Im going to try the above suggestion and see if it helps.



#6 OP awergh

awergh

    Neowinian

  • Joined: 07-March 12

Posted 07 August 2013 - 09:47

Well I'm glad I'm not the only one. Having tried more stuff I discovered that when I put in a PCI Intel Pro 100 NIC it exhibited the same symptoms as the Realtek NIC.

 

Also do you get the same problem when you disable and renable the NIC or just when resuming from sleep?



#7 ZeroSeven

ZeroSeven

    NeoDevil

  • Joined: 23-July 02

Posted 09 August 2013 - 11:16

Ok turning off power management for the NIC in device manager had no effect, problem still exists. And no amount of disabling/enabling the NIC fixes it either, its just dead when resuming from sleep, a restart is required. Could this be related to VirtualBox? Anyone else have that installed? It may be worth trying to uninstall it and trying again, perhaps theres something in the VirtualBox NIC drivers causing an issue.



#8 +Zlip792

Zlip792

    Neowinian Senior

  • Tech Issues Solved: 11
  • Joined: 31-October 10
  • Location: Pakistan
  • OS: Windows 8.1 Pro 64-bit
  • Phone: Nokia C3-00 (8.70 firmware) It sucks!!!

Posted 09 August 2013 - 11:39

Latest NIC driver released on August 1st, so try them..



#9 bjorndori

bjorndori

    Neowinian

  • Joined: 27-March 13

Posted 09 August 2013 - 11:43

Open the configuration window as you did before, select the advanced tab. Disable the "Energy efficient ethernet" and "Green Ethernet".

 

This worked for me when my NIC was giving me similar problems.



#10 articuno1au

articuno1au

    Neowinian Senior

  • Tech Issues Solved: 2
  • Joined: 20-March 11
  • Location: Brisbane, Australia

Posted 09 August 2013 - 11:45

If that doesn't work, hit the Realtek site and download the driver directly.

 

Should help, but might be a bit of a crap shoot >.<



#11 +Zlip792

Zlip792

    Neowinian Senior

  • Tech Issues Solved: 11
  • Joined: 31-October 10
  • Location: Pakistan
  • OS: Windows 8.1 Pro 64-bit
  • Phone: Nokia C3-00 (8.70 firmware) It sucks!!!

Posted 11 August 2013 - 09:53

From here download: http://www.realtek.c...3&GetDown=false