Jump to content
  • 0
Sign in to follow this  
Followers 0

Network Speeds Issue

Question

Posted

So I upgraded my router from the Linksys WRT54GL to the ASUS RT-AC66U router.

 

Yet, when copying a file from one computer to the next, I am still only getting around 11MB/s..

 

Is there something I need to change or what's going on?

Share this post


Link to post
Share on other sites

109 answers to this question

  • 0

Posted

Are you talking wired or wireless? From wireless client to wireless client? Or from wireless client to wired client? To internet?

Nice that router now supports N or Gig, do your clients? Do you have anything else between your clients wired to your new gig router? That is not gig?

11MB/s would be a very good wired 100Mbit connection.. So your not at some point in your connection. Or what are you making the copy from, a USB disk that is where you limit could be?

Share this post


Link to post
Share on other sites
  • 0

Posted

I am talking about a wired connection. It's coming from the system hard drive of one computer, to my computer.

 

Are you saying the speed depends on the hard drive? So if the file is coming from an old 7200RPM drive, it's maxed out at 11-15MB/s?

 

And anything between, not sure. The house is wired all the way through, my computer is close to the router...but not sure where the cable actually goes in the house, but it should end up to the router.

Share this post


Link to post
Share on other sites
  • 0

Posted

You're either hitting something that is limited to or operating at 100Mbit. If you believe everything should be on gigabit then start checking driver settings as your devices should be on auto negotiate for your router.

Some driver options like Green Ethernet can get stuck on 100Mbit even though "on-demand" they are supposed to re-negotiate to 1000Mbit.

Share this post


Link to post
Share on other sites
  • 0

Posted

So it does not matter what the hard drives are?

 

My router is gigabit, my new computer is gigabit...and my old computer is gigabit.

 
I have checked all settings on drivers, turned off any power saving stuff...still same. Also checked all cables, they are all cat5e.

Share this post


Link to post
Share on other sites
  • 0

Posted

Even if it depends on the drives, 7200RPM should be able to do between 90 and 150MB/s am I wrong?

 

So what the heck is going on?

Share this post


Link to post
Share on other sites
  • 0

Posted

There's a tool somewhere to test the limit of your connection in a "vacuum" of sorts to see if there's any problems. Essentially it tests your speed without writing anything to the destination. I'll dig around to see if I can remember the name but basically you seem to be getting pretty good speeds as it is. You have to remember that a hard drive is going to be the slowest part of a system.

Share this post


Link to post
Share on other sites
  • 0

Posted

Try shutting off the anti-virus on both PC's and copy.  I bet your network speed has little to do with the problem and that you're virus scanning the inbound file.

 

Once I adjusted what was scanning, my transfer file time went from 20 minutes to under 30 seconds.

Share this post


Link to post
Share on other sites
  • 0

Posted

As I said, if it depends on the drives, the drives should be able to do at least 90MB/s......my max 14MB/s (average 11MB/s) is not 90.

 

And the computer getting the file, has no virus program (well it has Windows 8, how do you turn that off)

Share this post


Link to post
Share on other sites
  • 0

Posted

OP - test your drive speeds to make sure everything is good on your end first. See what kind of Read/Write speeds you get. 

 

What is your Jumbo Frame set to?

 

Are you transferring many many small files or large files?

 

Hell my SSD on my MBP Retina is 475/410 R/W and with a Thunderbolt 500GB Portable drive it was only 80MB/S - 110MB/s 

Share this post


Link to post
Share on other sites
  • 0

Posted

Double check to see if the network cards are running at gigabit speeds and not just assuming they are.

Share this post


Link to post
Share on other sites
  • 0

Posted

How would I check? They are stated as 1000, so let me know what else I can check.

 

What is Jumbo Frame?

 

Also, how can I test drive speeds?

Share this post


Link to post
Share on other sites
  • 0

Posted

11MB/s sounds like a 100MB connection. Sure your NIC is actually connected at the 1GB speed? Check your network status, it'll tell you its current link speed. I don't remember the exact numbers, when my network was at 100MB I would average like 12MB/s or so on copies, thereabouts. With this machine I'm on at the moment, on a 1GB network, I'm capped at the drive's speed as it's a mechanical drive, 7200RPM, I get about 55MB/s or so out of it. A couple units here have SSDs, if I recall they're around 100-110 if I remember right.

ihxk.png
Go to the network/sharing control panel, "Change adapter settings", then double click the network adapter in question.

 

I did have one issue quite a while back when my network had a couple of XP machines on it.. XP to/from 7 or Linux was slow for a gigabit network, even though they were configured properly, maybe 20MB/s under what they should be. Once they were bumped to 7 they went full speed. Never did figure that one out, you didn't mention what the other one was running but probably unrelated.

Share this post


Link to post
Share on other sites
  • 0

Posted

As mentioned before confirm that all computers involved are actually at 1 Gbps 

[attachment=340301:speed.jpg]

Next traditionally ASUS stock firmware for thier routers is not the best, most people will flash the router with either Tomato USB or DD-WRT

 

Tomato USB

http://tomato.groov.pl/

 

DD-WRT

http://www.dd-wrt.ca/site/index

 

I have an older ASUS RT-N16 router with tomato USB and I get great speeds doing file transfers between computers. Like you I have cat5e wiring throughout the house and all computers support gigabit speeds. The transfer image is for 3 movie files sent between computers that are about 10 meters apart.  

[attachment=340303:transfer.jpg]

 

Also make sure you have the latest drivers for all Ethernet cards, sometimes and upgraded driver will improve slow transfer speeds (sometimes not).

If you think you might want to use one of the 3rd party router firmwares mentioned above please make sure you read how-to's for both options.

 

Tomato USB

http://tomatousb.org/tut:installing-on-asus-rt-n16

 

DD-WRT

http://www.dd-wrt.ca/wiki/index.php/Installation

 

Anyway, I hope you can get to the bottom of the issue. 

post-328294-0-78999100-1375653608.jpg

Share this post


Link to post
Share on other sites
  • 0

Posted

11MB/s sounds like a 100MB connection. Sure your NIC is actually connected at the 1GB speed? Check your network status, it'll tell you its current link speed. I don't remember the exact numbers, when my network was at 100MB I would average like 12MB/s or so on copies, thereabouts. With this machine I'm on at the moment, on a 1GB network, I'm capped at the drive's speed as it's a mechanical drive, 7200RPM, I get about 55MB/s or so out of it. A couple units here have SSDs, if I recall they're around 100-110 if I remember right.

ihxk.png
Go to the network/sharing control panel, "Change adapter settings", then double click the network adapter in question.

 

I did have one issue quite a while back when my network had a couple of XP machines on it.. XP to/from 7 or Linux was slow for a gigabit network, even though they were configured properly, maybe 20MB/s under what they should be. Once they were bumped to 7 they went full speed. Never did figure that one out, you didn't mention what the other one was running but probably unrelated.

Ok from that menu, it shows 100Mbps.....but WHY? All my computers are Windows 7 (mine is Windows 8)...all cables etc are Gigabit ready.

 

What am I missing....is there a setting somewhere I need to change.

Share this post


Link to post
Share on other sites
  • 0

Posted

Ok from that menu, it shows 100Mbps.....but WHY? All my computers are Windows 7 (mine is Windows 8)...all cables etc are Gigabit ready. What am I missing....is there a setting somewhere I need to change.

They usually auto-detect the network speed on its own and adjust accordingly.. it's probably set to Auto-Negotiate or even forced to 100MB at the moment. You can go to the driver settings in the device manager or through the network control panel (either/or), bring up the properties for the network device, on the advanced tab there's a bunch of options. Look for the one that's marked "Speed and Duplex". 1.0GBs Full Duplex is usually what you want if auto-negotiate is failing for some reason, again that's assuming the hardware is all capable of it, both NICs and router.  Be careful as you can obviously make things worse if you change the wrong thing, remember what you change.

 

3ikd.png

 

Of course, both machines have to be running at 1GB, it'll only go as fast as the slowest NIC that's in the "conversation."

Share this post


Link to post
Share on other sites
  • 0

Posted

If you're on stock ASUS firmware, you'll want it on Auto for speed and duplex.

 

Check BIOS/UEFI for LAN power saving/Green Ethernet/Energy Star compliant Ethernet and try turning it off. The other possibility is that one of your network cables is improperly terminated/wired.

Share this post


Link to post
Share on other sites
  • 0

Posted

So I found that area, changed it to 1Gbps Full Duplex, and now it won't connect. Says network cable unplugged.

 

Had to change it back....What's with that...that has to do with the ASUS firmware?

Share this post


Link to post
Share on other sites
  • 0

Posted

So I found that area, changed it to 1Gbps Full Duplex, and now it won't connect. Says network cable unplugged.

 

Had to change it back....What's with that...that has to do with the ASUS firmware?

The majority of non-managed Ethernet equipment requires auto-negotiate to be set to negotiate a suitable connection. Normal for most home network routers & switches - not limited to ASUS.

 

If you have a proper managed router (E.g. CISCO, Draytek) then you can specify what port negotiates at what transfer speed.

Share this post


Link to post
Share on other sites
  • 0

Posted

So what does that mean, shouldn't it auto detect my gigabit speeds?

 

What's my options...still lost...my stuff should still be running at higher speeds..

Share this post


Link to post
Share on other sites
  • 0

Posted

Apparently, I am an idiot.

 

My modem does not do gigabit....10/100 only :( How did I miss that one.

Share this post


Link to post
Share on other sites
  • 0

Posted

What does your modem have to do with anything?? Unless you were physically connected to it - it has nothing to do with 2 devices talking to each other.

If you not getting gig speeds, then your plugged into a non gig port. Or there is something wrong with your cable.

Can you draw out how your physically connected to each other.. And how you have your router connected to your "modem" btw can you give the make and model number?? Does it have more than 1 lan port?

Share this post


Link to post
Share on other sites
  • 0

Posted

Your right, I was confused, the modem does not matter.

There is only one port on my motherboard, it's the asrock z87e-itx. My router is the Asus RT-ac66u

My computer to the wall, to router, to modem.

Share this post


Link to post
Share on other sites
  • 0

Posted

"My computer to the wall, to router, to modem. "

How is that a drawing?? Where is other computer your trying to copy files from or too connected.. Is it also wired to lan port on your router?

As you stated if one of your device your either copy from or too is only connected at 100mbit -- does not matter if your have 5 SSD in a Raid 0 on the other end connected at 10Gbe..

your only connected at 100mbit, so that is the limit your going to be able to move files in and out of that box at.

Share this post


Link to post
Share on other sites
  • 0

Posted

Yes second computer is the same, and is actually right beside the modem and router.

Xomputer to the router, to the modem.

And I was concentrating on one system, cause that menu doesn't even say 1gb,says 100Mbps.

Share this post


Link to post
Share on other sites
  • 0

Posted

This is the back of your router

 

[attachment=340309:backio.jpg]

 

Your home network speeds have noting to do with the speed set by your ISP for your modem.  Your computers are connected to the yellow ports on the router so they should get max speed (according to ASUS your modem is rated at 1.75Gbps). Resident Elite made a good point, maybe one of your Ethernet cables is not terminated correctly or has a wire broken - I had that happen after some renovations, prior to the work connection was 1 Gbps after the work it was down to 100 Mbps - once I opened the wall jack I found that one of the wires was broken  - I fixed it and I was back a 1 Gbps. 


Are both /all your computers saying that the connection is 100 Mbps or is just one of them that is 100 Mbps and the rest show 1 Gbps?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.