Sign in to follow this  
Followers 0
streetw0lf

Windows 8.1 RTM gliches I've found, how about you?

36 posts in this topic

I did a clean install of Windows 8.1 Pro x64 RTM on an 8.0 system.  The install went remarkably well.  However, I have noticed a few errors mostly in my Event log.

 

1.  I'm getting window update errors for Zune video and Zune music upgrades.  I know these are re-branded from the Xbox name so I wonder if it's just a matter of the Windows Store not ready for the Zune change until the official release of 8.1.

 

2. On the 'Defragment and Optimize Drives' menu I have two entries for  SSD GPT partitions.  The first is my C drive and the last on the list is the Recovery Partition.  Under Windows 8.0 I could TRIM both partitions.  Under 8.1 the Recovery TRIM fails with an error in my Event log.  Anyone else see this?

 

How about glitches you guys have seen?  Not talking about install problems.

 

 

Share this post


Link to post
Share on other sites

Go, I've got some too:

 

1. I've no idea why this happened, but when pressing to Windows button or clicking the startbutton (both taskbar as Charms bar), I still saw the desktop icons when desktop wallpaper on startscreen was on.

2. I can't deactivate libraries...

3. The "All apps" view sometimes switches to "by category" all by itsself.

 

Anyway, that's everything I've got for now... No serious issues, number 1 didn't appear anymore. Only 2 is annoying.

1 person likes this

Share this post


Link to post
Share on other sites

it should matter if its a leaked copy. Are you sure it is the real rtm and not a hacked together copy? You can't complain about bugs on an illegal copy because you cannot be sure it is the real copy. You won't know for sure till the real one is released to compare it to.

1 person likes this

Share this post


Link to post
Share on other sites

Windows 8 Tutorials  has some great tips on dealing with the way the File Manager displays things.  You can get things looking like 8.0 by following the tips.

 

I always laugh at the comments from the Internet Police.  I am a developer and since MS won't let me have an early Technet version I'll get it where I can.

 

btw.. I am assuming that the official release will have added changes as MS told us that.  So knock off the 'holier than thou' comment for using the leaked version..

 

Also I have no hesitation to do a clean install of the official version.  No upgrades for me as they always seem to cause problems.

3 people like this

Share this post


Link to post
Share on other sites

Running Bing Weather causes lots of errors in my event log.  Weather still works.

Share this post


Link to post
Share on other sites

I don't expect apps to work correctly until the update goes live in October. Same with the issue with .NET 3.5 - have to wait until they enable the update or of course you can install it manually.

Share this post


Link to post
Share on other sites

My thinking too.  I'm getting errors relating to modern apps.

Share this post


Link to post
Share on other sites

8.1 RTM is definitely not as polished as the Preview in my opinion. A lot more glitches and apps not working correctly. Shame

Share this post


Link to post
Share on other sites

I did a clean install of Windows 8.1 Pro x64 RTM on an 8.0 system.  The install went remarkably well.  However, I have noticed a few errors mostly in my Event log.

 

1.  I'm getting window update errors for Zune video and Zune music upgrades.  I know these are re-branded from the Xbox name so I wonder if it's just a matter of the Windows Store not ready for the Zune change until the official release of 8.1.

 

2. On the 'Defragment and Optimize Drives' menu I have two entries for  SSD GPT partitions.  The first is my C drive and the last on the list is the Recovery Partition.  Under Windows 8.0 I could TRIM both partitions.  Under 8.1 the Recovery TRIM fails with an error in my Event log.  Anyone else see this?

 

How about glitches you guys have seen?  Not talking about install problems.

Zune never existed in Windows 8. That's weird.

Share this post


Link to post
Share on other sites

For some reason Xbox music and video apps show up as "Zune" in event viewer. I guess they never bothered to change it. There's 2 borked updates for those apps in the store. 

 

Other than that, much more stable and faster than the preview for me :) 

Share this post


Link to post
Share on other sites

I havent found any glitches yet though upgrading will cause problems XD

Share this post


Link to post
Share on other sites

@Streetw0lf:  My Intel X-25 SSD showed in need of optimization, one click and trim completed. Yesterday I used SSD Tweaker -- it worked fine too; Am too seeing the WMZuneComm info event entry (still use Zune with WP7.8);

@Studio384: hiding favorites works fine here;

 

Used the 'remove everything and reinstall windows' method without saving personal files. Left with a Windows.Old directory and complete reinstall of applications. Integrating with the Microsoft account synched desktop, favorites, start page, SkyDrive, and personal settings. From there, turned off Favorites and the setting stuck.

 

The new option to designate where synched SkyDrive files are saved... fit nicely on a 32gb microSD.

 

Had some trouble with Skype video app. I'll bet it's updated before 10/18. 

 

No trouble with Windows Media Player as reported on other forums.

 

Cheers

Share this post


Link to post
Share on other sites

I was getting an error where the tops of the tiles on the start screen were chopped off, same on the bottom. I am running the latest version of the UltraUXThemePatcher 2.1 though so might have to do with that.

 

Doesn't happen all the time either.

Share this post


Link to post
Share on other sites

it should matter if its a leaked copy. Are you sure it is the real rtm and not a hacked together copy? You can't complain about bugs on an illegal copy because you cannot be sure it is the real copy. You won't know for sure till the real one is released to compare it to.

It's the official RTM that has leaked...

And you can be absolutely be sure it's the real one, doesn't take much research.

Share this post


Link to post
Share on other sites

8.1 RTM is definitely not as polished as the Preview in my opinion. A lot more glitches and apps not working correctly. Shame

They can, and most likely will, push updates before the general release.

Share this post


Link to post
Share on other sites

8.1 RTM is definitely not as polished as the Preview in my opinion. A lot more glitches and apps not working correctly. Shame

 

Apps not working correctly yet doesn't surprise me.   They're probably still working on them and tweaking the server side.

Share this post


Link to post
Share on other sites

Some other apps are logitech apps (game software/setpoint), diskeeper 12.

Share this post


Link to post
Share on other sites

@Streetw0lf:  My Intel X-25 SSD showed in need of optimization, one click and trim completed. Yesterday I used SSD Tweaker -- it worked fine too; Am too seeing the WMZuneComm info event entry (still use Zune with WP7.8);

On the Administrative Tools | Defragment and Optimize Drives window I have two entries for my SSD.  My C: drive (SSD) is the first entry and the Recovery partition for my C: drive is at the bottom of he list.  I have no problems TRIMing my C: drive but TRIMing the Recovery Partition does not do anything other then place an error in my Event Log.  Windows 8 had no problem TRIMing the Recovery Partition.

 

Are you seeing the Recovery Partition?  If so, are you able to TRIM this successfully?  It should not say 'Needs optimization' if it was successful.

Share this post


Link to post
Share on other sites

when you go to "This PC" --->"Documents"...right click on any folder, then go to --->"include in library" -->Documents. Once you do that, you will see Libraries appears on the left side navigation. But when you close the window, the library disappears

Share this post


Link to post
Share on other sites

I haven't liked SetPoint - ever. Unless you go macro-happy, it's too bulky (even compared to Microsoft's Mouse and Keyboard Center for Windows 8, which I happily use instead).  And it's not crookery, as I have a Microsoft Wireless Keyboard 6000 V.3.

 

And speaking of the Mouse and Keyboard Center, it works a treat in 8.1, too.

 

Diskeeper 12 was in trouble with Disk Optimizer in Windows 8 alone; I neither use OR recommend it in Windows 8, let alone 8.1.  (This will be the first back-to-back Windows versions I have refused to either use OR recommend ANY version of Diskeeper with since - egad - Windows 98, when I started my LONG association with Diskeeper.)

Share this post


Link to post
Share on other sites

On the Administrative Tools | Defragment and Optimize Drives window I have two entries for my SSD.  My C: drive (SSD) is the first entry and the Recovery partition for my C: drive is at the bottom of he list.  I have no problems TRIMing my C: drive but TRIMing the Recovery Partition does not do anything other then place an error in my Event Log.  Windows 8 had no problem TRIMing the Recovery Partition.

 

Are you seeing the Recovery Partition?  If so, are you able to TRIM this successfully?  It should not say 'Needs optimization' if it was successful.

 

I have a similar issue to you. In Optimise Drives I see my HDD, my C partition (SSD) and the 350 MB System Reserved partition (SSD). If I try and optimise the System Reserved partition, the Optimise Drives window disappears, reappears, but it says "Never run" and "Needs optimisation" next to the System Reserved partition. Also, an error is logged in Event Log: -

 

The volume System Reserved was not optimised because an error was encountered: The parameter is incorrect. (0x80070057)

 

There is also a bug in Windows 8.1 that's carried over from Windows 8, where your SSD will be defragmented under certain circumstances. For this to occur, the following conditions have to be met: -

 

1. The SSD partition is more than 10% fragmented.

2. The standard scheduled maintenance is enabled, or you start a maintenance run manually via Action Center.

 

This issue never occurs if you just go to Optimise Drives and click on your SSD then hit "Optimise". It only occurs when the above conditions are met, which is why a lot of people don't know it's happened. To see if it's happened, you can copy and paste this command into Windows PowerShell: -

 

Get-EventLog -LogName Application -Source "microsoft-windows-defrag" | sort timegenerated -desc | fl timegenerated, message

 

For any partitions on an SSD, you should only see logged events that say this: -

 

 

 

The storage optimiser successfully completed retrim on *Drive Name* (*Drive letter*)

 

But if you have been affected by this bug, you will also see this appear occasionally for SSD partitions: -

 

The storage optimiser successfully completed defragmentation on *Drive Name* (*Drive Letter*)

 

I have reported this to Microsoft and so have a bunch of other people, but either they are not interested in fixing it or the reports aren't getting through to the right people. The only solution is to exclude all SSD partitions from scheduled maintenance in Optimise Drives, then create a new event in Task Scheduler that will retrim SSD partitions once per week using the -l -h switches. If you do that, you won't see any more logged events saying that SSD partitions have been defragmented and you'll only see ones saying that they've been retrimmed. This does not fix the issue with not being able to optimise certain SSD partitions, however. It was through Googling for a solution to that that I found this thread.

Share this post


Link to post
Share on other sites

Hold off worrying about these errors until 8.1 is officially released.

 

There are backend features that are still not in place, which is why the release is set for the date it is. 

Specifically, Zune/Xbox services and servers are not fully changed and available for 8.1 users yet, and that would explain why the Apps and services would be failing.

 

With Windows 8 and 8.1, there are a lot of server side features that must be enabled and working. For example, just how your roaming profile of your MS Account is stored and saved is different from 8 and 8.1 Preview.  So if Microsoft hasn't fully enabled all these features or allowed access to them, it would generate errors.

 

(I see people complaining that 8.1 RTM isn't as polished as the Preview, and considering that not all the RTM features are enabled for everyone in every location, this should be expected.)

Share this post


Link to post
Share on other sites

Connecting to a VPN network doesn't work from the sidebar, you have to open VPN connection properties and connect/disconnect from there.

 

Sometimes, context menus/combo boxes get messed up. I had this problem in Windows 8 as well as Windows 8.1, on NVidia and ATI cards, on both an AMD and an Intel machine.

Share this post


Link to post
Share on other sites

Buttons on charms bar shift upwards or downwards depending on their mood.

Share this post


Link to post
Share on other sites

Buttons on charms bar shift upwards or downwards depending on their mood.

If you swipe in from the top the charms bar will load the icons towards the top of the screen, if you swipe in from the bottom it will load the icons towards the bottom of the screen. Same with the mouse pointer. Its not a glitch or bug, its a feature.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.