Jump to content



Photo

itunes library question


  • Please log in to reply
16 replies to this topic

#1 BoDEAN

BoDEAN

    REDHead

  • Joined: 04-May 04
  • Location: Chicago, IL
  • OS: Windows 8.1
  • Phone: Iphone

Posted 03 September 2013 - 00:50

I moved my itunes library to my Nas.  Just formated my PC, and reinstalled itunes. Now I need to put itunes to my library.  
 
Not sure what path to put in Itunes anymore for it.
 
My diskstation is E:\MP3 and the subdirectories are Automatically add to itunes, downloads, mobile applications, music (all created by itunes)
 
Should I use MP3 or Music for the itunes library in itunes? (ie the root directory, or the directory with the actual music)



#2 +timster

timster

    Neowinian Senior

  • Joined: 29-March 08
  • Location: Toronto, Canada
  • OS: 8.1
  • Phone: Lumia 830

Posted 03 September 2013 - 00:56

drop the iTunes library config files into C:\Users\<username>\Music\iTunes

 

all your mp3s will remain linked properly



#3 OP BoDEAN

BoDEAN

    REDHead

  • Joined: 04-May 04
  • Location: Chicago, IL
  • OS: Windows 8.1
  • Phone: Iphone

Posted 03 September 2013 - 01:01

Not sure where that file is.  C: is my boot drive. D: is where Itunes was installed, and I reinstalled it after format to the same directory on D:

Again,  Before the format, I pointed my library to my NAS drive (where my music is).   

Root is MP3, subdirectories are Automatically Add to Itunes, Downloads, Mobile Applications, Music



#4 einsteinbqat

einsteinbqat

    Neowinian

  • Joined: 16-May 02

Posted 03 September 2013 - 02:19

You should have moved your library, and backup the folder c:\users\username\music\iTunes before the format.

Once the format was done, all that you needed to do was to copy the backup folder back to the C:\ drive, and be done.

#5 OP BoDEAN

BoDEAN

    REDHead

  • Joined: 04-May 04
  • Location: Chicago, IL
  • OS: Windows 8.1
  • Phone: Iphone

Posted 03 September 2013 - 02:25

You should have moved your library, and backup the folder c:\users\username\music\iTunes before the format.

Once the format was done, all that you needed to do was to copy the backup folder back to the C:\ drive, and be done.

 

I do have c:\users\username\music\iTunes backed up on my Nas. There are many files in there from backups. Copy all of that to C and be done? I don't need to change the Media Location in itunes if I do this?



#6 einsteinbqat

einsteinbqat

    Neowinian

  • Joined: 16-May 02

Posted 03 September 2013 - 02:32

Did you manually move the files or did you tell iTunes to do it?

If iTunes made the move because you told it to through the advanced preferences, and then consolidated the library to your Nas, all the media can be deleted from the C:\ drive. You only need to keep the .itl, .xml files.

If you manually moved the media, you need to set iTunes to the proper folder, consolidate the library, and then you will be able to delete the media from the C:\ drive.

#7 OP BoDEAN

BoDEAN

    REDHead

  • Joined: 04-May 04
  • Location: Chicago, IL
  • OS: Windows 8.1
  • Phone: Iphone

Posted 03 September 2013 - 02:36

Did you manually move the files or did you tell iTunes to do it?

If iTunes made the move because you told it to through the advanced preferences, and then consolidated the library to your Nas, all the media can be deleted from the C:\ drive. You only need to keep the .itl, .xml files.

If you manually moved the media, you need to set iTunes to the proper folder, consolidate the library, and then you will be able to delete the media from the C:\ drive.

 

I told Itunes to move the files, and it consolidated my library to my nas, where all my music is now.

Since I use Itunes match, all my songs/albums show in itunes, but all have cloud symbol next to them (telling me they are being located in the cloud, but not locally)



#8 einsteinbqat

einsteinbqat

    Neowinian

  • Joined: 16-May 02

Posted 03 September 2013 - 03:25

Oh! that cloud sign. Just remove it. It's in the preferences.



#9 OP BoDEAN

BoDEAN

    REDHead

  • Joined: 04-May 04
  • Location: Chicago, IL
  • OS: Windows 8.1
  • Phone: Iphone

Posted 03 September 2013 - 14:22

Ignore the cloud sign, ok



#10 OP BoDEAN

BoDEAN

    REDHead

  • Joined: 04-May 04
  • Location: Chicago, IL
  • OS: Windows 8.1
  • Phone: Iphone

Posted 03 September 2013 - 14:46

You should have moved your library, and backup the folder c:\users\username\music\iTunes before the format.

Once the format was done, all that you needed to do was to copy the backup folder back to the C:\ drive, and be done.

 

I should have specified, prior to format, I followed this guide/instructions from moving my library from my HD, to my NAS.



#11 einsteinbqat

einsteinbqat

    Neowinian

  • Joined: 16-May 02

Posted 03 September 2013 - 17:09

So everything is ok now?

#12 OP BoDEAN

BoDEAN

    REDHead

  • Joined: 04-May 04
  • Location: Chicago, IL
  • OS: Windows 8.1
  • Phone: Iphone

Posted 03 September 2013 - 19:29

Yup, seems to be working fine now. Thanks for the assistance



#13 OP BoDEAN

BoDEAN

    REDHead

  • Joined: 04-May 04
  • Location: Chicago, IL
  • OS: Windows 8.1
  • Phone: Iphone

Posted 19 October 2013 - 00:00

Hate to bring up an old topic, but I formatted again.  Restored the itunes library files.  Now my files show again, but again, every song (13000) of them, have an icloud symbol with a down arrow next to them...meaning they are in the icloud but not being found locally



#14 einsteinbqat

einsteinbqat

    Neowinian

  • Joined: 16-May 02

Posted 19 October 2013 - 16:14

LOL Unlucky, you! :p

 

And the path to the media folder is properly set within iTunes preferences?



#15 Boo Berry

Boo Berry

    Neowinian Ghost

  • Tech Issues Solved: 6
  • Joined: 26-March 05
  • Location: United States
  • OS: Windows 8.1 Pro 64-bit Mac OS X Yosemite 10.10.1 Ubuntu 14.10 64-bit

Posted 19 October 2013 - 16:23

What you could do is... delete all files in your library (without deleting the actual files) then dragging and dropping the folder of music into iTunes and it'll re-add them. I've done this in the past when I made sure I had the files already in the correct media folder directory that I set in iTunes so it doesn't create duplicates. This also assumes you have all your music properly tagged and everything.

 

It's really a last resort, but I've done it before.