Jump to content

Question

Posted

Hi,

 

I watched a YT video from CNET about setting up an open source dropbox alternative. To my surprise there was really a good one waiting to be explored. www.owncloud.org

Ok. so down to my issues:

Setup:

  1. TP link ADSL router TD-w8968 
  2. FTP server ftp://koshur.homelinux.net (which is basically my 1TB segate HDD connected to router's USB interface)
  3. Got dyndns setup within the router to resolve hostname (credits to Budman and +sc302!)
  4. Two laptops logged on via wifi apart from two android smart phones.
  5. I use XMBC to stream content via SMB sever on my LAN.

What I'm trying to do:n 

  • For now, I want my data to reside on my FTP (HDD).  
  • Installed ownclound via .deb installer on Ubuntu 12.04. When i pulled up the index page (http://ipaddress/owncloud) it asked me to set location for the data reside. 
  • I entered the URL (root directory - that i have admin access, read write) of the SMB sever (my FTP) but it didn't accept and threw permission error (see below)

[attachment=343441:Screenshot from 2013-09-06 21:39:38.png]

 

I read about the error at various thread like this one http://forum.owncloud.org/viewtopic.php?f=17&t=7118. Downloaded the admin user guide(http://doc.owncloud.org/) about setting up the SMB as location to save data. I guess i got caught up at 'Custom Mount Configuration' on page 41. Since I'm not from a programming field, couldn't make out the JSON thing.

 

I'm so willing to get this working. I would love to move on from Dropbox. If this works out, I'll probably think of getting a proper NAS device for backups. Now the reason I am wiling to go this far - Its a closest alternative I've come across to dropbox. 

 

How to get my FTP (HDD) working as storage for owncloud.?

 

Thanks
MArk

Share this post


Link to post
Share on other sites

31 answers to this question

  • 0

Posted

I don't think that is the correct syntax for smbclient, I would think you should have to escape \ so it would be like \\\\192.168.1.1

But I think you can just do something with -L and the IP.. it will throw out some errors but should work

budman@ubuntu:/$ smbclient -L 192.168.1.8
Enter budman's password:
Domain=[STORAGE] OS=[Windows Storage Server 2008 R2 Essentials 7601 Service Pack 1] Server=[Windows Storage Server 2008 R2 Essentials 6.1]

        Sharename       Type      Comment
        ---------       ----      -------
        ADMIN$          Disk      Remote Admin
        C$              Disk      Default share
        D$              Disk      Default share
        F$              Disk      Default share
        G$              Disk      Default share
        H$              Disk      Default share
        IPC$            IPC       Remote IPC
        J               Disk
        J$              Disk      Default share
        Media           Disk
        Molly           Disk
        Music           Disk
        temp            Disk
session request to 192.168.1.8 failed (Called name not present)
session request to 192 failed (Called name not present)
session request to *SMBSERVER failed (Called name not present)
NetBIOS over TCP disabled -- no workgroup available
budman@ubuntu:/$

Share this post


Link to post
Share on other sites
  • 0

Posted

so your smb share server name is "adsl router" with a space in the name? That can cause all kinds of issues, better would be adslrouter or adsl-router or adsl_router, etc.

You can access \\adsl router from your computer? That seems unlikely to me.

did you try
 
smb : // 192.168.1.xxx/sharename
What username and password are you using?

its odd if I put smb : // next to each other it doesnt post.

Share this post


Link to post
Share on other sites
  • 0

Posted

Not sure I understand...

 

why don't you just mount the share as a folder and point owncloud at that folder?

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Posted

so your smb share server name is "adsl router" with a space in the name? That can cause all kinds of issues, better would be adslrouter or adsl-router or adsl_router, etc.

You can access \\adsl router from your computer? That seems unlikely to me.

did you try
 

smb : // 192.168.1.xxx/sharename
What username and password are you using?

its odd if I put smb : // next to each other it doesnt post.

 

 

The URL for my SMB, for some reasons shows a %. I use the router 'admin' and password to access the SMB (which is basically the admin user for FTP). I also have a user with read only access with a different username and password. Check these:

 

[attachment=343481:Screenshot from 2013-09-07 07:58:02.png] 

[attachment=343483:Screenshot from 2013-09-07 07:49:02.png]

[attachment=343485:TD W8968.png]

[attachment=343487:TD W8968(2).png]

[attachment=343489:Screenshot from 2013-09-07 08:06:19.png]

 

Part of the problem now is that I cant get the location reset back to default. Everytime i open http://192.168.1.100/owncloud/, it points to the same smb location

 

I'm looking this would be in config.php (/var/www/owncloud/config). But the config file won't open with the text editor. Looks like i might need to re-instal?

 

 

Not sure I understand...

 

why don't you just mount the share as a folder and point owncloud at that folder?

 

Hmmm..wel. i'll first need to get the location reset to default. If i mount the smb as a share folder on my Lappi and point the owncloud to the location, it would still have the % symbol there. I'm guessing by mounting you mean as i've done (refer my file manger screenshots). 

The segate is mounted. Plus i'll need this to point everytime and always to my HDD permanently. I don't want to be mounting the folder everytime. Wouldn't that defeat the purpose of using my FTP as storage?

Share this post


Link to post
Share on other sites
  • 0

Posted

%20 is space in html, change your NAME of your device!!

As to mount, why don't you just go into command line of your owncloud install and mount the share via the OS say to /nas and then just in owncloud look to what it thinks is local storage.
2 people like this

Share this post


Link to post
Share on other sites
  • 0

Posted

noob question - where do i change the Device Name. Router? 

Share this post


Link to post
Share on other sites
  • 0

Posted

Koshur, on 07 Sept 2013 - 11:55, said:

noob question - where do i change the Device Name. Router? 

 

Yes, likely under the Network or LAN pages looking at that screenshot.

Share this post


Link to post
Share on other sites
  • 0

Posted

As to mount, why don't you just go into command line of your owncloud install and mount the share via the OS say to /nas and then just in owncloud look to what it thinks is local storage.

 

Isn't that what I said?

Share this post


Link to post
Share on other sites
  • 0

Posted

it wont allow to rename:

 

[attachment=343493:Screenshot from 2013-09-07 16:26:14.png]

Share this post


Link to post
Share on other sites
  • 0

Posted

That's what I took what you stated to mean yes.. I just reworded it a bit since he didn't seem to understand it.

"If i mount the smb as a share folder on my Lappi and point the owncloud to the location"

edit: Hit your adsl device directly!!! via its web gui

Share this post


Link to post
Share on other sites
  • 0

Posted

BTW, how do i reset this.I tried reinstalling. that didnt work 

[attachment=343497:Screenshot from 2013-09-07 16:40:02.png]

Share this post


Link to post
Share on other sites
  • 0

Posted

That's what I took what you stated to mean yes.. I just reworded it a bit since he didn't seem to understand it.

"If i mount the smb as a share folder on my Lappi and point the owncloud to the location"

edit: Hit your adsl device directly!!! via its web gui

 

I cant find an option to change the name in router GUI. Where could it possibly be?

Share this post


Link to post
Share on other sites
  • 0

Posted

I just looked in the manual real quick and did not see it to be honest.. Strange! I just got a tp-link TL-WDR3600 to replace my aging wrt54g and move into the dual band world of N.. Couldn't pass up the deal of $42 to use as accesspoint.

And in the few minutes I had the native firmware on it, not sure if it had a place to change hostname? But I did not bother with smb stuff.. But here in dd-wrt gui is where you would set it

[attachment=343501:sambaservername.png]

I would have to assume anything that could share out via smb must have place to change its name and what workgroup its a member of -- this would be for network browsing features and grouping, etc.

Share this post


Link to post
Share on other sites
  • 0

Posted

I've not flashed the firmware to dd-wrt. I'm using TP link's built in firmware. Mine is TD-w8968 and I don't see the NAS option you have. Does this mean I'll have to flash the firmware (that would void the warranty)

Share this post


Link to post
Share on other sites
  • 0

Posted

I doubt you can flash to dd-wrt if with a ADSL device.. I can not believe a device would allow sharing via smb/cifs and not allow changing of its name?? Or what workgroup its a member of. Like I said I had their crappy firmware on for about 3 minutes - enough time to flash it to dd-wrt ;)

But in the example they show using IP address to access it.

Mount it via command line and the ip address to a folder as suggested in the OS of the box your running owncloud on.

Share this post


Link to post
Share on other sites
  • 0

Posted

would it be "sudo mount <source location> <mount point folder/destination>" ??

Share this post


Link to post
Share on other sites
  • 0

Posted

Yes - that'll do it for a one-time mount.

 

You need to edit /etc/fstab for something that mounts automatically at boot.

 

See: http://www.ghacks.net/2009/04/19/auto-mounting-a-samba-share-in-linux/

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

Yes - that'll do it for a one-time mount.

 

You need to edit /etc/fstab for something that mounts automatically at boot.

 

See: http://www.ghacks.net/2009/04/19/auto-mounting-a-samba-share-in-linux/

 Thanks, Ill try this, would this fix "Can't create data directory" error? or would I need to reset the config.php (which i really can't figure out)

 

Ran the command, got this error. 

root@koshur-HP-ProBook-4530s:/home/koshur# //192.168.1.1/segate(sda1) -U admin
bash: syntax error near unexpected token `sda1'
root@koshur-HP-ProBook-4530s:/home/koshur# 

Edited by Koshur

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

Requesting a TM session.. 

 

User ID: 196281112

Edited by Koshur

Share this post


Link to post
Share on other sites
  • 0

Posted

I think you can just delete config.php

Share this post


Link to post
Share on other sites
  • 0

Posted

I think you can just delete config.php

Tried to. but i wont allow. throws permission error. 

Share this post


Link to post
Share on other sites
  • 0

Posted

use sudo?

Share this post


Link to post
Share on other sites
  • 0

Posted

ok. so i root into the /var/www/owncloud/config and deleted the config.php and config-sample.php. and i now see the default login screen! But i'm still dicey about the auto mount would work since it wont recognize  

root@koshur-HP-ProBook-4530s:/home/koshur# //192.168.1.1/segate(sda1) -U admin

Share this post


Link to post
Share on other sites
  • 0

Posted

Ok for one thing from your screeny, seqate(sda1) is NOT your share name.. its just segate

See
[attachment=343511:sharename.png]

So I have no idea why your putting that in your command? That might be your whole issue in your smb : // attempt..

And wouldn't it be seagate anyway? That is the name of the drive company, not segate ;)

Share this post


Link to post
Share on other sites
  • 0

Posted

Ok for one thing from your screeny, seqate(sda1) is NOT your share name.. its just segate

See
attachicon.gifsharename.png

So I have no idea why your putting that in your command? That might be your whole issue in your smb : // attempt..

And wouldn't it be seagate anyway? That is the name of the drive company, not segate ;)

 

ok, so here's the output:

root@koshur-HP-ProBook-4530s:/home/koshur# smbclient //192.168.1.1/segate -U admin
Enter admin's password: 
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.0.14a]
tree connect failed: NT_STATUS_BAD_NETWORK_NAME
root@koshur-HP-ProBook-4530s:/home/koshur# 

segate - well this would have been how it first can to my mind. :)

 

Here is how my Index of look like for admin:

[attachment=343515:Index of.png]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.