32 posts in this topic

that is not your smb index of shares - your hitting ftp in that screeny not \\servername

Here is example of smb shares on a server

post-14624-0-17090300-1378559170.png

Share this post


Link to post
Share on other sites

I guess mine would then be this:

 

post-431588-0-76929000-1378559615.png

post-431588-0-91579400-1378559619.png

post-431588-0-71992200-1378559627.png

 

The issue here is the space in device name.

 

Share this post


Link to post
Share on other sites

not sure if it was answered or not, but adsl%20router is showing you a special character, in this case a space. for unix to like this, it needs " " around the path, or a backslash after asdl (asdl\ router). or alternativly you can remove that space from your asdl routers name. If other things are configured this can be problematic. Hope this helps you with future special characters. also remember Asdlrouter is different from asdlrouter in the unix world (caps matter, extensions don't)

 

I got owncloud installed on my freeBSD server and super easy to get working, but it was terrible at performing.. very buggy, froze the server up every time a file over 2MB was transferred. Good thing I made backups! Hope your ubuntu install goes better.

1 person likes this

Share this post


Link to post
Share on other sites

I don't think that is the correct syntax for smbclient, I would think you should have to escape \ so it would be like \\\\192.168.1.1

But I think you can just do something with -L and the IP.. it will throw out some errors but should work

budman@ubuntu:/$ smbclient -L 192.168.1.8
Enter budman's password:
Domain=[STORAGE] OS=[Windows Storage Server 2008 R2 Essentials 7601 Service Pack 1] Server=[Windows Storage Server 2008 R2 Essentials 6.1]

        Sharename       Type      Comment
        ---------       ----      -------
        ADMIN$          Disk      Remote Admin
        C$              Disk      Default share
        D$              Disk      Default share
        F$              Disk      Default share
        G$              Disk      Default share
        H$              Disk      Default share
        IPC$            IPC       Remote IPC
        J               Disk
        J$              Disk      Default share
        Media           Disk
        Molly           Disk
        Music           Disk
        temp            Disk
session request to 192.168.1.8 failed (Called name not present)
session request to 192 failed (Called name not present)
session request to *SMBSERVER failed (Called name not present)
NetBIOS over TCP disabled -- no workgroup available
budman@ubuntu:/$

Share this post


Link to post
Share on other sites

thanks.. it worked with 

 /home/koshur# smbclient -L //192.168.1.1/segate -U admin
root@koshur-HP-ProBook-4530s:/home/koshur# smbclient -L //192.168.1.1/segate -U admin
Enter admin's password: 
Domain=[WORKGROUP] OS=[unix] Server=[samba 3.0.14a]
 
Sharename       Type      Comment
---------       ----      -------
segate(sda1)    Disk      
movies(sda1)    Disk      
IPC$            IPC       IPC Service (Samba Server)
ADMIN$          IPC       IPC Service (Samba Server)
Domain=[WORKGROUP] OS=[unix] Server=[samba 3.0.14a]
 
Server               Comment
---------            -------
ADSL ROUTER          Samba Server
KOSHUR-HP-PROBO      koshur-HP-ProBook-4530s server (Samba, Ubu
 
Workgroup            Master
---------            -------
WORKGROUP            KOSHUR-HP-PROBO
 

I'll try testing it for some time and decide if i should stick to it or not. 

 

Cheers!!

Share this post


Link to post
Share on other sites

not sure if it was answered or not, but adsl%20router is showing you a special character, in this case a space. for unix to like this, it needs " " around the path, or a backslash after asdl (asdl\ router). or alternativly you can remove that space from your asdl routers name. If other things are configured this can be problematic. Hope this helps you with future special characters. also remember Asdlrouter is different from asdlrouter in the unix world (caps matter, extensions don't)

 

I got owncloud installed on my freeBSD server and super easy to get working, but it was terrible at performing.. very buggy, froze the server up every time a file over 2MB was transferred. Good thing I made backups! Hope your ubuntu install goes better.

 

Thanks for the tip. I'll put it to some testing and see how it tuns out on ubuntu

Share this post


Link to post
Share on other sites

your listing with -L is messed up.. So in your screeny showing how you had it setup, you called your sharename segate, but then in your connection via smbclient it lists your shares as

Sharename       Type      Comment
---------       ----      -------
segate(sda1)    Disk      
movies(sda1)    Disk      
Where (sda1) is added to the sharename??

So far from what I can see the tp-link implementation of SAMBA is horrific! Seems you can not change the server name or workgroup name.. And it mangles what you create for a share name? That is terrible way to go about it, and seems it defaults to netbios name with a space in the name that you can not alter? Pathetic if you ask me.. Good luck with it, I can only assume its performance is par with what we have seen so far ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.