Jump to content



Photo

Sound.. Gone?


  • Please log in to reply
5 replies to this topic

#1 Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 9
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Mint Debian LMDE
  • Phone: HTC ONE V

Posted 21 September 2013 - 01:33

I recently opened JR Media Jukebox in Wine, and played some tunes, then nothing else gave sound, VLC, Movie Player, even youtube and games. It's just like, it turned off. I look at volume options, and all was the same way I left it. So, I thought a restart would fix it. Nope. There's something I need to do, I know it, sometimes it just... works....

 

Edit: Oh, I had it using HDA Intel PCH (Alsa Mixer)




#2 OP Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 9
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Mint Debian LMDE
  • Phone: HTC ONE V

Posted 21 September 2013 - 02:14

Just using Gnome for now.... But still, why?



#3 medhunter

medhunter

    Muslim Emergency physician

  • Joined: 19-June 11
  • Location: Egypt
  • OS: Win 7 SP1 Home Premium , Ubuntu 12.04 LTS, Xubuntu 13.04
  • Phone: Sony Sola

Posted 21 September 2013 - 03:46

I had similar issues with Ububtu 13.04, so ditched it to LTS.

I think you didn't mention the distro you are using, did you?



#4 francescob

francescob

    Neowinian Senior

  • Tech Issues Solved: 1
  • Joined: 04-November 08

Posted 21 September 2013 - 03:51

The Gentlemen must be back in town!

xOgQI.jpg



#5 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 21 September 2013 - 05:17

Wine sets up a bridge to ALSA (or PulseAudio if that is available) for the applications running under it to use transparently. Effectively Wine gives those applications complete control over the audio settings for the current user. Since those applications are not aware of this bridge they sometimes unintentionally make changes that are not represented by controls in your graphical audio control center (in this case GNOME's audio applet). Unfortunately this behavior is usually triggered by bugs in Wine (or bugs in the programs triggered by technically-correct behavior in the Wine ABI) and cannot be avoided short of not running the aforementioned programs.

 

Given the scenario above the easiest way to restore your audio stack to a working state is probably to reset your ALSA (or PulseAudio) settings. Since it is likely that you are using PulseAudio if you are running a relatively modern Linux distro, you can reset those settings for the current user as follows:

sudo service pulseaudio stop
rm -rf /tmp/pulse* ~/.pulse*
sudo reboot


#6 OP Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 9
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Mint Debian LMDE
  • Phone: HTC ONE V

Posted 21 September 2013 - 12:41

I think you didn't mention the distro you are using, did you?

 

Sorry, thought I had Debian Wheezy in my sig. Need to fix that.

 

Thanks, Orange, that helped :)