Jump to content



Photo

Why user name and password needed for network sharing?

network sharing windows 7 networking

  • Please log in to reply
10 replies to this topic

#1 flynempire

flynempire

    It's called the bat and yes Mr. Wayne it comes in black :)

  • Joined: 19-January 10
  • Location: Sunny - Miami, FL
  • OS: Windows 7 Pro SP-1, Windows 8.1 (RT) Android 4.1.2 Windows 8.1 Up1
  • Phone: Samsung Exhibit (Latest Model)

Posted 30 September 2013 - 21:12

Recently I helped a new customer at their office which has a Peer network and had 2 Vista Pro SP-2 machines & 1 Win 7 Pro SP-1 machine.

One of the Vista machines was either hacked or some bad virus came in and I had to backup everything and install Windows 7 Pro SP-1 on it.

Now everything is working better as this machine acts as the server but when the other 2 need to access a share it wants the user name and password of the local account.

How can I stop this from happening? I do have the shares set for everyone with full control/access. There are 4 shares in that machine and this really should be simple. I made sure in the registry, services and network and sharing that the server machine is the only one that acts as server and the others just clients.

Any help is appreciated..




#2 Lord Method Man

Lord Method Man

    Banned

  • Tech Issues Solved: 1
  • Joined: 18-September 12

Posted 30 September 2013 - 21:17

Did you also add give 'Everyone' access in the Security tab (not the Sharing tab) of the folder? I ran into this a few weeks ago and had to do that as well.



#3 OP flynempire

flynempire

    It's called the bat and yes Mr. Wayne it comes in black :)

  • Joined: 19-January 10
  • Location: Sunny - Miami, FL
  • OS: Windows 7 Pro SP-1, Windows 8.1 (RT) Android 4.1.2 Windows 8.1 Up1
  • Phone: Samsung Exhibit (Latest Model)

Posted 30 September 2013 - 21:30

Good question. I believe I did but will confirm tonight..



#4 TPreston

TPreston

    Neowinian Senior

  • Tech Issues Solved: 2
  • Joined: 18-July 12
  • Location: Ireland
  • OS: Windows 8.1 Enterprise & Server 2012R2/08R2 Datacenter
  • Phone: Nokia Lumia 1520

Posted 30 September 2013 - 21:32

Its secure by default, You have to disable this using group policy

Edit in gpedit.msc ( Window 2008 Enterprise Server )

gpedit.msc >>> Computer Configuration >>> Window Settings >>> Security Settings >>> Local

Policies >>> Security Options

then Search and Change in "Network access: Sharing and security model for local account" from

“Classic-local users authenticate as themselves” to “Guest only-local users authenticate as Guest”

http://serverfault.c...sking-for-login

#5 OP flynempire

flynempire

    It's called the bat and yes Mr. Wayne it comes in black :)

  • Joined: 19-January 10
  • Location: Sunny - Miami, FL
  • OS: Windows 7 Pro SP-1, Windows 8.1 (RT) Android 4.1.2 Windows 8.1 Up1
  • Phone: Samsung Exhibit (Latest Model)

Posted 30 September 2013 - 21:52

This is not a server though. Just  peer to peer with one acting as a server holding the shares and files.



#6 Ambroos

Ambroos

    Neowinian Senior

  • Tech Issues Solved: 7
  • Joined: 16-January 06
  • Location: Belgium
  • OS: Windows 7 + 8.1
  • Phone: Sony Xperia Z2

Posted 30 September 2013 - 22:01

This is not a server though. Just  peer to peer with one acting as a server holding the shares and files.

There's a lot of server stuff in Windows client versions. The setting is there.



#7 OP flynempire

flynempire

    It's called the bat and yes Mr. Wayne it comes in black :)

  • Joined: 19-January 10
  • Location: Sunny - Miami, FL
  • OS: Windows 7 Pro SP-1, Windows 8.1 (RT) Android 4.1.2 Windows 8.1 Up1
  • Phone: Samsung Exhibit (Latest Model)

Posted 01 October 2013 - 01:08

Yes thanks. I found it. I never knew this existed. So by applying this setting then no login prompt should appear. They should just be able to access the share



#8 +BudMan

BudMan

    Neowinian Senior

  • Tech Issues Solved: 101
  • Joined: 04-July 02
  • Location: Schaumburg, IL
  • OS: Win7, Vista, 2k3, 2k8, XP, Linux, FreeBSD, OSX, etc. etc.

Posted 01 October 2013 - 05:11

Or you could just turn off password sharing in advanced sharing options in control panel..



#9 HawkMan

HawkMan

    Neowinian Senior

  • Tech Issues Solved: 4
  • Joined: 31-August 04
  • Location: Norway
  • Phone: Noka Lumia 1020

Posted 01 October 2013 - 05:41

Yes, you need to turn off password protected sharing. Which is a bit misnamed, since you CAN still require passwords with it off. But with it on you can't share without passwords.

You may also need to change the home sharing setting to use usernames and passwords instead of the windows 7 and 8 home network group thing.

Also remember on any folder stored in a user profile, you will need to set everyone to have at least read access, not only on the sharing rights, but also on the folder permissions themselves.

#10 OP flynempire

flynempire

    It's called the bat and yes Mr. Wayne it comes in black :)

  • Joined: 19-January 10
  • Location: Sunny - Miami, FL
  • OS: Windows 7 Pro SP-1, Windows 8.1 (RT) Android 4.1.2 Windows 8.1 Up1
  • Phone: Samsung Exhibit (Latest Model)

Posted 01 October 2013 - 12:27

Thanks for all the help guys. I basically have all the settings correct but I need to go back there today and see about the password protected sharing. I do have one question though.

When I tick Turn On Network Discovery and click save it never sticks. I go back in to make sure and it is always off. Why does this happen?



#11 OP flynempire

flynempire

    It's called the bat and yes Mr. Wayne it comes in black :)

  • Joined: 19-January 10
  • Location: Sunny - Miami, FL
  • OS: Windows 7 Pro SP-1, Windows 8.1 (RT) Android 4.1.2 Windows 8.1 Up1
  • Phone: Samsung Exhibit (Latest Model)

Posted 06 October 2013 - 20:51

Just wanted to provide and update. I did everything that was posted here and no longer do they get the User Name and Password logon.

 

Thank you