Jump to content



Photo

Strange IP behaviour

Answered Go to the full post ip lan gateway nic server

  • Please log in to reply
2 replies to this topic

#1 Skiver

Skiver

    Neowinian Senior

  • Tech Issues Solved: 2
  • Joined: 10-October 05
  • Location: UK, Reading

Posted 07 October 2013 - 13:41

Hi All,

 

I hope you can help me with an incredibly strange issue I'm facing. I have a server that randomly seems to have decided that it wants a new static IP and no matter what I do it is forcing that IP into the NIC settings. It should have the .169 address assigned to it but no matter how many times i remove the .22 or reboot it just keeps coming back.

 

It's causing, as you can imagine to have inconsistent network connectivity and the server is failing to do its job. Luckily so far the the Hyper V host that has the .22 address doesn't seem to have thrown up any errors but I suspect this is more through luck than anything else and it will start to cause issues sooner rather than later.

 

anyone ever experienced this or got any ideas as I am fresh out!

 

Untitled-3.png



Best Answer +PeterUK , 07 October 2013 - 14:16

Remove the gateway IP and the two IP's check in

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\Parameters\PersistentRoutes

and delete the any PersistentRoutes (do not delete the key) then re-add your IP and gateway settings.

Go to the full post



#2 +PeterUK

PeterUK

    Neowinian Senior

  • Tech Issues Solved: 5
  • Joined: 26-March 07

Posted 07 October 2013 - 14:16   Best Answer

Remove the gateway IP and the two IP's check in

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\Parameters\PersistentRoutes

and delete the any PersistentRoutes (do not delete the key) then re-add your IP and gateway settings.



#3 OP Skiver

Skiver

    Neowinian Senior

  • Tech Issues Solved: 2
  • Joined: 10-October 05
  • Location: UK, Reading

Posted 07 October 2013 - 15:31

 

Remove the gateway IP and the two IP's check in

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\Parameters\PersistentRoutes

and delete the any PersistentRoutes (do not delete the key) then re-add your IP and gateway settings.

 

Damn I wish I had spotted this and tried it - It was a VM and I ended up removing the NIC and re-adding it with the same settings and so far the issue hasn't re-appeared. I'll keep this in mind though if it does!